summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-11-25 16:01:14 +0100
committerAgostino Sarubbo <ago@gentoo.org>2021-11-25 16:01:14 +0100
commit315aa0c533593e799c001d56f2d29c4afd2d1917 (patch)
treed601647ab569e55b8bfb0bc00301243cdd0552b0 /app-admin/exo
parentmedia-libs/pnglite: update SRC_URI (diff)
downloadgentoo-315aa0c533593e799c001d56f2d29c4afd2d1917.tar.gz
gentoo-315aa0c533593e799c001d56f2d29c4afd2d1917.tar.bz2
gentoo-315aa0c533593e799c001d56f2d29c4afd2d1917.zip
app-admin/exo: version bump to 1.47.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/exo')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.47.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index 4a615f801d4c..78dfe1389666 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.47.1.tar.gz 5554646 BLAKE2B 609e64a380145160ee849c9338f87db2e1f0866006e1bf0e567447035b39660872b173bfa38c0d101ceb990dacbabb7d5e3364bef37d363be8f0028fa0465741 SHA512 b4806ff23e00ba35bb284add105f2e8c38ea3006a195976447b87c57c8680076a7b5414c4ac12fe301da28bf32c6ae6d05ba3e9aad2995cb216997e90ba67133
+DIST exo-1.47.2.tar.gz 5553730 BLAKE2B 2e5b6b67f148c35978ec0c81c80c839cff22168d0d509e009784555e6eb91e36d629126844714fd9c2b5011f9dc84c7d57236f59b473d079e651d5645984e5be SHA512 00f25b403d4aafd32a5fc1a8d46898b1c58b6a491b83f3f282e3b9d0742b54959e988aceda8262a7379f5ca683cab9dc3c3a547e7b9700ce0fa0f777d71a1935
diff --git a/app-admin/exo/exo-1.47.2.ebuild b/app-admin/exo/exo-1.47.2.ebuild
new file mode 100644
index 000000000000..49b1772f318b
--- /dev/null
+++ b/app-admin/exo/exo-1.47.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns."
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}