summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-09-17 23:22:43 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-09-17 23:54:59 -0500
commit9b6399b82861fea546adffc3b0673b15226dadb7 (patch)
tree260864d72b4918a8216d9c4c41c006a9f37c5dea /app-admin/glance
parentsys-cluster/cinder: update init script (diff)
downloadgentoo-9b6399b82861fea546adffc3b0673b15226dadb7.tar.gz
gentoo-9b6399b82861fea546adffc3b0673b15226dadb7.tar.bz2
gentoo-9b6399b82861fea546adffc3b0673b15226dadb7.zip
app-admin/glance: update init script one last time
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-admin/glance')
-rw-r--r--app-admin/glance/files/glance.initd-215
-rw-r--r--app-admin/glance/glance-15.0.0.ebuild4
-rw-r--r--app-admin/glance/glance-2017.2.9999.ebuild4
3 files changed, 17 insertions, 6 deletions
diff --git a/app-admin/glance/files/glance.initd-2 b/app-admin/glance/files/glance.initd-2
new file mode 100644
index 000000000000..4d4849f77e78
--- /dev/null
+++ b/app-admin/glance/files/glance.initd-2
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Starts ${SVCNAME} service for OpenStack"
+
+command=/usr/bin/${RC_SVCNAME}
+command_user="${GLANCE_USER:-glance}"
+command_background=yes
+pidfile=/run/${RC_SVCNAME}.pid
+required_files=/etc/glance/${RC_SVCNAME}.conf
+
+depend() {
+ need net
+}
diff --git a/app-admin/glance/glance-15.0.0.ebuild b/app-admin/glance/glance-15.0.0.ebuild
index 495638699ed5..9bea9ce0a554 100644
--- a/app-admin/glance/glance-15.0.0.ebuild
+++ b/app-admin/glance/glance-15.0.0.ebuild
@@ -125,9 +125,7 @@ python_compile_all() {
python_install_all() {
distutils-r1_python_install_all
- for svc in api glare registry scrubber; do
- newinitd "${FILESDIR}/glance.initd-r2" glance-${svc}
- done
+ newinitd "${FILESDIR}/glance.initd-2" glance-api
diropts -m 0750 -o glance -g glance
dodir /var/log/glance /var/lib/glance/images /var/lib/glance/scrubber
diff --git a/app-admin/glance/glance-2017.2.9999.ebuild b/app-admin/glance/glance-2017.2.9999.ebuild
index c65b743b462c..71b923e6de69 100644
--- a/app-admin/glance/glance-2017.2.9999.ebuild
+++ b/app-admin/glance/glance-2017.2.9999.ebuild
@@ -126,9 +126,7 @@ python_compile_all() {
python_install_all() {
distutils-r1_python_install_all
- for svc in api glare registry scrubber; do
- newinitd "${FILESDIR}/glance.initd-r2" glance-${svc}
- done
+ newinitd "${FILESDIR}/glance.initd-2" glance-api
diropts -m 0750 -o glance -g glance
dodir /var/log/glance /var/lib/glance/images /var/lib/glance/scrubber