summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2023-08-28 14:09:42 +0200
committerAgostino Sarubbo <ago@gentoo.org>2023-08-28 14:09:42 +0200
commitff35d2c45a87c7defea027afadee6ea80f63e2e4 (patch)
tree82c8a0c33e169e41c1432fd09c4263a5e63eed96 /app-admin/hcloud/hcloud-1.37.0.ebuild
parentapp-admin/exo: remove old (diff)
downloadgentoo-ff35d2c45a87c7defea027afadee6ea80f63e2e4.tar.gz
gentoo-ff35d2c45a87c7defea027afadee6ea80f63e2e4.tar.bz2
gentoo-ff35d2c45a87c7defea027afadee6ea80f63e2e4.zip
app-admin/hcloud: version bump to 1.37.0
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/hcloud/hcloud-1.37.0.ebuild')
-rw-r--r--app-admin/hcloud/hcloud-1.37.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/hcloud/hcloud-1.37.0.ebuild b/app-admin/hcloud/hcloud-1.37.0.ebuild
new file mode 100644
index 000000000000..c7dcd8ef353e
--- /dev/null
+++ b/app-admin/hcloud/hcloud-1.37.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A command-line interface for Hetzner Cloud"
+HOMEPAGE="https://github.com/hetznercloud/cli"
+SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND=">=dev-lang/go-1.18:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+src_compile() {
+ go build -mod vendor -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/internal/version.Version=${PV}-gentoo" ./cmd/${PN} || die "build failed"
+}
+
+src_test() {
+ # For upstream a simple test is run 'hcloud version'
+ ./hcloud version
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}