summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2023-11-27 16:57:43 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-12-13 09:04:41 +0100
commitf7ad25fffac9cfb7ee551f8cd953da74c5510913 (patch)
treeb36623c1360b008efe4f42ccf85c83fcb6929549 /app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild
parentapp-admin/ryzen_monitor: add myself as maintainer (diff)
downloadgentoo-f7ad25fffac9cfb7ee551f8cd953da74c5510913.tar.gz
gentoo-f7ad25fffac9cfb7ee551f8cd953da74c5510913.tar.bz2
gentoo-f7ad25fffac9cfb7ee551f8cd953da74c5510913.zip
app-admin/ryzen_monitor: add 1.0.5-r1, 1.0.6_pre20220901
- Added remote-id to metadata.xml. - Added -1.0.5-r1 which uses code from ryzen_smu-0.1.5 to work with the kernel module created by it (see https://github.com/hattedsquirrel/ryzen_monitor/issues/25). The source archive already contains a copy of ryzen_smu-0.1.2, which get's replaced with the current ryzen_smu version. ryzen_smu is needed to run ryzen_monitor so the source archive should always be present. - Added -1.0.6_pre snapshot from latest commit with improved Cezanne support Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34019 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild')
-rw-r--r--app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild b/app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..13583265e579
--- /dev/null
+++ b/app-admin/ryzen_monitor/ryzen_monitor-1.0.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+SMU_PN="ryzen_smu"
+SMU_PV="0.1.5"
+inherit toolchain-funcs
+
+DESCRIPTION="Monitor power information of Ryzen processors via the PM table of the SMU"
+HOMEPAGE="https://github.com/hattedsquirrel/ryzen_monitor"
+SRC_URI="
+ https://github.com/hattedsquirrel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://gitlab.com/leogx9r/${SMU_PN}/-/archive/v${SMU_PV}/${SMU_PN}-v${SMU_PV}.tar.bz2
+"
+
+LICENSE="AGPL-3 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-admin/ryzen_smu"
+
+src_unpack() {
+ unpack "${P}.tar.gz" "${SMU_PN}-v${SMU_PV}.tar.bz2"
+}
+
+src_prepare() {
+ rm "src/lib/"* || die
+ cp -a "${WORKDIR}/${SMU_PN}-v${SMU_PV}/lib/libsmu."{c,h} "src/lib/" || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin src/ryzen_monitor
+}