summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-03-10 09:55:29 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-03-10 09:55:55 -0600
commit15666b29281cb4254e684be0bc37fc4fa6062eb2 (patch)
tree6beaac3fc78ffa786627bb751dfbaed83324b829 /app-admin
parentdev-python/pytest-pythonpath: Add python3_5 (diff)
downloadgentoo-15666b29281cb4254e684be0bc37fc4fa6062eb2.tar.gz
gentoo-15666b29281cb4254e684be0bc37fc4fa6062eb2.tar.bz2
gentoo-15666b29281cb4254e684be0bc37fc4fa6062eb2.zip
app-admin/puppet-agent: 1.9.3 bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.9.3.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index f08cdbbc74c2..e5ac3adccd34 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -10,3 +10,5 @@ DIST puppet-agent_1.9.1-1xenial_amd64.deb 15458462 SHA256 ed7a124842b48a3ec16875
DIST puppet-agent_1.9.1-1xenial_i386.deb 16870810 SHA256 6739a03ab3ffa69680c84aed79f50e3e0383a50055b1e5f5545a24aec68c3791 SHA512 421b32d2eba33af0bbbbbd41f3615222c1907107023f6cb80bb23a9378f5ba9cc26bac24749c611cc41fc52bca25df92377ba76cfd2d09d1328067138d2a8db3 WHIRLPOOL e9abd1b50856577e7892511b94f9ca64b023f41ff39c6fd106874305380522cf7fd98e0d659eb896d400fd8865510dec7144a7915fa4f3bb069069d74302612f
DIST puppet-agent_1.9.2-1xenial_amd64.deb 15684862 SHA256 97d5cbe6743c7d9dd67289fda74795e4c82b45464560606654c26eea78a72872 SHA512 9a1cb959e174992b1dfc51db5c4c75f0a855469caa41d3e9f8da9c8cbf0b987f222d0cf2105df37a61edc190633f9407f7717379124619dab8650df9ae356f16 WHIRLPOOL e8ddebcab3ae8ba4429c0855792f0b35043cce4d9d10bfc18e0b1a73c1eb43894b54c8743739d8c6b3d2b174684af6b9b620dc7863ea34ccfe9ec475b112247a
DIST puppet-agent_1.9.2-1xenial_i386.deb 16767542 SHA256 5cb35fd22ab2922963192120d3f48d9a92fa7c3b1d25d80c8f0c4c92269cc62a SHA512 7f2e0277ba074b532bcf95e21b4faac7b6699b133202b3abd004337de3a9d3f07e3ed0213c125552878d75d642f7d824ac73314cf83da1ede943e930062aa824 WHIRLPOOL fd200eec4d71331d7b199b1b32c8c8b27d9375f2747c3b871c72bddb2d3a867cb9d46921c052dac72fba4add67aab57b710d4638136d580653d79539f5d69a8e
+DIST puppet-agent_1.9.3-1xenial_amd64.deb 16045528 SHA256 db73567754514595b729c299bea34289fbf108282dcc3ca2b2bda8946b1a9b01 SHA512 1142bb008569ebd26e70c89705539eee89ef1d886fee9c18ee19b563ba280c96295a77b30af2c3b149e2e8fb5cd953f55300d3c3bea1d63cb4e6a4c4103a1cfb WHIRLPOOL 193d8ece0997c66f0e0a0c70df6e41243fabbda7bdc944f1c9940476e7cfa01bbff80e739cd5e3b95d4027b8d13b3186823b2035251c57c69a7a2e188c4a5801
+DIST puppet-agent_1.9.3-1xenial_i386.deb 16072786 SHA256 eb9476d55cc769608a3b5a3a971a4c005ae1042c0f3f3f5748b14aa40b6251ea SHA512 b9bb7579fc3106b0b701ef2cdac9dc72a5e663b360e7e10816698fed85337c9aa0b77b392353d70682f2cea057d52ebf1c356474e9ec6ccd8e85302d938666af WHIRLPOOL 2acdd44be0fa1665be34f10d3967185acf49388460af6291ac9cb53c7296af78630d82e6c3fce456bdfd7fbd06d1956d9c592ad17dc0f1cf2ee0aa9c008965ef
diff --git a/app-admin/puppet-agent/puppet-agent-1.9.3.ebuild b/app-admin/puppet-agent/puppet-agent-1.9.3.ebuild
new file mode 100644
index 000000000000..2d099b35fe06
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.9.3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/xenial/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1xenial"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/glibc
+ >=sys-libs/readline-6.0
+ <sys-libs/readline-7.0
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/mcollective.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}