summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-04 17:44:15 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-04 19:25:30 +0300
commit1e9b828dd48c64379c219a829b981440c6ad475b (patch)
tree470d63aa486e1a89c85c4d0910f6fc214b4479eb /app-admin
parentdev-python/boto3: add 1.24.45 (diff)
downloadgentoo-1e9b828dd48c64379c219a829b981440c6ad475b.tar.gz
gentoo-1e9b828dd48c64379c219a829b981440c6ad475b.tar.bz2
gentoo-1e9b828dd48c64379c219a829b981440c6ad475b.zip
app-admin/awscli: add 1.25.45
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.45.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 6591aec49c76..dabdcbe0aac1 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.25.41.gh.tar.gz 2238897 BLAKE2B b0e4d1b96048971f41a0fce9c91491547
DIST aws-cli-1.25.42.gh.tar.gz 2239243 BLAKE2B 081535dbe7dac01101b570ef319af9c1bfff6ac1eb1dd000d9f15906a1538682dd77c9d6c78ee38db0f103c3681b9a9b2fb3954be0e5f6a11dcd16e54c33b79f SHA512 6d771f4e4235da349905ef0df1a5b118877425e9192ae5eac3b711c63a4ef80c491476d6a14440af19bae01e51c7a86fb6dd0efe976d11fa0bec2d526ba0e0b1
DIST aws-cli-1.25.43.gh.tar.gz 2239407 BLAKE2B cad8350671679b1314f22ed0a21b1933b7fb960549b16d1ec60ff6e2bdaf91f943fe108f54521a538cfe558aa7185aeaf82b353da4b83026856578df1cb70d13 SHA512 e62ead7f3e1d8edef20bc8781304a3cec507807c919f70ae0dd59634e9d5af271e040d05117739eeca48d148b7d89d7afb3798a8bae7a26def343fcf419e31dc
DIST aws-cli-1.25.44.gh.tar.gz 2239578 BLAKE2B 26a8fda0d12f4b46cf82189c02cc6a17be25e7c2bb2de82821ed6f93e4d02c8c178eaea1eb67fec3c3c012fd3cd2368f3e969c7eb69f40de94c56f58a79fe649 SHA512 08982c0c74028513a7bbf7141fe3b4896f2dd32dfcaf25f1a959feaa0ed0456fe39a5548324c928bc8b75aa7d5360fcf2d647b5f9797695701f6bd2a8d6575b4
+DIST aws-cli-1.25.45.gh.tar.gz 2239771 BLAKE2B eeddfbbd02da47965255319385c7579d39de76d3bd173c4bc7010f68cb4ebfdfce1133c0a1f3db0a0dba8312e70865bf34b7fe32bceb16b022cc1e8efe86d816 SHA512 f93ad04b8766348ff0d61ec468bc9a805917c94a8edc566456f944747cdb269873da9c200c7f5318a513b9c42bf459db190d3eaeb24aee4b373144eda41df050
diff --git a/app-admin/awscli/awscli-1.25.45.ebuild b/app-admin/awscli/awscli-1.25.45.ebuild
new file mode 100644
index 000000000000..9f176fa05cc8
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.45.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}