summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-07-19 12:46:43 +0200
committerUltrabug <ultrabug@gentoo.org>2018-08-02 09:30:53 +0200
commit56192c875c9139eee2bd13e85928efe499d5c01f (patch)
treee18eaa1aae45953bb9c3f7626e126b70da03e3c6 /app-admin
parentapp-admin/mongo-tools: bump to 3.6.6 (diff)
downloadgentoo-56192c875c9139eee2bd13e85928efe499d5c01f.tar.gz
gentoo-56192c875c9139eee2bd13e85928efe499d5c01f.tar.bz2
gentoo-56192c875c9139eee2bd13e85928efe499d5c01f.zip
dev-db/mongodb: bump to 3.6.6
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.4.16.ebuild18
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.6.6.ebuild20
2 files changed, 19 insertions, 19 deletions
diff --git a/app-admin/mongo-tools/mongo-tools-3.4.16.ebuild b/app-admin/mongo-tools/mongo-tools-3.4.16.ebuild
index 509a9eb6a0ed..5efc22cf1e80 100644
--- a/app-admin/mongo-tools/mongo-tools-3.4.16.ebuild
+++ b/app-admin/mongo-tools/mongo-tools-3.4.16.ebuild
@@ -27,32 +27,32 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
default
- # do not substitute version because it uses git
- sed -i '/^sed/,+3d' build.sh || die
- sed -i '/^mv/d' build.sh || die
+ # 1) ensure we use bash wrt #582906
+ # 2) do not substitute version because it uses git
+ sed -e 's@/bin/sh@/bin/bash@g' \
+ -e '/^sed/,+3d' \
+ -e '/^mv/d' \
+ -i build.sh || die
# build pie to avoid text relocations wrt #582854
# skip on ppc64 wrt #610984
if ! use ppc64; then
sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
fi
-
- # ensure we use bash wrt #582906
- sed -i 's@/bin/sh@/bin/bash@g' build.sh || die
}
src_compile() {
local myconf=()
if use sasl; then
- myconf+=(sasl)
+ myconf+=(sasl)
fi
if use ssl; then
- myconf+=(ssl)
+ myconf+=(ssl)
fi
- ./build.sh ${myconf[@]} || die "build failed"
+ ./build.sh "${myconf[@]}" || die "build failed"
}
src_install() {
diff --git a/app-admin/mongo-tools/mongo-tools-3.6.6.ebuild b/app-admin/mongo-tools/mongo-tools-3.6.6.ebuild
index 3589981cbd8e..47f22a423a83 100644
--- a/app-admin/mongo-tools/mongo-tools-3.6.6.ebuild
+++ b/app-admin/mongo-tools/mongo-tools-3.6.6.ebuild
@@ -27,33 +27,33 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
default
- # do not substitute version because it uses git
- sed -i '/^sed/,+3d' build.sh || die
- sed -i '/^stty/d' build.sh || die
- sed -i '/^mv/d' build.sh || die
+ # 1) ensure we use bash wrt #582906
+ # 2) do not substitute version because it uses git
+ sed -e 's@/bin/sh@/bin/bash@g' \
+ -e '/^sed/,+3d' \
+ -e '/^stty/d' \
+ -e '/^mv/d' \
+ -i build.sh || die
# build pie to avoid text relocations wrt #582854
# skip on ppc64 wrt #610984
if ! use ppc64; then
sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
fi
-
- # ensure we use bash wrt #582906
- sed -i 's@/bin/sh@/bin/bash@g' build.sh || die
}
src_compile() {
local myconf=()
if use sasl; then
- myconf+=(sasl)
+ myconf+=(sasl)
fi
if use ssl; then
- myconf+=(ssl)
+ myconf+=(ssl)
fi
- ./build.sh ${myconf[@]} || die "build failed"
+ ./build.sh "${myconf[@]}" || die "build failed"
}
src_install() {