summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-17 05:08:18 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-17 05:08:18 +0100
commit946ebf1a07bbb9247860ce60089d632aeb0c5a03 (patch)
tree254170f6b4d121af2350074cb0d34a8d90d750b7 /app-admin
parentdev-python/boto3: Bump to 1.26.93 (diff)
downloadgentoo-946ebf1a07bbb9247860ce60089d632aeb0c5a03.tar.gz
gentoo-946ebf1a07bbb9247860ce60089d632aeb0c5a03.tar.bz2
gentoo-946ebf1a07bbb9247860ce60089d632aeb0c5a03.zip
app-admin/awscli: Bump to 1.27.93
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.93.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 8ad70351b164..20d3450fa6d5 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -9,3 +9,4 @@ DIST aws-cli-1.27.89.gh.tar.gz 2382599 BLAKE2B 3a2dae3cc1928e149dd605de1e9a35098
DIST aws-cli-1.27.90.gh.tar.gz 2383305 BLAKE2B c67abc7d2c7e09bbbcc34bd07f2aebc76e9b03904b9e5ce6fe5569f2f1ba0341c4b7cf6dfe8cec6fc1840a5567bfde1f073d3a91ae1443c1354648fd6b330b34 SHA512 f6391afff00a53d998cffa000b309587e3bb50ca0d526f0979a2a2cf1303186400428eb10a9c09cb139ac2428717f8e8c76c72b4243943426afef77e188f0167
DIST aws-cli-1.27.91.gh.tar.gz 2384591 BLAKE2B ca80ec0bbbb96168f959cfef9e134a72cff8cad57e2e694cbf3a239c68c0ddcafa2a6fbdf6e02c9dcb601165df6597976d0097be820eedbc6977dfc56146d31a SHA512 310b14d4d21ffbc41ae0c205810f308e99a9d2110415e32236c9dacf1f288e62a79367db16b2acc794175e6a37764154d8923d8291dbbb2ecb5ab43c54dbfd5f
DIST aws-cli-1.27.92.gh.tar.gz 2384667 BLAKE2B e7cf1485ef7c3a1fd31532482b555ceb73317a124150d4953b4ee3c2ef94ceb7677910b2c27edb06cea4ef5340638e3763d06e1b76385160e79f9c09802f7148 SHA512 94494273da5dcd80d03db42bee81974ce8843f883dfc434013938a4b817e2c441d21de4f3c5902de542c82f081b4478442a4251d51c1d84dadd1db90b1f1e2b5
+DIST aws-cli-1.27.93.gh.tar.gz 2385084 BLAKE2B 18dc59339303b9f32e297ca6a37c5d2a9466a2ac2b2f8795baeb686465dfe561ecb5abb29c38d37f32f44408b9ff1e083c330fbe23a5bf3c19a05033993dc533 SHA512 ce979f35966f2c48d8bf74ed95d27e5d6de9e33990bc01556bba660fd5692dd3751002d1dafbba11121e768a21d97130d9e76d309640ade5377193ba79ba1628
diff --git a/app-admin/awscli/awscli-1.27.93.ebuild b/app-admin/awscli/awscli-1.27.93.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.93.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}