summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-03-06 15:47:49 -0500
committerCraig Andrews <candrews@gentoo.org>2018-03-06 15:51:34 -0500
commite5ac8f8157f47c79e625eb9f78b0452a8f5445f4 (patch)
treeca0442a5bdc88d671049e46fa5f0b6d0805817fe /app-arch/brotli/brotli-9999.ebuild
parentdev-php/geos-php: Add extension split off from sci-libs/geos (diff)
downloadgentoo-e5ac8f8157f47c79e625eb9f78b0452a8f5445f4.tar.gz
gentoo-e5ac8f8157f47c79e625eb9f78b0452a8f5445f4.tar.bz2
gentoo-e5ac8f8157f47c79e625eb9f78b0452a8f5445f4.zip
app-arch/brotli: Use only the major version as the subslot
This change prevents unnecessary rebuilds due to subslot changes Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-arch/brotli/brotli-9999.ebuild')
-rw-r--r--app-arch/brotli/brotli-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-arch/brotli/brotli-9999.ebuild b/app-arch/brotli/brotli-9999.ebuild
index f437159d3521..98869f75b246 100644
--- a/app-arch/brotli/brotli-9999.ebuild
+++ b/app-arch/brotli/brotli-9999.ebuild
@@ -6,12 +6,12 @@ EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
DISTUTILS_OPTIONAL="1"
-inherit cmake-utils distutils-r1
+inherit cmake-utils distutils-r1 eapi7-ver
DESCRIPTION="Generic-purpose lossless compression algorithm"
HOMEPAGE="https://github.com/google/brotli"
-SLOT="0/${PV}"
+SLOT="0/$(ver_cut 1)"
RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"