summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2023-08-12 08:49:57 +0200
committerSam James <sam@gentoo.org>2023-08-17 07:22:38 +0100
commit9ccab744fc1ae781582585a716cf18a2dfa4f785 (patch)
tree08395db13100e2ef7566364da440884ee0f48b32 /app-arch/engrampa
parentdev-libs/libmateweather: add 1.26.1 (diff)
downloadgentoo-9ccab744fc1ae781582585a716cf18a2dfa4f785.tar.gz
gentoo-9ccab744fc1ae781582585a716cf18a2dfa4f785.tar.bz2
gentoo-9ccab744fc1ae781582585a716cf18a2dfa4f785.zip
app-arch/engrampa: add 1.26.1
Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/engrampa')
-rw-r--r--app-arch/engrampa/Manifest1
-rw-r--r--app-arch/engrampa/engrampa-1.26.1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-arch/engrampa/Manifest b/app-arch/engrampa/Manifest
index f0088d97f1eb..84bac8f31c37 100644
--- a/app-arch/engrampa/Manifest
+++ b/app-arch/engrampa/Manifest
@@ -1 +1,2 @@
DIST engrampa-1.26.0.tar.xz 1761596 BLAKE2B c72def523f6589ab97351568e0562898d996e640ffefa66f32096e5a0ad97ad0b05b21ebdcc16ba1f75d9b75a444f8ed4ed492a412cc16c018e65135a88f3398 SHA512 8058627af19744d26f0997fca37a9a1d9902c63e4008e1af44b2a3b15ebc03e27f2018c60351ee503a28aa072836d201625074abb838e0a95071ce65c64a52bc
+DIST engrampa-1.26.1.tar.xz 1792452 BLAKE2B ff87f21848919654a2392c02e6050ac0b4c80308361ec7c829a2acf3fb25b088e164a3722be0312b2c814022bf0e06c80ae0796add182e6ac8e5d696409c5afe SHA512 6e3e59503d3d55df3eddc63f5f8f67c80a84b2b602801f9bcbaf4e38b6e991fffaa879e1cd44c1173b5c11096587122438bda51401c2694654c99b87a52b9f5e
diff --git a/app-arch/engrampa/engrampa-1.26.1.ebuild b/app-arch/engrampa/engrampa-1.26.1.ebuild
new file mode 100644
index 000000000000..c3fde5887419
--- /dev/null
+++ b/app-arch/engrampa/engrampa-1.26.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mate-desktop/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/mate-desktop/${PN}/archive/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+inherit mate optfeature
+
+DESCRIPTION="Engrampa archive manager for MATE"
+HOMEPAGE="https://mate-desktop.org/ https://github.com/mate-desktop/engrampa"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="caja magic"
+
+DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/json-glib-0.14
+ virtual/libintl
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[X]
+ x11-libs/libSM
+ x11-libs/pango
+ caja? ( >=mate-base/caja-1.17.1 )
+ magic? ( sys-apps/file )
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/libintl
+"
+BDEPEND="
+ app-text/yelp-tools
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.26.0-clang16.patch
+)
+
+src_configure() {
+ mate_src_configure \
+ --disable-run-in-place \
+ $(use_enable caja caja-actions) \
+ $(use_enable magic) \
+ --disable-packagekit
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+
+ optfeature "Support for 7-zip" app-arch/p7zip
+ optfeature "Support for ace" app-arch/unace
+ optfeature "Support for arj" app-arch/arj
+ optfeature "Support for cpio" app-arch/cpio
+ optfeature "Support for deb" app-arch/dpkg
+ optfeature "Support for iso" app-cdr/cdrtools
+ optfeature "Support for jar,zip" app-arch/zip app-arch/unzip
+ optfeature "Support for lha" app-arch/lha
+ optfeature "Support for lzma" app-arch/xz-utils
+ optfeature "Support for lzop" app-arch/lzop
+ optfeature "Support for rar" app-arch/unrar
+ optfeature "Support for rpm" app-arch/rpm
+ optfeature "Support for unstuff" app-arch/stuffit
+ optfeature "Support for zoo" app-arch/zoo
+}