summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/freeze/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/freeze/files')
-rw-r--r--app-arch/freeze/files/freeze-2.5.0-gentoo.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-arch/freeze/files/freeze-2.5.0-gentoo.patch b/app-arch/freeze/files/freeze-2.5.0-gentoo.patch
new file mode 100644
index 000000000000..3be357c25309
--- /dev/null
+++ b/app-arch/freeze/files/freeze-2.5.0-gentoo.patch
@@ -0,0 +1,55 @@
+--- a/Makefile.in 1999-05-20 11:07:51.000000000 +0200
++++ b/Makefile.in 2012-12-12 17:22:36.444775985 +0100
+@@ -3,7 +3,7 @@
+ VPATH = $(srcdir)
+
+ CC = @CC@
+-CFLAGS = -I. # -O2 # for gcc 2.2.2
++CFLAGS += -I.
+
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+@@ -79,15 +79,15 @@
+
+ freeze$(EXE): $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+- -strip $@
++
+
+ statist$(EXE): statist.$(OBJ) lz.$(OBJ)
+ $(CC) $(LDFLAGS) -o $@ statist.$(OBJ) lz.$(OBJ) $(LIBS)
+- -strip $@
++
+
+ showhuf$(EXE): showhuf.$(OBJ)
+ $(CC) $(LDFLAGS) -o $@ showhuf.$(OBJ) $(LIBS)
+- -strip $@
++
+
+ clobber: clean
+ rm -f freeze$(EXE) statist$(EXE) showhuf$(EXE) *.man \#* *~ config.h Makefile
+@@ -101,18 +101,18 @@
+
+ $(DEST)/freeze: freeze
+ $(INSTALL_PROGRAM) freeze $@
+- -ln -f $@ $(DEST)/melt
+- -ln -f $@ $(DEST)/unfreeze
+- -ln -f $@ $(DEST)/fcat
++ ln -sf $< $(DEST)/melt
++ ln -sf $< $(DEST)/unfreeze
++ ln -sf $< $(DEST)/fcat
+
+ $(DEST)/statist: statist
+ $(INSTALL_PROGRAM) statist $@
+
+ $(MANDEST)/freeze.$(SEC): freeze.1
+ $(INSTALL_DATA) $(srcdir)/freeze.1 $@
+- -ln -f $@ $(MANDEST)/melt.$(SEC)
+- -ln -f $@ $(MANDEST)/unfreeze.$(SEC)
+- -ln -f $@ $(MANDEST)/fcat.$(SEC)
++ ln -sf $< $(MANDEST)/melt.$(SEC)
++ ln -sf $< $(MANDEST)/unfreeze.$(SEC)
++ ln -sf $< $(MANDEST)/fcat.$(SEC)
+ # This is much better for places which keep preformated manpages.
+ # echo ".so man1/freeze.$(SEC)" > $(MANDEST)/melt.$(SEC)
+ # echo ".so man1/freeze.$(SEC)" > $(MANDEST)/unfreeze.$(SEC)