summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-10-11 19:42:34 +0200
committerMatt Turner <mattst88@gentoo.org>2022-10-13 21:21:29 -0400
commitad2ed8a2af8b004bf6349fe31a8e60ec9916e5f3 (patch)
treebd544b5bf01ec3ed306fd7401a8d78468ce2b611 /app-backup/deja-dup/deja-dup-43.4-r1.ebuild
parentapp-backup/duplicity: change SRC_URI to pythonhosted.org (diff)
downloadgentoo-ad2ed8a2af8b004bf6349fe31a8e60ec9916e5f3.tar.gz
gentoo-ad2ed8a2af8b004bf6349fe31a8e60ec9916e5f3.tar.bz2
gentoo-ad2ed8a2af8b004bf6349fe31a8e60ec9916e5f3.zip
app-backup/deja-dup: remove dep on <app-backup/duplicity-1.0.0
Bug: https://bugs.gentoo.org/876781 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/27742 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-backup/deja-dup/deja-dup-43.4-r1.ebuild')
-rw-r--r--app-backup/deja-dup/deja-dup-43.4-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-backup/deja-dup/deja-dup-43.4-r1.ebuild b/app-backup/deja-dup/deja-dup-43.4-r1.ebuild
new file mode 100644
index 000000000000..53f1ed16bfed
--- /dev/null
+++ b/app-backup/deja-dup/deja-dup-43.4-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson gnome2-utils vala xdg
+
+DESCRIPTION="Simple backup tool using duplicity back-end"
+HOMEPAGE="https://wiki.gnome.org/Apps/DejaDup"
+SRC_URI="https://gitlab.gnome.org/World/deja-dup/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ $(vala_depend)
+ dev-util/intltool
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-libs/appstream-glib )
+"
+
+DEPEND="
+ >=gui-libs/libadwaita-1.0:1
+ >=dev-libs/glib-2.70.0:2
+ >=dev-libs/libgpg-error-1.33
+ >=gui-libs/gtk-4.6:4
+ >=dev-libs/json-glib-1.2
+ >=dev-libs/glib-2.64:2[dbus]
+ >=app-crypt/libsecret-0.18.6[vala]
+ >=net-libs/libsoup-3.0:3.0
+ >=app-backup/duplicity-0.8.21
+"
+
+RDEPEND="${DEPEND}
+ gnome-base/dconf
+ gnome-base/gvfs[fuse]
+"
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}