summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 22:41:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 08:55:11 +0100
commit4d022576a3ba63fb660279f23189f3cc47da1f17 (patch)
treea2267d8d6f9b531978fe6501a2827463388e7ea0 /app-backup
parentapp-backup/backintime: EAPI-7, xdg, fix QA, add missing PyQt5 RDEPENDs (diff)
downloadgentoo-4d022576a3ba63fb660279f23189f3cc47da1f17.tar.gz
gentoo-4d022576a3ba63fb660279f23189f3cc47da1f17.tar.bz2
gentoo-4d022576a3ba63fb660279f23189f3cc47da1f17.zip
app-backup/backintime: 1.2.1 version bump
Closes: https://bugs.gentoo.org/696240 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/backintime/Manifest1
-rw-r--r--app-backup/backintime/backintime-1.2.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-backup/backintime/Manifest b/app-backup/backintime/Manifest
index 3936cd8d65ec..bf5f9506312a 100644
--- a/app-backup/backintime/Manifest
+++ b/app-backup/backintime/Manifest
@@ -1 +1,2 @@
DIST backintime-1.2.0_pre20180221.tar.gz 712330 BLAKE2B 9ba40c5f89b9fbdf0b1c381bf2e3edce13553b2c301792627fc037bd2de181804b2dc6cad6e78a02844f8835dcd6415a35590125e832d55187fa2ed1a5fa864b SHA512 ad1bb11ea411904027952809c577de1a5317f40430af9b91b16a2c157d560c72b65c879bb880b557e9b5e333e76a44977a26486f4ed4f45281a5e8b0d4583c2a
+DIST backintime-1.2.1.tar.gz 713853 BLAKE2B 0f05d6cdc04a41ec9737badb8693c1270bb1333b2986fce925625ba2d7be05de0630ff5f59a7b5854a38ba382d6992df1ffc4e1cb584cae0e2618b877db4f06b SHA512 91dbc76a7db81469c5a538be03196c8e307d13307486d8e1c6cad10ce0af399de495f0292fecffc2853ed78804b5899750f06f274b4701efe3af6a708ea1024e
diff --git a/app-backup/backintime/backintime-1.2.1.ebuild b/app-backup/backintime/backintime-1.2.1.ebuild
new file mode 100644
index 000000000000..c3cef948142f
--- /dev/null
+++ b/app-backup/backintime/backintime-1.2.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
+HOMEPAGE="https://backintime.readthedocs.io/en/latest/ https://github.com/bit-team/backintime/"
+SRC_URI="https://github.com/bit-team/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples qt5"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ net-misc/openssh
+ net-misc/rsync[xattr,acl]
+"
+RDEPEND="${DEPEND}
+ qt5? ( dev-python/PyQt5[gui,widgets] )
+"
+
+PATCHES=( "${FILESDIR}/${P}-no-compress-docs-examples.patch" )
+
+src_configure() {
+ pushd common > /dev/null || die
+ ./configure --python3 --no-fuse-group || die
+ popd > /dev/null || die
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ ./configure --python3 || die
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ pushd common > /dev/null || die
+ emake
+ popd > /dev/null || die
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ emake
+ popd > /dev/null || die
+ fi
+}
+
+src_install() {
+ pushd common > /dev/null || die
+ emake DESTDIR="${D}" install
+ popd > /dev/null || die
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ emake DESTDIR="${D}" install
+ popd > /dev/null || die
+ fi
+
+ einstalldocs
+ if use examples ; then
+ docinto examples
+ dodoc common/{config-example-local,config-example-ssh}
+ fi
+
+ python_optimize "${D}"
+}