summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-12-09 12:49:20 +0100
committerPetr Vaněk <arkamar@gentoo.org>2024-12-09 12:50:15 +0100
commit6347b9af18e73e1cc3ea0895f1ceceecffa0149f (patch)
treeda0836fcdc6b919cb1c337d127d3d3b85df65f6f /app-backup
parentdev-python/mysqlclient: Remove old (diff)
downloadgentoo-6347b9af18e73e1cc3ea0895f1ceceecffa0149f.tar.gz
gentoo-6347b9af18e73e1cc3ea0895f1ceceecffa0149f.tar.bz2
gentoo-6347b9af18e73e1cc3ea0895f1ceceecffa0149f.zip
app-backup/borgmatic: add 1.9.4
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.9.4.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index f6f0e8b7d254..2f3e1eb886d5 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,3 +1,4 @@
DIST borgmatic-1.8.14.tar.gz 623966 BLAKE2B fd52bc5be4f63e1207a0bedcf654af075082d31af76ddc65ea30a3259f1ec093c826612e114fd9f9fa46668f80eed3b2b6a88262fbb9e4db49c36ba31efa70c5 SHA512 74daecbf02f957b21121dff073c2e114c87b1afdf6b3408b8fc2bf465102425cca60e4bdc8bc8d0e2d0a9c20b1f514eb7c9a2e136e71cb61969e07a38841235a
DIST borgmatic-1.9.2.tar.gz 641879 BLAKE2B 0c1678c905235ee435fdeb7fc57eabb44054344fab596ecb17f5cbeb0a2afa944b3105b08c61547de853de561c58971a6d32ac677434475b38cc90af4600b88d SHA512 8226155f049141b80bed32f955faa37cd8d2c01489092510440c1f53247d1aabf7d8730aa8c22b20f16ffb5686b158966a544e2bea4558178ec52da187b18c13
DIST borgmatic-1.9.3.tar.gz 645018 BLAKE2B ae069bece54d80eab080cb30d4fb4b523cc7f31ca5d434a7f2fdfc8447ab72e6687fc6775a7811e15f120a0ad57284c539813c07b5cb258a2acf92e02dd55999 SHA512 22624e1a4454660288a3019513509006b389aafd657a45fa9e24c0b13b6a1266450c5b4ed531be5d8574c5f5fa5b869cb6860273f5d3d9a53b4e41474fb1b90e
+DIST borgmatic-1.9.4.tar.gz 635562 BLAKE2B aac7cea7c7b9537a1f13f6cdd5fc15c3a7d439f9c609a3b05aeb0c10a844f479f0f3a1ec9470283b38594646985cc87c45445602e264f2e8fbabb509691feab4 SHA512 db258ebaa87ac88873c73ab750b7f72278376679c3641c91f4d3565d690a9cb25be5df94bb94aead83f09b27a1d41edbb7e457261440c33fddc9fde3477e7006
diff --git a/app-backup/borgmatic/borgmatic-1.9.4.ebuild b/app-backup/borgmatic/borgmatic-1.9.4.ebuild
new file mode 100644
index 000000000000..c8ac8622d33f
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.9.4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="
+ https://torsion.org/borgmatic/
+ https://projects.torsion.org/borgmatic-collective/borgmatic
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="apprise"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="
+ app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ ')
+ apprise? ( $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ ') )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+ "${FILESDIR}"/${PN}-1.9.3-no_test_coverage.patch
+)
+
+EPYTEST_DESELECT=(
+ # A fragile test whose only purpose is to make sure the NEWS file
+ # has been updated for the current version.
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.9.0; then
+ ewarn "Please be warned that ${PN}-1.9.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.9.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+}