summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-23 14:59:21 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-23 16:11:57 +0100
commit7b259d60652e7f31e1d78b57c5c3917b8a7ca1b7 (patch)
treed1d99274a8f2fb6d38270bcbd88f55c1b0234827 /app-containers/devcontainer/devcontainer-0.54.0.ebuild
parentapp-emacs/helm: bump to 3.9.6 (diff)
downloadgentoo-7b259d60652e7f31e1d78b57c5c3917b8a7ca1b7.tar.gz
gentoo-7b259d60652e7f31e1d78b57c5c3917b8a7ca1b7.tar.bz2
gentoo-7b259d60652e7f31e1d78b57c5c3917b8a7ca1b7.zip
app-containers/devcontainer: bump to 0.54.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers/devcontainer/devcontainer-0.54.0.ebuild')
-rw-r--r--app-containers/devcontainer/devcontainer-0.54.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-containers/devcontainer/devcontainer-0.54.0.ebuild b/app-containers/devcontainer/devcontainer-0.54.0.ebuild
new file mode 100644
index 000000000000..399665b46cde
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.54.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}