summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-09-10 09:25:31 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-09-10 09:25:31 +0300
commit4320b09b549e88a2a1cf5a287d3a3616ecc472eb (patch)
treea7553c760d382f9c5683ecb1936a210821d92749 /app-containers/lxc
parentsys-devel/gcc: add 13.2.1_p20230909 (diff)
downloadgentoo-4320b09b549e88a2a1cf5a287d3a3616ecc472eb.tar.gz
gentoo-4320b09b549e88a2a1cf5a287d3a3616ecc472eb.tar.bz2
gentoo-4320b09b549e88a2a1cf5a287d3a3616ecc472eb.zip
app-containers/lxc: drop 5.0.2
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-containers/lxc')
-rw-r--r--app-containers/lxc/Manifest2
-rw-r--r--app-containers/lxc/files/lxc.initd.8131
-rw-r--r--app-containers/lxc/lxc-5.0.2.ebuild168
3 files changed, 0 insertions, 301 deletions
diff --git a/app-containers/lxc/Manifest b/app-containers/lxc/Manifest
index 110ca14bf5ce..49be2b841cfd 100644
--- a/app-containers/lxc/Manifest
+++ b/app-containers/lxc/Manifest
@@ -1,4 +1,2 @@
-DIST lxc-5.0.2.tar.gz 973977 BLAKE2B e6017406b96f53525b576528814922a017a7d65fb04724046236307f4e85219b3c8ac725678e57ae3f77a4e817f718748e8c61fbc8147160e4ac87d3146b6567 SHA512 2e8800875e9c91cc0cbfdfc33c43d84bad9471d8a1b8ccd52d7d9c6fe44f280f9f701b8ccc2e0f5319a3e4c50d8c4331722f0dd9c0347575eb4f7b4ed110bef3
-DIST lxc-5.0.2.tar.gz.asc 833 BLAKE2B 3d78f8a87b2f45d2b91a9a6595d286e2fc1dcfc7d28f3c1d86e968860a7e346506ab28d4dafffede8acf1f82e8b12f90eda2e6210cd6bdec702f59bad97295c6 SHA512 9bd1ef117cf256841b75d409e8f14b88ed54fdfc9c8c472b6baa5e9695e39cdb8c1f47ce612dc8263abb65511df0812554cc9a5820cdd6c1539a07283a4cd08f
DIST lxc-5.0.3.tar.gz 975269 BLAKE2B 533d97fe4d986acbf5d562bb2c295a63df2a9a8bfc27aeff5056e4235f667102500debc586c5698482ec048c1b222a0fdc234db6fd6648c4b649f87a85de18f8 SHA512 0553be317431ab7ec0c450c0f85724a53de1f251c39c9716168e17cda6a8daec70b8221228c4be64027df28a327e0f1fd508e6bb48348ab540bbfeaf2b9ac974
DIST lxc-5.0.3.tar.gz.asc 833 BLAKE2B c35278ed17cad76d2ea94b3985e0110731efea751fb5f1c2d1c9db71486e4844285f372a94c8611dcfe91fdb16459694843b9e0a8273cfc68a56f549c7162cfb SHA512 a5ce5769d49abdf35d94de8273fd3e9c2a8ba4fafea71cf33ee6bce1d83531c8b550d972f7080409a4cc5a92e9d04ece50ed108f92c6aec4868d150e58d7d11a
diff --git a/app-containers/lxc/files/lxc.initd.8 b/app-containers/lxc/files/lxc.initd.8
deleted file mode 100644
index 727f6d504fb3..000000000000
--- a/app-containers/lxc/files/lxc.initd.8
+++ /dev/null
@@ -1,131 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-CONTAINER=${SVCNAME#*.}
-
-LXC_PATH=`lxc-config lxc.lxcpath`
-
-lxc_get_configfile() {
- if [ -f "${LXC_PATH}/${CONTAINER}.conf" ]; then
- echo "${LXC_PATH}/${CONTAINER}.conf"
- elif [ -f "${LXC_PATH}/${CONTAINER}/config" ]; then
- echo "${LXC_PATH}/${CONTAINER}/config"
- else
- eerror "Unable to find a suitable configuration file."
- eerror "If you set up the container in a non-standard"
- eerror "location, please set the CONFIGFILE variable."
- return 1
- fi
-}
-
-[ $CONTAINER != $SVCNAME ] && CONFIGFILE=${CONFIGFILE:-$(lxc_get_configfile)}
-
-lxc_get_var() {
- awk 'BEGIN { FS="[ \t]*=[ \t]*" } $1 == "'$1'" { print $2; exit }' ${CONFIGFILE}
-}
-
-lxc_get_net_link_type() {
- awk 'BEGIN { FS="[ \t]*=[ \t]*"; _link=""; _type="" }
- $1 == "lxc.network.type" {_type=$2;}
- $1 == "lxc.network.link" {_link=$2;}
- match($1, /lxc\.net\.[[:digit:]]+\.type/) {_type=$2;}
- match($1, /lxc\.net\.[[:digit:]]+\.link/) {_link=$2;}
- {if(_link != "" && _type != ""){
- printf("%s:%s\n", _link, _type );
- _link=""; _type="";
- }; }' <${CONFIGFILE}
-}
-
-checkconfig() {
- if [ ${CONTAINER} = ${SVCNAME} ]; then
- eerror "You have to create an init script for each container:"
- eerror " ln -s lxc /etc/init.d/lxc.container"
- return 1
- fi
-
- # no need to output anything, the function takes care of that.
- [ -z "${CONFIGFILE}" ] && return 1
-
- utsname=$(lxc_get_var lxc.uts.name)
- if [ -z "$utsname" ] ; then
- utsname=$(lxc_get_var lxc.utsname)
- fi
-
- if [ "${CONTAINER}" != "${utsname}" ]; then
- eerror "You should use the same name for the service and the"
- eerror "container. Right now the container is called ${utsname}"
- return 1
- fi
-}
-
-depend() {
- # be quiet, since we have to run depend() also for the
- # non-muxed init script, unfortunately.
- checkconfig 2>/dev/null || return 0
-
- config ${CONFIGFILE}
- need localmount
- use lxcfs
-
- local _x _if
- for _x in $(lxc_get_net_link_type); do
- _if=${_x%:*}
- case "${_x##*:}" in
- # when the network type is set to phys, we can make use of a
- # network service (for instance to set it up before we disable
- # the net_admin capability), but we might also not set it up
- # at all on the host and leave the net_admin capable service
- # to take care of it.
- phys) use net.${_if} ;;
- *) need net.${_if} ;;
- esac
- done
-}
-
-start() {
- checkconfig || return 1
- rm -f /var/log/lxc/${CONTAINER}.log
-
- rootpath=$(lxc_get_var lxc.rootfs)
-
- # Check the format of our init and the chroot's init, to see
- # if we have to use linux32 or linux64; always use setarch
- # when required, as that makes it easier to deal with
- # x32-based containers.
- case $(scanelf -BF '%a#f' ${rootpath}/sbin/init) in
- EM_X86_64) setarch=linux64;;
- EM_386) setarch=linux32;;
- esac
-
- ebegin "Starting LXC container ${CONTAINER}"
- env -i ${setarch} $(which lxc-start) -n ${CONTAINER} -f ${CONFIGFILE} -d -o /var/log/lxc/${CONTAINER}.log
- sleep 1
-
- # lxc-start -d will _always_ report a correct startup, even if it
- # failed, so rather than trust that, check that the cgroup exists.
- # fix for LXC 3.1
-
- STATE="$(lxc-info -s -H ${CONTAINER})"
- [ "$STATE" = "RUNNING" ]
-
- eend $?
-}
-
-stop() {
- checkconfig || return 1
-
- STATE="$(lxc-info -s -H ${CONTAINER})"
-
- if ! [ "$STATE" = "RUNNING" ]; then
- ewarn "${CONTAINER} doesn't seem to be started."
- return 0
- fi
-
- # 30s should be enough to shut everything down
- # lxc-stop will return back anyway as soon as successful shutdown
- # after 30s, lxc-stop sends SIGKILL (dirty shotdown)
- ebegin "Stopping LXC container ${CONTAINER}"
- lxc-stop -t 30 -n ${CONTAINER}
- eend $?
-}
diff --git a/app-containers/lxc/lxc-5.0.2.ebuild b/app-containers/lxc/lxc-5.0.2.ebuild
deleted file mode 100644
index de0e266a84c9..000000000000
--- a/app-containers/lxc/lxc-5.0.2.ebuild
+++ /dev/null
@@ -1,168 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 linux-info meson optfeature systemd toolchain-funcs verify-sig
-
-DESCRIPTION="A userspace interface for the Linux kernel containment features"
-HOMEPAGE="https://linuxcontainers.org/ https://github.com/lxc/lxc"
-SRC_URI="https://linuxcontainers.org/downloads/lxc/${P}.tar.gz
- verify-sig? ( https://linuxcontainers.org/downloads/lxc/${P}.tar.gz.asc )"
-
-LICENSE="GPL-2 LGPL-2.1 LGPL-3"
-SLOT="0/1.502" # SONAME liblxc.so.1 + ${PV//./} _if_ breaking ABI change while bumping.
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
-IUSE="apparmor +caps examples io-uring lto man pam seccomp selinux ssl systemd test +tools"
-
-RDEPEND="acct-group/lxc
- acct-user/lxc
- apparmor? ( sys-libs/libapparmor )
- caps? ( sys-libs/libcap[static-libs] )
- io-uring? ( >=sys-libs/liburing-2:= )
- pam? ( sys-libs/pam )
- seccomp? ( sys-libs/libseccomp )
- selinux? ( sys-libs/libselinux )
- ssl? ( dev-libs/openssl:0= )
- systemd? ( sys-apps/systemd:= )
- tools? ( sys-libs/libcap[static-libs] )"
-DEPEND="${RDEPEND}
- sys-kernel/linux-headers"
-BDEPEND="virtual/pkgconfig
- man? ( app-text/docbook2X )
- verify-sig? ( sec-keys/openpgp-keys-linuxcontainers )"
-
-RESTRICT="!test? ( test )"
-
-CONFIG_CHECK="~!NETPRIO_CGROUP
- ~CGROUPS
- ~CGROUP_CPUACCT
- ~CGROUP_DEVICE
- ~CGROUP_FREEZER
-
- ~CGROUP_SCHED
- ~CPUSETS
- ~IPC_NS
- ~MACVLAN
-
- ~MEMCG
- ~NAMESPACES
- ~NET_NS
- ~PID_NS
-
- ~POSIX_MQUEUE
- ~USER_NS
- ~UTS_NS
- ~VETH"
-
-ERROR_CGROUP_FREEZER="CONFIG_CGROUP_FREEZER: needed to freeze containers"
-ERROR_MACVLAN="CONFIG_MACVLAN: needed for internal (inter-container) networking"
-ERROR_MEMCG="CONFIG_MEMCG: needed for memory resource control in containers"
-ERROR_NET_NS="CONFIG_NET_NS: needed for unshared network"
-ERROR_POSIX_MQUEUE="CONFIG_POSIX_MQUEUE: needed for lxc-execute command"
-ERROR_UTS_NS="CONFIG_UTS_NS: needed to unshare hostnames and uname info"
-ERROR_VETH="CONFIG_VETH: needed for internal (host-to-container) networking"
-
-VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
-
-DOCS=( AUTHORS CONTRIBUTING MAINTAINERS README.md doc/FAQ.txt )
-
-pkg_setup() {
- linux-info_pkg_setup
-}
-
-src_configure() {
- local emesonargs=(
- --localstatedir "${EPREFIX}/var"
-
- -Dcoverity-build=false
- -Doss-fuzz=false
-
- -Dcommands=true
- -Dmemfd-rexec=true
- -Dthread-safety=true
-
- $(meson_use apparmor)
- $(meson_use caps capabilities)
- $(meson_use examples)
- $(meson_use io-uring io-uring-event-loop)
- $(meson_use lto b_lto)
- $(meson_use man)
- $(meson_use pam pam-cgroup)
- $(meson_use seccomp)
- $(meson_use selinux)
- $(meson_use ssl openssl)
- $(meson_use test tests)
- $(meson_use tools)
-
- -Ddata-path=/var/lib/lxc
- -Ddoc-path=/usr/share/doc/${PF}
- -Dlog-path=/var/log/lxc
- -Drootfs-mount-path=/var/lib/lxc/rootfs
- -Druntime-path=/run
- )
-
- if use systemd; then
- local emesonargs+=( -Dinit-script="systemd" )
- local emesonargs+=( -Dsd-bus=enabled )
- else
- local emesonargs+=( -Dinit-script="sysvinit" )
- local emesonargs+=( -Dsd-bus=disabled )
- fi
-
- use tools && local emesonargs+=( -Dcapabilities=true )
-
- if $(tc-ld-is-gold) || $(tc-ld-is-lld); then
- local emesonargs+=( -Db_lto_mode=thin )
- else
- local emesonargs+=( -Db_lto_mode=default )
- fi
-
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
-
- # The main bash-completion file will collide with lxd, need to relocate and update symlinks.
- mkdir -p "${ED}"/$(get_bashcompdir) || die "Failed to create bashcompdir."
-
- if use tools; then
- bashcomp_alias lxc-start lxc-{attach,autostart,cgroup,checkpoint,config,console,copy,create,destroy,device,execute,freeze,info,ls,monitor,snapshot,stop,top,unfreeze,unshare,usernsexec,wait}
- else
- bashcomp_alias lxc-start lxc-usernsexec
- fi
-
- keepdir /var/lib/cache/lxc /var/lib/lib/lxc
-
- find "${ED}" -name '*.la' -delete -o -name '*.a' -delete || die
-
- # Replace upstream sysvinit/systemd files.
- if use systemd; then
- rm -r "${D}$(systemd_get_systemunitdir)" || die "Failed to remove systemd lib dir"
- else
- rm "${ED}"/etc/init.d/lxc-{containers,net} || die "Failed to remove sysvinit scripts"
- fi
-
- newinitd "${FILESDIR}/${PN}.initd.8" ${PN}
- systemd_newunit "${FILESDIR}"/lxc-monitord.service.5.0.0 lxc-monitord.service
- systemd_newunit "${FILESDIR}"/lxc-net.service.5.0.0 lxc-net.service
- systemd_newunit "${FILESDIR}"/lxc.service-5.0.0 lxc.service
- systemd_newunit "${FILESDIR}"/lxc_at.service.5.0.0 "lxc@.service"
-
- if ! use apparmor; then
- sed -i '/lxc-apparmor-load/d' "${D}$(systemd_get_systemunitdir)/lxc.service" || die "Failed to remove apparmor references from lxc.service systemd unit."
- fi
-}
-
-pkg_postinst() {
- elog "Please refer to "
- elog "https://wiki.gentoo.org/wiki/LXC for introduction and usage guide."
- elog
- elog "Run 'lxc-checkconfig' to see optional kernel features."
- elog
-
- optfeature "automatic template scripts" app-containers/lxc-templates
- optfeature "Debian-based distribution container image support" dev-util/debootstrap
- optfeature "snapshot & restore functionality" sys-process/criu
-}