summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-04-04 12:44:46 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-04-04 12:44:46 -0500
commit8bf602af49691499bc7830038062b0ce059a7838 (patch)
treef3cc6b1b3af841a164cec4c7bbb4ea7f029de934 /app-containers
parentsys-apps/util-linux: Stabilize 2.38.1-r2 amd64, #902599 (diff)
downloadgentoo-8bf602af49691499bc7830038062b0ce059a7838.tar.gz
gentoo-8bf602af49691499bc7830038062b0ce059a7838.tar.bz2
gentoo-8bf602af49691499bc7830038062b0ce059a7838.zip
app-containers/grype: add 0.61.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/grype/Manifest2
-rw-r--r--app-containers/grype/grype-0.61.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/grype/Manifest b/app-containers/grype/Manifest
index b90d79fb3721..dc740f1b0fb3 100644
--- a/app-containers/grype/Manifest
+++ b/app-containers/grype/Manifest
@@ -4,3 +4,5 @@ DIST grype-0.51.0-deps.tar.xz 601816220 BLAKE2B 441982389af5e33cbe988571464cad03
DIST grype-0.51.0.tar.gz 1124375 BLAKE2B 6d2fb92edd2bc174d0879426f56812be7ede7e8c83cae49a0dee9781b0a771592f352b9a4fb96f87e8031592295c255e041bf30d0e5be5c24887c8436d505cf8 SHA512 4d1868a74523279734239836421c6a17595baa3179c80d18dba04cc5188e29eb5d97bc3102c931e9b1995a9afbc1da03d95d52bb8d74f5465c7415a1b16f947c
DIST grype-0.59.1-deps.tar.xz 555292828 BLAKE2B ce132ecd42efd2c76bce1843b1da2ff763494a0206c8618c95ec03ae9d73a77378a68e503de9115c73efd6acbab4cc30bf222676c7888aafb08de8454351fb2b SHA512 aa627bfbf52c218786d009dee6e37bc09d70fd98ad10b8c07ec91db9d15380a1fbc35f380ee22fae8b6e7b090d1aabfebf58bc1ea6bca2bd179dcaa74b52a2c0
DIST grype-0.59.1.tar.gz 1021093 BLAKE2B 0c5b0a8a14e297e123965d451daff082cbabb01f766ec355a37d54d7044b865430aa7cbec20d8002feac33f93e24565ebe6346a8559e8a25bf3df1dcc8ca217e SHA512 8f219ade9d7369f124dd8c035f3bef6ce5055e318d7ab1578f7f98a7fa6e842dad26fae8b2337884d4af3773b2c590b61485a490f98c66dfcbd82ef73d8b766b
+DIST grype-0.61.0-deps.tar.xz 562038080 BLAKE2B cb780751f50f9c74ac9f9a7064e489211bdfbd3d9df5fbd3fd51aa6081a48cac38b5efcaf524708cb010b3767c7bf31eaf8151e96f610ae84a814de767beec8e SHA512 eca6b813c140af26533154ca10f50a44351bef921e6140c3ae02c8b888d4e43bd7163954684463c19acf3c11b7ee93c1531b4b1042f0cd3886e1da36f384c029
+DIST grype-0.61.0.tar.gz 1021705 BLAKE2B 32ff98f3f240ee5d883edb568ff9caa7614053e76ea9bd8a774a5abb92091e4356e25c10b94d9aaf4a17a2f8c4c7d0f26e2ceec8a089ca079029893d255a7480 SHA512 ce4b1805f17bccd3281a218673156669ae632418bdfabf95c310b973bc224b89b7e0e3ca57a8c7e1df444074e034092d963df3b11cbf393e500fe1786f707ed5
diff --git a/app-containers/grype/grype-0.61.0.ebuild b/app-containers/grype/grype-0.61.0.ebuild
new file mode 100644
index 000000000000..99ae14b81d3c
--- /dev/null
+++ b/app-containers/grype/grype-0.61.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=d8c0c0805b59659c4d6e49d6806a0eba11bdc2ee
+SYFT_VERSION=0.76.0
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require a running docker
+RESTRICT="test"
+
+src_compile() {
+ ego build -o bin/grype -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/grype/internal/version.version=${PV}
+ -X github.com/anchore/grype/internal/version.syftVersion=${SYFT_VERSION}
+ -X github.com/anchore/grype/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/grype/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/grype/internal/version.gitDescription=v${PV}"
+}
+
+src_install() {
+ dobin bin/grype
+}