summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-07-27 18:10:23 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-07-27 18:11:49 -0500
commit57a5ebafe8bf88bbfbd6f3cc4d9f218fdf25d5a9 (patch)
tree4bb4e7c492779658117cb7c5546e68d883052333 /app-crypt/cfssl
parentdev-python/sphinxcontrib-blockdiag: keyword 2.0.0 for ~riscv (diff)
downloadgentoo-57a5ebafe8bf88bbfbd6f3cc4d9f218fdf25d5a9.tar.gz
gentoo-57a5ebafe8bf88bbfbd6f3cc4d9f218fdf25d5a9.tar.bz2
gentoo-57a5ebafe8bf88bbfbd6f3cc4d9f218fdf25d5a9.zip
app-crypt/cfssl: 1.6.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-crypt/cfssl')
-rw-r--r--app-crypt/cfssl/Manifest1
-rw-r--r--app-crypt/cfssl/cfssl-1.6.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/cfssl/Manifest b/app-crypt/cfssl/Manifest
index dfe0138b7adb..28bf72a18d46 100644
--- a/app-crypt/cfssl/Manifest
+++ b/app-crypt/cfssl/Manifest
@@ -1 +1,2 @@
DIST cfssl-1.4.1.tar.gz 5736648 BLAKE2B 581627eb269fcbbbe9ff3afe558c6ddc7afa10f563444899244045baa0ae195d8822b389e7c59bec6c9135b1159b18d2a5e497c83cd26eaa47a3a87de23ce694 SHA512 0aa557708a300e2eaf48a99d55794069530b6842584cdd867a864272b205c89d5abc2acf3a19d34b3b5519a6429b5f55685129638e65d574ad6afe5b7e1e1e8f
+DIST cfssl-1.6.0.tar.gz 7428162 BLAKE2B 100313b756885e00a09003bfd326f8b0d69a14d148cd65b97a53667716c14a8841d862740b7dafbca74da30a8f1d6465ca3f3bad6ccd2ed39379bb1de80fd225 SHA512 a1470c50a6ffa506d2c1798a9e8af5a60206cd41d24cc3ca8a071e9ddfc3249a07fa79c03dabc3df0800985be7e930018045ae95ee83d31486cba93e516da111
diff --git a/app-crypt/cfssl/cfssl-1.6.0.ebuild b/app-crypt/cfssl/cfssl-1.6.0.ebuild
new file mode 100644
index 000000000000..58eda26f63bc
--- /dev/null
+++ b/app-crypt/cfssl/cfssl-1.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="Cloudflare's PKI and TLS toolkit"
+HOMEPAGE="https://github.com/cloudflare/cfssl"
+SRC_URI="https://github.com/cloudflare/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-1 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hardened"
+
+RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.1-build-fix.patch"
+)
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
+}
+
+src_install() {
+ dobin bin/*
+ dodoc CHANGELOG README.md
+}