summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-10 16:39:44 +0100
committerSam James <sam@gentoo.org>2022-07-10 16:45:27 +0100
commitea5b30612aecea0ca8952c820cb8588353e78162 (patch)
treedceae630f649ee3c190b0e0676076853580b3e5b /app-crypt/ckpass
parentprofiles: last-rite net-mail/mpack (diff)
downloadgentoo-ea5b30612aecea0ca8952c820cb8588353e78162.tar.gz
gentoo-ea5b30612aecea0ca8952c820cb8588353e78162.tar.bz2
gentoo-ea5b30612aecea0ca8952c820cb8588353e78162.zip
app-crypt/ckpass: EAPI 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/ckpass')
-rw-r--r--app-crypt/ckpass/ckpass-0.2-r2.ebuild (renamed from app-crypt/ckpass/ckpass-0.2-r1.ebuild)6
-rw-r--r--app-crypt/ckpass/files/ckpass-0.2-implicit-function-declaration.patch10
2 files changed, 14 insertions, 2 deletions
diff --git a/app-crypt/ckpass/ckpass-0.2-r1.ebuild b/app-crypt/ckpass/ckpass-0.2-r2.ebuild
index 4b1f070d0852..48fc5954525f 100644
--- a/app-crypt/ckpass/ckpass-0.2-r1.ebuild
+++ b/app-crypt/ckpass/ckpass-0.2-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit autotools
DESCRIPTION="ncurses based password database client compatible with KeePass 1.x databases"
@@ -17,6 +18,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-implicit-function-declaration.patch
)
src_prepare() {
diff --git a/app-crypt/ckpass/files/ckpass-0.2-implicit-function-declaration.patch b/app-crypt/ckpass/files/ckpass-0.2-implicit-function-declaration.patch
new file mode 100644
index 000000000000..78dce6d1a3f3
--- /dev/null
+++ b/app-crypt/ckpass/files/ckpass-0.2-implicit-function-declaration.patch
@@ -0,0 +1,10 @@
+--- a/ckpass.c
++++ b/ckpass.c
+@@ -30,6 +30,7 @@
+ #include <string.h>
+ #include <sys/mman.h>
+ #include <sys/stat.h>
++#include <sys/wait.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <errno.h>