summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/elettra
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/elettra')
-rw-r--r--app-crypt/elettra/Manifest1
-rw-r--r--app-crypt/elettra/elettra-1.0.ebuild35
-rw-r--r--app-crypt/elettra/metadata.xml7
3 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/elettra/Manifest b/app-crypt/elettra/Manifest
new file mode 100644
index 000000000000..6a69e18915bd
--- /dev/null
+++ b/app-crypt/elettra/Manifest
@@ -0,0 +1 @@
+DIST elettra-src-1.0.tar.gz 16102 SHA256 fb0c4e3f624c02a613e34abbf7bc03d8fc0d43b4967c2b51b202d7201d95e05b SHA512 341a83436d9c163391eabbc06600b29e8ee837bb805f2f9ea922ffa8d8dcb9ec53e50ae475e13e2810ac69419b86072cd7e6c44d13c80e43ee67071e6864d5b3 WHIRLPOOL a5aff8c548c71181686b8724c4b2080b3b42b151747573c89cbd82579e8ad5a527204ceb24f04c39fd6f53387702410b9e6edf59968d2f563e94c2f4ead09827
diff --git a/app-crypt/elettra/elettra-1.0.ebuild b/app-crypt/elettra/elettra-1.0.ebuild
new file mode 100644
index 000000000000..456371a5c468
--- /dev/null
+++ b/app-crypt/elettra/elettra-1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+MY_P="${PN}-src-${PV}"
+
+DESCRIPTION="Plausible deniable file cryptography"
+HOMEPAGE="http://www.winstonsmith.info/julia/elettra/"
+SRC_URI="http://www.winstonsmith.info/julia/elettra/${MY_P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib
+ app-crypt/mhash
+ dev-libs/libmcrypt"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -I. src/*.c \
+ -lz `libmcrypt-config --cflags --libs` -lmhash \
+ -o elettra || die "compilation failed"
+}
+
+src_install() {
+ dobin elettra || die "dobin failed"
+ dodoc README || die "dodoc failed"
+}
diff --git a/app-crypt/elettra/metadata.xml b/app-crypt/elettra/metadata.xml
new file mode 100644
index 000000000000..6eb35690d41d
--- /dev/null
+++ b/app-crypt/elettra/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>lu_zero@gentoo.org</email>
+</maintainer>
+</pkgmetadata>