summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-07 08:23:23 -0700
committerMatt Turner <mattst88@gentoo.org>2022-05-07 08:32:51 -0700
commitb38043e8e56bc7ceeee547fcb5c9dbf0a713f28a (patch)
treec20802d35c3d9f4f730c82ba93943589efeeb215 /app-crypt/gcr
parentnet-misc/tigervnc: Stabilize 1.12.0-r5 ppc, #842723 (diff)
downloadgentoo-b38043e8e56bc7ceeee547fcb5c9dbf0a713f28a.tar.gz
gentoo-b38043e8e56bc7ceeee547fcb5c9dbf0a713f28a.tar.bz2
gentoo-b38043e8e56bc7ceeee547fcb5c9dbf0a713f28a.zip
app-crypt/gcr: Version bump to 3.41.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-crypt/gcr')
-rw-r--r--app-crypt/gcr/Manifest1
-rw-r--r--app-crypt/gcr/files/gcr-3.41.0-Unbreak-build-without-systemd.patch27
-rw-r--r--app-crypt/gcr/gcr-3.41.0.ebuild89
3 files changed, 117 insertions, 0 deletions
diff --git a/app-crypt/gcr/Manifest b/app-crypt/gcr/Manifest
index cc0e9da4b4eb..c24bb8c5bd97 100644
--- a/app-crypt/gcr/Manifest
+++ b/app-crypt/gcr/Manifest
@@ -1 +1,2 @@
DIST gcr-3.40.0.tar.xz 1011044 BLAKE2B 6b1016f74e5fd3ace32a534a59575db9c39b5deefd2f4f3a747ef7e87a43c7c00b33500d8151009347af9fe6b073c390895bb6e17c577c6e150c780c487b997e SHA512 7118608e7bef7d0cf2eea33cb3286b7f9c3622a38892ce88cf33ed453d343cc33e070831e7b4d0c5cdb43c2e57b3f0b91c7cbd6aa8463982d3af8844b59bcb81
+DIST gcr-3.41.0.tar.xz 1039744 BLAKE2B c646a04168310051d5b582a9d2f7ab9da89eef095e856e56b8d730600debead051ad8bb40eddb7457b1be2be3e092227dd886f647258a9c6a81d4bab728245f7 SHA512 455acc40ed77feeb35f9845b00229f468b322b7eda0b1b5abb0153f0a6ba29f3d0364df22225143f4caf130254a1258b3c7f934370e5142f2f64e1c3084b6f6e
diff --git a/app-crypt/gcr/files/gcr-3.41.0-Unbreak-build-without-systemd.patch b/app-crypt/gcr/files/gcr-3.41.0-Unbreak-build-without-systemd.patch
new file mode 100644
index 000000000000..eac12c0a34a2
--- /dev/null
+++ b/app-crypt/gcr/files/gcr-3.41.0-Unbreak-build-without-systemd.patch
@@ -0,0 +1,27 @@
+From 96e76ee482dad2a0d71f9a5a5a6558d272d538ca Mon Sep 17 00:00:00 2001
+From: Antoine Jacoutot <ajacoutot@gnome.org>
+Date: Sun, 24 Oct 2021 10:26:03 +0200
+Subject: [PATCH] Unbreak build without systemd.
+
+This fixes the check for WITH_SYSTEMD and prevents a fatal error:
+'systemd/sd-daemon.h' file not found when building with systemd disabled.
+---
+ gcr/gcr-ssh-agent-service.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gcr/gcr-ssh-agent-service.c b/gcr/gcr-ssh-agent-service.c
+index 3b5a4ca..b7e8928 100644
+--- a/gcr/gcr-ssh-agent-service.c
++++ b/gcr/gcr-ssh-agent-service.c
+@@ -39,7 +39,7 @@
+ #include <glib/gstdio.h>
+ #include <gcr/gcr-base.h>
+
+-#ifdef WITH_SYSTEMD
++#if WITH_SYSTEMD
+ #include <systemd/sd-daemon.h>
+ #endif
+
+--
+2.35.1
+
diff --git a/app-crypt/gcr/gcr-3.41.0.ebuild b/app-crypt/gcr/gcr-3.41.0.ebuild
new file mode 100644
index 000000000000..6a5988f3730b
--- /dev/null
+++ b/app-crypt/gcr/gcr-3.41.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gcr"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/1" # subslot = suffix of libgcr-base-3 and co
+
+IUSE="gtk gtk-doc +introspection systemd test +vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+DEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/libgcrypt-1.2.2:0=
+ >=app-crypt/p11-kit-0.19.0
+ >=app-crypt/libsecret-0.20
+ systemd? ( sys-apps/systemd:= )
+ gtk? ( >=x11-libs/gtk+-3.22:3[introspection?] )
+ >=sys-apps/dbus-1
+ introspection? ( >=dev-libs/gobject-introspection-1.58:= )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="app-crypt/gnupg"
+BDEPEND="
+ ${PYTHON_DEPS}
+ gtk? ( dev-libs/libxml2:2 )
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.9
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ >=sys-devel/gettext-0.19.8
+ test? ( app-crypt/gnupg )
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/3.38.0-optional-vapi.patch
+ "${FILESDIR}"/${PN}-3.40.0-meson-0.61-build.patch
+ "${FILESDIR}"/${P}-Unbreak-build-without-systemd.patch
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_use gtk)
+ $(meson_use gtk-doc gtk_doc)
+ -Dgpg_path="${EPREFIX}"/usr/bin/gpg
+ -Dssh_agent=true
+ $(meson_feature systemd)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}