summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2017-01-18 12:59:09 -0500
committerZero_Chaos <zerochaos@gentoo.org>2017-01-18 12:59:28 -0500
commitbf17d199cd0b37c7caf93d5165e6861db26d3aa5 (patch)
treee8836ed0640ad3fdd1e257739346073a7bba3ba4 /app-crypt/hashcat/hashcat-3.30.ebuild
parentx11-misc/spnavcfg: 0.3 (bug #606430) (diff)
downloadgentoo-bf17d199cd0b37c7caf93d5165e6861db26d3aa5.tar.gz
gentoo-bf17d199cd0b37c7caf93d5165e6861db26d3aa5.tar.bz2
gentoo-bf17d199cd0b37c7caf93d5165e6861db26d3aa5.zip
app-crypt/hashcat: bumpity bump bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-crypt/hashcat/hashcat-3.30.ebuild')
-rw-r--r--app-crypt/hashcat/hashcat-3.30.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-crypt/hashcat/hashcat-3.30.ebuild b/app-crypt/hashcat/hashcat-3.30.ebuild
new file mode 100644
index 000000000000..a7dc12ea3120
--- /dev/null
+++ b/app-crypt/hashcat/hashcat-3.30.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils pax-utils multilib
+
+DESCRIPTION="World's fastest and most advanced password recovery utility"
+HOMEPAGE="https://github.com/hashcat/hashcat"
+SRC_URI="https://github.com/hashcat/hashcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="custom-cflags video_cards_nvidia video_cards_fglrx"
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ #do not strip
+ sed -i "/LFLAGS += -s/d" src/Makefile
+ #do not add random CFLAGS
+ sed -i "s/-O2//" src/Makefile || die
+ export PREFIX=/usr
+ export LIBRARY_FOLDER="/usr/$(get_libdir)"
+ eapply_user
+}
+
+src_compile() {
+ default
+ pax-mark -mr hashcat
+}
+
+src_test() {
+ if use video_cards_nvidia; then
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia-uvm
+ if [ ! -w /dev/nvidia0 ]; then
+ einfo "To run these tests, portage likely must be in the video group."
+ einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
+ fi
+ elif use vidia_cards_fglrx; then
+ addwrite /dev/ati
+ fi
+ #this always exits with 255 despite success
+ #./hashcat -b -m 2500 || die "Test failed"
+ ./hashcat -a 3 -m 1500 nQCk49SiErOgk
+}