summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-22 23:22:32 +0100
committerSam James <sam@gentoo.org>2021-09-22 23:24:12 +0100
commit3f0a0993461657039f3a44f37f6e67490e09d4c6 (patch)
treea4bf561b1135e2c0cd736016144911d6b5516671 /app-crypt/johntheripper-jumbo
parentsys-kernel/gentoo-sources: Clean-up of 5.4.X series (diff)
downloadgentoo-3f0a0993461657039f3a44f37f6e67490e09d4c6.tar.gz
gentoo-3f0a0993461657039f3a44f37f6e67490e09d4c6.tar.bz2
gentoo-3f0a0993461657039f3a44f37f6e67490e09d4c6.zip
app-crypt/johntheripper-jumbo: add 1.9.0_p20210920-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/johntheripper-jumbo')
-rw-r--r--app-crypt/johntheripper-jumbo/Manifest1
-rw-r--r--app-crypt/johntheripper-jumbo/files/johntheripper-jumbo-1.9.0-fix-bashism.patch24
-rw-r--r--app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20210920.ebuild143
3 files changed, 168 insertions, 0 deletions
diff --git a/app-crypt/johntheripper-jumbo/Manifest b/app-crypt/johntheripper-jumbo/Manifest
index cf2f85e511b8..40c0211c6790 100644
--- a/app-crypt/johntheripper-jumbo/Manifest
+++ b/app-crypt/johntheripper-jumbo/Manifest
@@ -1 +1,2 @@
DIST john-1.9.0-jumbo-1.tar.xz 33638768 BLAKE2B 2fd6813e234308408d42581705ee8b25f9217a3dfb43f05483156f7bb67d0ce0d6de9c3ce8c2e4a17bb99bb377119dae2897bc08c800e7bc80bc6cf245400df6 SHA512 c5cb5dc739ee4c666f8479cdf10511fddc391b590c59f90c060d3ccd8449b794ac7b831a6d1f7553883892499e709a66578cfa4d62caef9b7e0a831eb827e808
+DIST johntheripper-jumbo-1.9.0_p20210920.tar.gz 47758128 BLAKE2B e85255dc218c43e6358f76eac1e79af01d437a7a1fcddd608a390734fdc4070cbf949b8abc080b82decf4a1f5e32d2baa6d2a09d385a31913d8e988c8732e85e SHA512 5121434ad275921fe6288c51fd9dfd36ed3162387e70e8089bbc266d4a17ea461b72ce26b2004acfb62d95a9ee2d570ef3b3f00c1d031abd8cff2f20c3ab480a
diff --git a/app-crypt/johntheripper-jumbo/files/johntheripper-jumbo-1.9.0-fix-bashism.patch b/app-crypt/johntheripper-jumbo/files/johntheripper-jumbo-1.9.0-fix-bashism.patch
new file mode 100644
index 000000000000..a0a18158ce7e
--- /dev/null
+++ b/app-crypt/johntheripper-jumbo/files/johntheripper-jumbo-1.9.0-fix-bashism.patch
@@ -0,0 +1,24 @@
+https://patch-diff.githubusercontent.com/raw/openwall/john/pull/4822.patch
+
+From dd9501341808fe19b9c5cd4f8f04edfc5f377077 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 22 Sep 2021 19:34:38 +0100
+Subject: [PATCH] configure.ac: avoid bashism in pkg-config check
+
+== is a Bashism and configure scripts need to work
+with a POSIX shell, so let's change to = (like in
+the other condition).
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/src/configure.ac
++++ b/src/configure.ac
+@@ -347,7 +347,7 @@ AS_IF([test -z "$STRIP"], [AC_CHECK_TOOL([STRIP], [strip])])
+ dnl Check if we have this at all
+ PKG_PROG_PKG_CONFIG
+ AC_MSG_CHECKING([if pkg-config will be used])
+-if test "x$PKG_CONFIG" = x || test "x$enable_pkg_config" == xno ; then
++if test "x$PKG_CONFIG" = x || test "x$enable_pkg_config" = xno ; then
+ JTR_MSG_RESULT_FAILIF_FORCED([xno], [x$enable_pkg_config], [pkg-config is NOT available])
+ PKG_CONFIG=no
+ else
+
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20210920.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20210920.ebuild
new file mode 100644
index 000000000000..df228200cfd7
--- /dev/null
+++ b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20210920.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs pax-utils
+
+DESCRIPTION="Fast password cracker"
+HOMEPAGE="http://www.openwall.com/john/"
+
+MY_PN="JohnTheRipper"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/magnumripper/${MY_PN}.git"
+ inherit git-r3
+else
+ JUMBO="jumbo-1.1"
+ MY_PV="${PV}-${JUMBO}"
+ MY_P="john-${MY_PV}"
+ HASH_COMMIT="43c7f8850736d4ec68bf0a022ae9fb34c274a01d"
+
+ SRC_URI="https://github.com/openwall/john/archive/${HASH_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/john-${HASH_COMMIT}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="custom-cflags kerberos mpi opencl openmp pcap"
+
+DEPEND=">=dev-libs/openssl-1.0.1:=
+ virtual/libcrypt:=
+ mpi? ( virtual/mpi )
+ opencl? ( virtual/opencl )
+ kerberos? ( virtual/krb5 )
+ pcap? ( net-libs/libpcap )
+ dev-libs/gmp:=
+ sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}
+ !app-crypt/johntheripper"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9.0-fix-bashism.patch
+)
+
+pkg_setup() {
+ if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
+ tc-has-openmp || die "Please switch to an OpenMP compatible compiler"
+ fi
+}
+
+src_prepare() {
+ default
+
+ cd src || die
+ eautoreconf
+
+ sed -i 's#$prefix/share/john#/etc/john#' configure || die
+}
+
+src_configure() {
+ cd src || die
+
+ use custom-cflags || strip-flags
+
+ econf \
+ --enable-pkg-config \
+ --disable-native-march \
+ --disable-native-tests \
+ --disable-rexgen \
+ --with-openssl \
+ --with-systemwide \
+ $(use_enable mpi) \
+ $(use_enable opencl) \
+ $(use_enable openmp) \
+ $(use_enable pcap)
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_test() {
+ pax-mark -mr run/john
+ #if use opencl; then
+ #gpu tests fail in portage, so run cpu only tests
+ # ./run/john --device=cpu --test=0 --verbosity=2 || die
+ #else
+ #weak tests
+ # ./run/john --test=0 --verbosity=2 || die
+ #strong tests
+ #./run/john --test=1 --verbosity=2 || die
+ #fi
+ ewarn "When built systemwide, john can't run tests without reading files in /etc."
+ ewarn "Don't bother opening a bug for this unless you include a patch to fix it"
+}
+
+src_install() {
+ # Executables
+ dosbin run/john
+ newsbin run/mailer john-mailer
+
+ pax-mark -mr "${ED}/usr/sbin/john"
+
+ # grep '$(LN)' Makefile.in | head -n-3 | tail -n+2 | cut -d' ' -f3 | cut -d/ -f3
+ local s
+ for s in \
+ unshadow unafs undrop unique ssh2john putty2john pfx2john keepass2john keyring2john \
+ zip2john gpg2john rar2john racf2john keychain2john kwallet2john pwsafe2john dmg2john \
+ hccap2john base64conv truecrypt_volume2john keystore2john
+ do
+ dosym john /usr/sbin/${s}
+ done
+
+ # Scripts
+ exeinto /usr/share/john
+ doexe run/*.pl
+ doexe run/*.py
+ cd run || die
+
+ local s
+ for s in *.pl *.py; do
+ dosym ../share/john/${s} /usr/bin/${s}
+ done
+ cd .. || die
+
+ if use opencl; then
+ insinto /etc/john
+ doins -r run/opencl
+ fi
+
+ # Config files
+ insinto /etc/john
+ doins run/*.chr run/password.lst
+ doins run/*.conf
+ doins -r run/rules run/ztex
+
+ # dDocumentation
+ rm -f doc/README || die
+ dodoc -r README.md doc/*
+}