summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-14 23:30:04 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-14 23:30:04 +0200
commitf7ef3949041a92d4d9aadd8f26c33ac8f6d23198 (patch)
tree386748fd551f16380c680627aeef647ae6d43051 /app-crypt/johntheripper-jumbo
parentdev-db/mongodb: fix build with Boost 1.79; fix automagic SSL usage (diff)
downloadgentoo-f7ef3949041a92d4d9aadd8f26c33ac8f6d23198.tar.gz
gentoo-f7ef3949041a92d4d9aadd8f26c33ac8f6d23198.tar.bz2
gentoo-f7ef3949041a92d4d9aadd8f26c33ac8f6d23198.zip
app-crypt/johntheripper-jumbo: [QA] tc-has-openmp → tc-check-openmp
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/johntheripper-jumbo')
-rw-r--r--app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0-r3.ebuild10
-rw-r--r--app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20210920.ebuild10
-rw-r--r--app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20211129.ebuild8
-rw-r--r--app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild8
4 files changed, 22 insertions, 14 deletions
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0-r3.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0-r3.ebuild
index 632f59d7a16f..f17408ea8cf3 100644
--- a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0-r3.ebuild
+++ b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,10 +45,12 @@ PATCHES=(
"${FILESDIR}/${P}-gcc11.patch"
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20210920.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20210920.ebuild
index df228200cfd7..a77f1fbf4199 100644
--- a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20210920.ebuild
+++ b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20210920.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,10 +45,12 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.9.0-fix-bashism.patch
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
- tc-has-openmp || die "Please switch to an OpenMP compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20211129.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20211129.ebuild
index 6f4a38509974..5143d68af9a3 100644
--- a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20211129.ebuild
+++ b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0_p20211129.ebuild
@@ -53,10 +53,12 @@ PATCHES=(
"${FILESDIR}"/${P}-fix-bashism.patch
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
- tc-has-openmp || die "Please switch to an OpenMP compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
index 90eb1c9135c3..0b2c68d044c4 100644
--- a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
+++ b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
@@ -49,10 +49,12 @@ RDEPEND="${DEPEND}
dev-perl/Digest-GOST
!app-crypt/johntheripper"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
- tc-has-openmp || die "Please switch to an OpenMP compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {