summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-04-15 01:41:21 +0200
committerDavid Seifert <soap@gentoo.org>2023-04-15 01:41:21 +0200
commit51c1daf62a027c5ee2549369c6ee8a06b3a146f6 (patch)
tree7244a11ff671cd2bd279ecb697633c1f94c54a2c /app-crypt/libnitrokey
parentdev-libs/icu-layoutex: add 73.1, drop 73_rc (diff)
downloadgentoo-51c1daf62a027c5ee2549369c6ee8a06b3a146f6.tar.gz
gentoo-51c1daf62a027c5ee2549369c6ee8a06b3a146f6.tar.bz2
gentoo-51c1daf62a027c5ee2549369c6ee8a06b3a146f6.zip
app-crypt/libnitrokey: add 3.8
Bug: https://bugs.gentoo.org/856142 Bug: https://bugs.gentoo.org/896248 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/libnitrokey')
-rw-r--r--app-crypt/libnitrokey/Manifest1
-rw-r--r--app-crypt/libnitrokey/libnitrokey-3.8.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-crypt/libnitrokey/Manifest b/app-crypt/libnitrokey/Manifest
index db77f8d535ce..1d90cd22336e 100644
--- a/app-crypt/libnitrokey/Manifest
+++ b/app-crypt/libnitrokey/Manifest
@@ -1 +1,2 @@
DIST libnitrokey-3.6.tar.gz 98038 BLAKE2B 27f99e7b6de93548fc7a373f37ce784da0aa50503a5c635b4d90282e6330a5ff4c0dcc03a83a7e57045b8a1aabaab27d76a090d7c49693a6ff1037b81e75ece9 SHA512 a00a6724e5c64715eca688ec254efd979acceb5ff4cad28a205f7128e44db8674a5924634fd7da6c69d589deafca7b28b99e1d05a244c321d5cb429f2e5a3bec
+DIST libnitrokey-3.8.tar.gz 118197 BLAKE2B 6216229d718e6c1763abc56cc6cea341bcc7c6e1ea1a100a490d72786e5ce88d5784c1452036835a0a2fa104254d807d135efaee4b1696508c9c9d0d865e78a1 SHA512 30f966eed77aa75057b096d18f8e88d6be28a376dfc1888e44aff80347e031a16755d30acf1bca196acc5b922778d90627ac71cba22f5cb002ba3ec058939c90
diff --git a/app-crypt/libnitrokey/libnitrokey-3.8.ebuild b/app-crypt/libnitrokey/libnitrokey-3.8.ebuild
new file mode 100644
index 000000000000..b37e5cdbd34f
--- /dev/null
+++ b/app-crypt/libnitrokey/libnitrokey-3.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit udev cmake
+
+DESCRIPTION="Support library for the Nitrokey"
+HOMEPAGE="https://github.com/Nitrokey/libnitrokey"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nitrokey/libnitrokey.git"
+
+ # Disable pulling in bundled dependencies
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/hidapi:=
+ virtual/udev"
+DEPEND="
+ ${RDEPEND}
+ test? ( <dev-cpp/catch-3:0 )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_UDEVRULESDIR="$(get_udevdir)"/rules.d
+
+ # actual hardware tests
+ # 1. require a connected Nitrokey
+ # 2. may kill data on your Nitrokey
+ # hence the main testsuite is disabled
+ -DCOMPILE_TESTS=OFF
+ -DCOMPILE_OFFLINE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}