summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-30 12:20:41 +0100
committerMichał Górny <mgorny@gentoo.org>2019-10-30 12:22:31 +0100
commit6a36ce3e863fbb411f22af3740334d4b7d27b4a6 (patch)
treec76d250a891554a2c485d81b501c831a5487fe8f /app-crypt/openpgp-keys-gentoo-release/openpgp-keys-gentoo-release-20191030.ebuild
parentwww-client/vivaldi-snapshot: Old (diff)
downloadgentoo-6a36ce3e863fbb411f22af3740334d4b7d27b4a6.tar.gz
gentoo-6a36ce3e863fbb411f22af3740334d4b7d27b4a6.tar.bz2
gentoo-6a36ce3e863fbb411f22af3740334d4b7d27b4a6.zip
app-crypt/openpgp-keys-gentoo-release: Bump to 20191030
A fresh snapshot with prolonged keys. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt/openpgp-keys-gentoo-release/openpgp-keys-gentoo-release-20191030.ebuild')
-rw-r--r--app-crypt/openpgp-keys-gentoo-release/openpgp-keys-gentoo-release-20191030.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/openpgp-keys-gentoo-release/openpgp-keys-gentoo-release-20191030.ebuild b/app-crypt/openpgp-keys-gentoo-release/openpgp-keys-gentoo-release-20191030.ebuild
new file mode 100644
index 000000000000..ae331b090421
--- /dev/null
+++ b/app-crypt/openpgp-keys-gentoo-release/openpgp-keys-gentoo-release-20191030.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenPGP keys used for Gentoo releases (snapshots, stages)"
+HOMEPAGE="https://www.gentoo.org/downloads/signatures/"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/openpgp-keys/gentoo-release.asc.${PV}.gz
+ test? ( https://dev.gentoo.org/~mgorny/dist/openpgp-keys/gentoo-release-test-sigs-20190224.tar.gz )"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( app-crypt/gnupg )"
+
+S=${WORKDIR}
+
+src_test() {
+ local old_umask=$(umask)
+ umask 077
+
+ local -x GNUPGHOME=${T}/.gnupg
+ mkdir "${GNUPGHOME}" || die
+ einfo "Importing keys ..."
+ gpg --import "gentoo-release.asc.${PV}" || die "Key import failed"
+
+ local f
+ for f in gentoo-release-test-sigs*/*.asc; do
+ einfo "Testing ${f##*/} ..."
+ gpg -q --trust-model always --verify "${f}" || die "Verification failed on ${f}"
+ done
+
+ umask "${old_umask}"
+}
+
+src_install() {
+ insinto /usr/share/openpgp-keys
+ newins "gentoo-release.asc.${PV}" gentoo-release.asc
+}