summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-08-02 11:53:13 -0500
committerJohn Helmert III <ajak@gentoo.org>2022-08-02 11:55:28 -0500
commit46694cf0c3e2c0512b65aa5acfe52e0a4fcb04cf (patch)
tree1422a076d0f7a3f7a46002fff964c605b7150997 /app-crypt/sbctl/sbctl-0.9.ebuild
parentsec-keys/openpgp-keys-foxboron: new package, add 20220802 (diff)
downloadgentoo-46694cf0c3e2c0512b65aa5acfe52e0a4fcb04cf.tar.gz
gentoo-46694cf0c3e2c0512b65aa5acfe52e0a4fcb04cf.tar.bz2
gentoo-46694cf0c3e2c0512b65aa5acfe52e0a4fcb04cf.zip
app-crypt/sbctl: new package, add 0.9
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-crypt/sbctl/sbctl-0.9.ebuild')
-rw-r--r--app-crypt/sbctl/sbctl-0.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/sbctl/sbctl-0.9.ebuild b/app-crypt/sbctl/sbctl-0.9.ebuild
new file mode 100644
index 000000000000..7d3e9ef2e850
--- /dev/null
+++ b/app-crypt/sbctl/sbctl-0.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module verify-sig
+
+DESCRIPTION="Secure Boot key manager"
+HOMEPAGE="https://github.com/Foxboron/sbctl"
+SRC_URI="https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz
+ https://dev.gentoo.org/~ajak/dist/${P}-deps.tar.xz
+ verify-sig? ( https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz.sig )"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-text/asciidoc
+ dev-lang/go
+ verify-sig? ( sec-keys/openpgp-keys-foxboron )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/foxboron.asc"
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.sig}
+ fi
+
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+}