summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-21 16:57:57 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-21 17:00:11 -0400
commitabf1be2ec233e1e034d1013e84549ca1c520bf27 (patch)
tree40e6a7157a0ab59697621ad28b67a9cc1a53efb5 /app-crypt/seahorse
parentvirtual/perl-bignum: Add 5.36 version (diff)
downloadgentoo-abf1be2ec233e1e034d1013e84549ca1c520bf27.tar.gz
gentoo-abf1be2ec233e1e034d1013e84549ca1c520bf27.tar.bz2
gentoo-abf1be2ec233e1e034d1013e84549ca1c520bf27.zip
app-crypt/seahorse: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/Manifest1
-rw-r--r--app-crypt/seahorse/seahorse-42.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
index 762f387e6f85..948d1cb5aebd 100644
--- a/app-crypt/seahorse/Manifest
+++ b/app-crypt/seahorse/Manifest
@@ -1 +1,2 @@
DIST seahorse-41.0.tar.xz 1371984 BLAKE2B fdfc7c6d5ba41ab83c639d93c92fe6e1c36d42a02c7a384c2055bfe594e2a16415115bfb07597de93a886e492974e38c812fbbd59c7112c0360adeed96cb437d SHA512 cc51e27a55ed646ee376aa1b1bffe28369d80e4b8c484c9711de6bdf190694714ef208579d0399b5c199b5619491d72dede1b1f6c03b89cf3a53e8519a4d4fcf
+DIST seahorse-42.0.tar.xz 1395040 BLAKE2B ae40d587c881851014b1989af986993768598a6a530f281cef3e177f0e6dbb3a97ec5128c5f39a463f69a4dfabb5c9f95af1dd3de7af12247338b8003c102ea3 SHA512 2a961a4054360c9a4fe0e9e360d6ea621a65325db8e40365e75d747cfe751c2dc3230ff51ffe0435d24766a91e8a042b8c01183fd58a70974a7ad095af8d247e
diff --git a/app-crypt/seahorse/seahorse-42.0.ebuild b/app-crypt/seahorse/seahorse-42.0.ebuild
new file mode 100644
index 000000000000..0aeb990bc5c0
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-42.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Manage your passwords and encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="ldap zeroconf"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.66:2
+ >=app-crypt/gcr-3.38:=
+ >=app-crypt/gpgme-1.14.0:=
+ >=x11-libs/gtk+-3.24.0:3
+ >=app-crypt/gnupg-2.2
+ >=gui-libs/libhandy-1.6:1=
+ >=app-crypt/libsecret-0.16
+ dev-libs/libpwquality
+ net-misc/openssh
+ ldap? ( net-nds/openldap:= )
+ >=net-libs/libsoup-2.33.92:2.4
+ zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/libxml2:2
+ app-crypt/gcr[vala]
+ app-crypt/libsecret[vala]
+ gui-libs/libhandy:1[vala]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/appstream-glib
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ vala_setup
+ gnome2_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dhelp=true
+ -Dpgp-support=true
+ -Dcheck-compatible-gpg=false # keep lowest version listed as compatible as min dep for gnupg RDEPEND
+ -Dpkcs11-support=true
+ -Dkeyservers-support=true
+ -Dhkp-support=true
+ $(meson_use ldap ldap-support)
+ $(meson_use zeroconf key-sharing)
+ -Dmanpage=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}