summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2021-02-27 19:30:00 +0000
committerMike Auty <ikelos@gentoo.org>2021-02-27 19:31:11 +0000
commitbb305819a4c39bb9a0da7f248a9ebbedc3097c7a (patch)
tree726f240cbcbefa5a392ef84e8b526e3ca384fcf1 /app-crypt/xca
parentdev-util/pkgdev: add tests (diff)
downloadgentoo-bb305819a4c39bb9a0da7f248a9ebbedc3097c7a.tar.gz
gentoo-bb305819a4c39bb9a0da7f248a9ebbedc3097c7a.tar.bz2
gentoo-bb305819a4c39bb9a0da7f248a9ebbedc3097c7a.zip
app-crypt/xca: Bump stable for 733000
Closes: https://bugs.gentoo.org/733000 Signed-off-by: Mike Auty <ikelos@gentoo.org>
Diffstat (limited to 'app-crypt/xca')
-rw-r--r--app-crypt/xca/files/xca-2.1.2-bug-733000.patch31
-rw-r--r--app-crypt/xca/files/xca-2.3.0-bug-733000.patch (renamed from app-crypt/xca/files/xca-bug-733000.patch)0
-rw-r--r--app-crypt/xca/xca-2.1.2-r1.ebuild66
-rw-r--r--app-crypt/xca/xca-2.3.0.ebuild2
4 files changed, 98 insertions, 1 deletions
diff --git a/app-crypt/xca/files/xca-2.1.2-bug-733000.patch b/app-crypt/xca/files/xca-2.1.2-bug-733000.patch
new file mode 100644
index 000000000000..3e17a8aa9a91
--- /dev/null
+++ b/app-crypt/xca/files/xca-2.1.2-bug-733000.patch
@@ -0,0 +1,31 @@
+diff --git a/doc/Makefile b/doc/Makefile
+index 7c9a643..f88c209 100644
+--- a/doc/Makefile
++++ b/doc/Makefile
+@@ -3,15 +3,11 @@ TOPDIR=..
+ BUILD=..
+ endif
+
+-DELFILES=xca*.html xca.1.gz changelog.html database_schema.html
++DELFILES=xca*.html changelog.html database_schema.html
+
+-doc: xca.1.gz xca.html changelog.html database_schema.html
++doc: xca.1 xca.html changelog.html database_schema.html
+ include $(TOPDIR)/Rules.mak
+
+-%.1.gz: %.1
+- @$(PRINT) " MAN [$(BASENAME)] $@"
+- gzip -9 <$^ >$@
+-
+ xca.html: xca.sgml
+ rm -f xca*.html
+ echo 'The documentation for XCA can be viewed online at: <a href="http://hohnstaedt.de/documentation">http://hohnstaedt.de/documentation</a>.' > $@
+@@ -23,7 +19,7 @@ install: $(doc)
+ $(ENABLE_DOC)install -m 755 -d $(destdir)$(htmldir)
+ $(ENABLE_DOC)install -m 644 xca*.html $(destdir)$(htmldir)
+ install -m 755 -d $(destdir)$(mandir)/man1
+- install -m 644 *.1.gz $(destdir)/$(mandir)/man1
++ install -m 644 *.1 $(destdir)/$(mandir)/man1
+
+ app: xca.html
+ mkdir -p $(APPDIR)/Resources
diff --git a/app-crypt/xca/files/xca-bug-733000.patch b/app-crypt/xca/files/xca-2.3.0-bug-733000.patch
index 044575475c89..044575475c89 100644
--- a/app-crypt/xca/files/xca-bug-733000.patch
+++ b/app-crypt/xca/files/xca-2.3.0-bug-733000.patch
diff --git a/app-crypt/xca/xca-2.1.2-r1.ebuild b/app-crypt/xca/xca-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..28e0f2da477f
--- /dev/null
+++ b/app-crypt/xca/xca-2.1.2-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit xdg-utils
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="https://hohnstaedt.de/xca/"
+SRC_URI="https://github.com/chris2511/${PN}/releases/download/RELEASE.${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="bindist doc libressl"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ dev-qt/qtgui:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( >=dev-libs/libressl-2.7.0:0= )
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+ "${FILESDIR}/${P}-bug-733000.patch"
+)
+
+src_configure() {
+ econf \
+ --with-qt-version=5 \
+ $(use_enable doc) \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+ einstalldocs
+
+ insinto /etc/xca
+ doins misc/*.txt
+
+ ewarn "Make a backup copy of your database!"
+ ewarn "This version completely changes the database format to SQL(ite)"
+ ewarn "Don't try to open it with older versions of XCA (< 1.4.0). They will corrupt the database."
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/app-crypt/xca/xca-2.3.0.ebuild b/app-crypt/xca/xca-2.3.0.ebuild
index 556779ccf8e4..c7ef3f20b62d 100644
--- a/app-crypt/xca/xca-2.3.0.ebuild
+++ b/app-crypt/xca/xca-2.3.0.ebuild
@@ -27,7 +27,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-1.0.0-desktop.patch"
- "${FILESDIR}/${PN}-bug-73300.patch"
+ "${FILESDIR}/${P}-bug-733000.patch"
)
src_configure() {