summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-05-11 12:56:33 +0100
committerMarek Szuba <marecki@gentoo.org>2023-05-11 12:59:34 +0100
commit0a38eb5aff2fc1d91e1b5c8d98f4b7e7e5293abe (patch)
tree16d168e8b3a68b26f5cf3916a30d1361ee9ba68a /app-crypt
parentmedia-sound/easyeffects: add 7.0.4, drop 7.0.1 (diff)
downloadgentoo-0a38eb5aff2fc1d91e1b5c8d98f4b7e7e5293abe.tar.gz
gentoo-0a38eb5aff2fc1d91e1b5c8d98f4b7e7e5293abe.tar.bz2
gentoo-0a38eb5aff2fc1d91e1b5c8d98f4b7e7e5293abe.zip
app-crypt/yubikey-manager: add 5.1.1
Seems whatever caused the errors I saw build-testing 5.1.0 either got fixed in this release or went away as dependencies got updated. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubikey-manager/Manifest2
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-5.1.1.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index 07370c95f345..d254833d0e20 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -1,2 +1,4 @@
DIST yubikey_manager-5.0.1.tar.gz 158829 BLAKE2B 082b7405a6b8049c0086126c8287ab66f5028b121da4aeae81939683ed65cef1a7c59bf545b5e768b18643bd6c0ee759b2897673870344d8f7ab5217413c1a0d SHA512 2e798f8475e52c9091f5cd6ebbd5937eb3f14c49e9c2c9c7eda09c095ac3a1c80065e14f8e9c827c1eee8914ce3c3e21dbb2820a6ac8cefed1306d409cc6a0fc
DIST yubikey_manager-5.0.1.tar.gz.sig 310 BLAKE2B c12b2c6f09be26a3df394cc296fbe28db560f31864a5b46d18021d672947c0d929b56be5cd10fd0347e4bcdeb988a242780b58565eb64163b125752756e5dda1 SHA512 876c47c2b22efd58f801f3bf7110c1896f425090d2454db4eb8214442b5a909b75f6fcf8e581c97806e488bfc6fb306e92274ce1b29be9e3240813944155478f
+DIST yubikey_manager-5.1.1.tar.gz 167947 BLAKE2B 4f0b7a3ba3f083112c0a43c9b9304e7f79526d7a31991959dc8a30e86f41b0ec616c9ed7790a551d998dc481bd18a89e87598c2534b8390a831572a77a36c32d SHA512 9da9588bb311594d2b4d2d8b234b64f333dfc7dc57145e250965bd9d058cfda43a9c9a32991081ac069819812bebaf0c10a24afab4ac444891ab21d2cff81c06
+DIST yubikey_manager-5.1.1.tar.gz.sig 310 BLAKE2B 4f636b5eab0602ec203c8d3d5b6d1de85c7341559b09fc131a994c75b15cb141706ccc65a8efb39e33d5a3704496e85c08a67d105d45f5264644b993c2585f20 SHA512 e964e39a995de7bd24a3e417d5e98cf68cdcd6412b7c95b552545468bbb434105fad97bbf82d758c9320bf9917d32312e6e286e9259d004899af2cde540cc731
diff --git a/app-crypt/yubikey-manager/yubikey-manager-5.1.1.ebuild b/app-crypt/yubikey-manager/yubikey-manager-5.1.1.ebuild
new file mode 100644
index 000000000000..00293500dc8c
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-5.1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1 verify-sig
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# According to https://github.com/Yubico/yubikey-manager/issues/518 the release
+# tarballs on Yubico Web site and on GitHub should be identical, and at least
+# for recent releases the latter are signed as well. Only the automatically
+# generated "Source code (tar.gz)" tarballs should not be used.
+# Still, prefer the former if available.
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${MY_P}.tar.gz
+ verify-sig? ( https://developers.yubico.com/${PN}/Releases/${MY_P}.tar.gz.sig )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="ssl"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/yubico.com.asc"
+
+# app-crypt/ccid required for
+# - 'ykman oath'
+# - 'ykman openpgp'
+# - 'ykman piv'
+RDEPEND="
+ app-crypt/ccid
+ dev-python/click[${PYTHON_USEDEP}]
+ <dev-python/cryptography-43[${PYTHON_USEDEP}]
+ dev-python/fido2:0/1.0[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ ssl? ( >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? ( dev-python/makefun[${PYTHON_USEDEP}] )
+ verify-sig? ( >=sec-keys/openpgp-keys-yubico-20220824 )"
+
+S="${WORKDIR}"/${MY_P}
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/ykman.1
+}