summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-10-06 20:11:52 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-10-06 22:26:39 +0200
commitc85eea5b68b7cca5e43a32a7e61fb7d41c03ce4d (patch)
tree63a3c71b42884380d086429bf6b08748ce9cb5be /app-crypt
parentwww-plugins/pdfjs: 2.10.377 bump (diff)
downloadgentoo-c85eea5b68b7cca5e43a32a7e61fb7d41c03ce4d.tar.gz
gentoo-c85eea5b68b7cca5e43a32a7e61fb7d41c03ce4d.tar.bz2
gentoo-c85eea5b68b7cca5e43a32a7e61fb7d41c03ce4d.zip
app-crypt/acme-sh: bump to version 3.0.1
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme-sh/Manifest1
-rw-r--r--app-crypt/acme-sh/acme-sh-3.0.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/acme-sh/Manifest b/app-crypt/acme-sh/Manifest
index 9c1d851aa0f7..145fe53929df 100644
--- a/app-crypt/acme-sh/Manifest
+++ b/app-crypt/acme-sh/Manifest
@@ -1 +1,2 @@
DIST acme.sh-3.0.0.tar.gz 237047 BLAKE2B 4165cb8b5d6f7a6deda8149332c798f795e5c8cfc63953f2e30e28f1b7ec256a1f3e38596d33d075c7257921d9ffd27bc6add3ac8bb3b9c0ddf5861cb0d3a2d3 SHA512 e93e955100071fda9398131aad965fe6d5b51d9c496b1db0269744513baca4c8eb142d9a35a72b72d4919c004848696fdf9de1ae51edec835ae0f695a6cb14b1
+DIST acme.sh-3.0.1.tar.gz 239311 BLAKE2B cbbaf6da068447c3400081889e249dc6f17f56df2038d75915eb990e417ecf5407c9c8272dfbd8403fac413357f30df552678ed27096de769ee5355f6343b6f4 SHA512 8bc5468fa70bf0a23f516b05e49f4c457cceb3ae0c12e963b538297912adce1f16fca200b116fc39a88ee0ba522e1757654ed231bebb6199ef7f5ad152511c71
diff --git a/app-crypt/acme-sh/acme-sh-3.0.1.ebuild b/app-crypt/acme-sh/acme-sh-3.0.1.ebuild
new file mode 100644
index 000000000000..a6b09a058aa2
--- /dev/null
+++ b/app-crypt/acme-sh/acme-sh-3.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+inherit optfeature
+
+DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
+HOMEPAGE="https://github.com/acmesh-official/acme.sh"
+SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:0
+ net-misc/curl
+ net-misc/socat
+"
+
+src_install() {
+ newdoc deploy/README.md README-deploy.md
+ newdoc dnsapi/README.md README-dnsapi.md
+ rm {deploy,dnsapi}/README.md || die
+ einstalldocs
+
+ exeinto /usr/share/acme.sh
+ doexe acme.sh
+
+ insinto /usr/share/acme.sh
+ doins -r deploy dnsapi notify
+
+ keepdir /etc/acme-sh
+ doenvd "${FILESDIR}"/99acme-sh
+
+ insinto /etc/bash/bashrc.d
+ doins "${FILESDIR}"/acme.sh
+
+ dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
+}
+
+pkg_postinst() {
+ optfeature_header "For webserver mode, install a supported web server:"
+ optfeature "using apache2 webserver mode" www-servers/apache
+ optfeature "using nginx webserver mode" www-servers/nginx
+}