summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-doc/abs-guide/abs-guide-10.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-doc/abs-guide/abs-guide-10.ebuild')
-rw-r--r--app-doc/abs-guide/abs-guide-10.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-doc/abs-guide/abs-guide-10.ebuild b/app-doc/abs-guide/abs-guide-10.ebuild
new file mode 100644
index 000000000000..3c0f51736f62
--- /dev/null
+++ b/app-doc/abs-guide/abs-guide-10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="An in-depth exploration of the art of shell scripting"
+HOMEPAGE="http://www.tldp.org/LDP/abs/html"
+
+SRC_URI="http://bash.deta.in/abs-guide-final.tar.bz2
+ pdf? ( http://bash.deta.in/abs-guide.pdf )"
+
+LICENSE="public-domain"
+IUSE="pdf"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ppc sparc x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/abs"
+
+src_unpack() {
+ unpack abs-guide-final.tar.bz2
+ use pdf && cp "${DISTDIR}"/abs-guide.pdf "${S}"
+}
+
+src_install() {
+ dodoc -r *
+ docompress -x /usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+ echo
+ elog "The HTML docs can be accessed through /usr/share/doc/${P}/HTML/index.html"
+ elog "Example scripts from the book are installed in /usr/share/doc/${P}/"
+ use pdf && elog "along with the pdf version."
+ echo
+}