summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2019-09-15 15:46:08 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-13 13:40:23 +0200
commitdda18deb4019c222598b94fff7be1a355d5e5690 (patch)
treedeb87dcc4074212df37218dd1b100d6d1c7cfcc1 /app-doc/gnucash-docs/gnucash-docs-3.7.ebuild
parentapp-office/gnucash: Fix testcase failures (diff)
downloadgentoo-dda18deb4019c222598b94fff7be1a355d5e5690.tar.gz
gentoo-dda18deb4019c222598b94fff7be1a355d5e5690.tar.bz2
gentoo-dda18deb4019c222598b94fff7be1a355d5e5690.zip
app-doc/gnucash-docs: Bump gnucash-docs-3.7
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-doc/gnucash-docs/gnucash-docs-3.7.ebuild')
-rw-r--r--app-doc/gnucash-docs/gnucash-docs-3.7.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-doc/gnucash-docs/gnucash-docs-3.7.ebuild b/app-doc/gnucash-docs/gnucash-docs-3.7.ebuild
new file mode 100644
index 000000000000..505a73b78785
--- /dev/null
+++ b/app-doc/gnucash-docs/gnucash-docs-3.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome2
+
+DESCRIPTION="Documentation package for GnuCash"
+HOMEPAGE="http://www.gnucash.org/"
+SRC_URI="https://github.com/Gnucash/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 FDL-1.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LOCALES=( de it ja pt ru )
+IUSE="${LOCALES[*]/#/l10n_}"
+
+DEPEND="
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ app-text/rarian
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local doc_type my_lang
+
+ for doc_type in help guide; do
+ for my_lang in C ${L10N}; do
+ case $my_lang in
+ # Both help and guides translated
+ C|de|it|pt) ;;
+ ru|ja) # Only guides translated
+ if [[ ${doc_type} = "help" ]] ; then
+ elog "Help documentation hasn't been translated for $my_lang"
+ elog "Will do English instead."
+ continue
+ fi
+ ;;
+ *)
+ die "Invalid locale: $my_lang"
+ ;;
+ esac
+
+ emake -C "${doc_type}/${my_lang}" DESTDIR="${D}" install
+ done
+ done
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ optfeature "You need dev-java/fop to generate pdf files." dev-java/fop
+ optfeature "You need gnome-extra/yelp to view the docs." gnome-extra/yelp
+}