summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-14 23:57:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-14 23:58:04 +0100
commita907228322492350c4814e69770f389ce5a6b298 (patch)
tree6cc85fefc7ab4057ae16e09fd6e3abae1a22de1e /app-doc
parentapp-cdr/kcdemu: add 0.8.1, add sourceforge upstream metadata (diff)
downloadgentoo-a907228322492350c4814e69770f389ce5a6b298.tar.gz
gentoo-a907228322492350c4814e69770f389ce5a6b298.tar.bz2
gentoo-a907228322492350c4814e69770f389ce5a6b298.zip
*/*: Revert a5097f91..b52ec567
Should not have been pushed. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/zeal/Manifest1
-rw-r--r--app-doc/zeal/files/zeal-0.7.0-0001-fix-ui-add-tool-tip-when-global-shortcuts-are-.patch15
-rw-r--r--app-doc/zeal/files/zeal-0.7.0-0002-fix-ui-use-async-selection-in-search-edit.patch21
-rw-r--r--app-doc/zeal/files/zeal-0.7.0-0003-fix-browser-send-key-events-to-web-view-s-focu.patch12
-rw-r--r--app-doc/zeal/files/zeal-0.7.0-0004-fix-registry-save-non-zero-docset-revision-in-.patch14
-rw-r--r--app-doc/zeal/files/zeal-0.7.0-0005-refactor-replace-deprecated-qAsConst-with-std-.patch91
-rw-r--r--app-doc/zeal/files/zeal-0.7.0-cmake.patch317
-rw-r--r--app-doc/zeal/files/zeal-0.7.0-disable-update-check.patch27
-rw-r--r--app-doc/zeal/files/zeal-0.7.0-settings-disable-checking-for-updates-by-default.patch11
-rw-r--r--app-doc/zeal/zeal-0.7.0.ebuild70
10 files changed, 0 insertions, 579 deletions
diff --git a/app-doc/zeal/Manifest b/app-doc/zeal/Manifest
index 66d93856ee1c..ff4a3054c4af 100644
--- a/app-doc/zeal/Manifest
+++ b/app-doc/zeal/Manifest
@@ -1,2 +1 @@
DIST zeal-0.6.1_p20200815.tar.gz 1180048 BLAKE2B 22a6ee7985516f2204de0603374944c101fa77339a6c83b8a33633fa51e25890f39d672f3d804adb8c41b9ffc2ad7971ce16f90dacb1160f1868ed3f8768aad2 SHA512 fa08c88a40f2f75847db4950c2b027262304bb8b63b95d497786fa2c3a90aa0c488fc3ebe494afe70353a2dd93a181bf2d8fa752a7241e572045c6728ea99f2d
-DIST zeal-0.7.0.tar.xz 784204 BLAKE2B 1926836ef18cf8a8ff80075de7e75d9b6f65af575a84fdaee54a482dcea7ee45ae0ce527bbe6def6e8415a07fffd9a2f6f68901f2e9023f6d71c6b76f381cfc2 SHA512 c4dd50c4a1e3fb7ffb402587f9473adec47026a68be10d1e8aad6f9cb9cb7a4c1f5905b9e2d205b9066d6daa4ced36238e27329944cee7de8386588f86145990
diff --git a/app-doc/zeal/files/zeal-0.7.0-0001-fix-ui-add-tool-tip-when-global-shortcuts-are-.patch b/app-doc/zeal/files/zeal-0.7.0-0001-fix-ui-add-tool-tip-when-global-shortcuts-are-.patch
deleted file mode 100644
index 59390b401b67..000000000000
--- a/app-doc/zeal/files/zeal-0.7.0-0001-fix-ui-add-tool-tip-when-global-shortcuts-are-.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Commit 1d92d3c737f04e9f7ba369777495a1fa4178ddd4
---- a/src/libs/ui/settingsdialog.cpp
-+++ b/src/libs/ui/settingsdialog.cpp
-@@ -79,7 +79,10 @@ SettingsDialog::SettingsDialog(QWidget *parent)
- setTabOrder(ui->fontSizeComboBox, ui->serifFontComboBox);
-
- // Disable global shortcut settings if not supported.
-- ui->globalHotKeyGroupBox->setEnabled(QxtGlobalShortcut::isSupported());
-+ if (!QxtGlobalShortcut::isSupported()) {
-+ ui->globalHotKeyGroupBox->setEnabled(false);
-+ ui->globalHotKeyGroupBox->setToolTip(tr("Global shortcuts are not supported on the current platform."));
-+ }
-
- QWebEngineSettings *webSettings = QWebEngineProfile::defaultProfile()->settings();
-
diff --git a/app-doc/zeal/files/zeal-0.7.0-0002-fix-ui-use-async-selection-in-search-edit.patch b/app-doc/zeal/files/zeal-0.7.0-0002-fix-ui-use-async-selection-in-search-edit.patch
deleted file mode 100644
index 22ab93c5f568..000000000000
--- a/app-doc/zeal/files/zeal-0.7.0-0002-fix-ui-use-async-selection-in-search-edit.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Commit d5ce8a0f04dfc4d609cfcab75cc53135ba1a9557
---- a/src/libs/ui/widgets/searchedit.cpp
-+++ b/src/libs/ui/widgets/searchedit.cpp
-@@ -29,6 +29,7 @@
- #include <QKeyEvent>
- #include <QLabel>
- #include <QStyle>
-+#include <QTimer>
-
- using namespace Zeal;
- using namespace Zeal::WidgetUi;
-@@ -82,7 +83,8 @@ void SearchEdit::selectQuery()
- return;
- }
-
-- selectAll();
-+ // Avoid some race condition which breaks Ctrl+K shortcut.
-+ QTimer::singleShot(0, this, &QLineEdit::selectAll);
- }
-
- bool SearchEdit::event(QEvent *event)
diff --git a/app-doc/zeal/files/zeal-0.7.0-0003-fix-browser-send-key-events-to-web-view-s-focu.patch b/app-doc/zeal/files/zeal-0.7.0-0003-fix-browser-send-key-events-to-web-view-s-focu.patch
deleted file mode 100644
index 33eb895487fc..000000000000
--- a/app-doc/zeal/files/zeal-0.7.0-0003-fix-browser-send-key-events-to-web-view-s-focu.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Commit f2212eb4f0c9b39a0a207995b097a6b0238b3cbb
---- a/src/libs/browser/searchtoolbar.cpp
-+++ b/src/libs/browser/searchtoolbar.cpp
-@@ -137,7 +137,7 @@ bool SearchToolBar::eventFilter(QObject *object, QEvent *event)
- case Qt::Key_Up:
- case Qt::Key_PageDown:
- case Qt::Key_PageUp:
-- QCoreApplication::sendEvent(m_webView, event);
-+ QCoreApplication::sendEvent(m_webView->focusProxy(), event);
- return true;
- default:
- break;
diff --git a/app-doc/zeal/files/zeal-0.7.0-0004-fix-registry-save-non-zero-docset-revision-in-.patch b/app-doc/zeal/files/zeal-0.7.0-0004-fix-registry-save-non-zero-docset-revision-in-.patch
deleted file mode 100644
index 996b670a2c7e..000000000000
--- a/app-doc/zeal/files/zeal-0.7.0-0004-fix-registry-save-non-zero-docset-revision-in-.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Commit 2cefcd45423e58283372a4c735609c284eded410
---- a/src/libs/registry/docsetmetadata.cpp
-+++ b/src/libs/registry/docsetmetadata.cpp
-@@ -89,8 +89,8 @@ void DocsetMetadata::save(const QString &path, const QString &version)
- if (!version.isEmpty())
- jsonObject[QStringLiteral("version")] = version;
-
-- if (version == latestVersion() && m_revision == 0)
-- jsonObject[QStringLiteral("revision")] = m_revision;
-+ if (version == latestVersion() && m_revision > 0)
-+ jsonObject[QStringLiteral("revision")] = QString::number(m_revision);
-
- if (!m_feedUrl.isEmpty())
- jsonObject[QStringLiteral("feed_url")] = m_feedUrl.toString();
diff --git a/app-doc/zeal/files/zeal-0.7.0-0005-refactor-replace-deprecated-qAsConst-with-std-.patch b/app-doc/zeal/files/zeal-0.7.0-0005-refactor-replace-deprecated-qAsConst-with-std-.patch
deleted file mode 100644
index 7d618b5d7bd8..000000000000
--- a/app-doc/zeal/files/zeal-0.7.0-0005-refactor-replace-deprecated-qAsConst-with-std-.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-Commit 9630cc94c155d87295e51b41fbab2bd5798f8229
---- a/src/libs/registry/docset.cpp
-+++ b/src/libs/registry/docset.cpp
-@@ -458,7 +458,7 @@ void Docset::loadSymbols(const QString &symbolType) const
- // with it.first and it.second respectively pointing to the start and the end
- // of the range of nodes having symbolType as key. It effectively represents a
- // contiguous view over the nodes with a specified key.
-- for (auto it = qAsConst(m_symbolStrings).equal_range(symbolType); it.first != it.second; ++it.first) {
-+ for (auto it = std::as_const(m_symbolStrings).equal_range(symbolType); it.first != it.second; ++it.first) {
- loadSymbols(symbolType, it.first.value());
- }
- }
-@@ -519,7 +519,7 @@ void Docset::createIndex()
- }
-
- // Drop old indexes
-- for (const QString &oldIndexName : qAsConst(oldIndexes)) {
-+ for (const QString &oldIndexName : std::as_const(oldIndexes)) {
- m_db->execute(indexDropQuery.arg(oldIndexName));
- }
-
-diff --git a/src/libs/registry/docsetmetadata.cpp b/src/libs/registry/docsetmetadata.cpp
-index 0678a13..5144e2f 100644
---- a/src/libs/registry/docsetmetadata.cpp
-+++ b/src/libs/registry/docsetmetadata.cpp
-@@ -97,7 +97,7 @@ void DocsetMetadata::save(const QString &path, const QString &version)
-
- if (!m_urls.isEmpty()) {
- QJsonArray urls;
-- for (const QUrl &url : qAsConst(m_urls)) {
-+ for (const QUrl &url : std::as_const(m_urls)) {
- urls.append(url.toString());
- }
-
-diff --git a/src/libs/registry/docsetregistry.cpp b/src/libs/registry/docsetregistry.cpp
-index 9776a19..17be79e 100644
---- a/src/libs/registry/docsetregistry.cpp
-+++ b/src/libs/registry/docsetregistry.cpp
-@@ -101,7 +101,7 @@ void DocsetRegistry::setFuzzySearchEnabled(bool enabled)
-
- m_isFuzzySearchEnabled = enabled;
-
-- for (Docset *docset : qAsConst(m_docsets)) {
-+ for (Docset *docset : std::as_const(m_docsets)) {
- docset->setFuzzySearchEnabled(enabled);
- }
- }
-@@ -193,7 +193,7 @@ Docset *DocsetRegistry::docset(int index) const
-
- Docset *DocsetRegistry::docsetForUrl(const QUrl &url)
- {
-- for (Docset *docset : qAsConst(m_docsets)) {
-+ for (Docset *docset : std::as_const(m_docsets)) {
- if (docset->baseUrl().isParentOf(url))
- return docset;
- }
-@@ -226,7 +226,7 @@ void DocsetRegistry::_runQuery(const QString &query)
-
- const SearchQuery searchQuery = SearchQuery::fromString(query);
- if (searchQuery.hasKeywords()) {
-- for (Docset *docset : qAsConst(m_docsets)) {
-+ for (Docset *docset : std::as_const(m_docsets)) {
- if (searchQuery.hasKeywords(docset->keywords()))
- enabledDocsets << docset;
- }
-diff --git a/src/libs/ui/docsetsdialog.cpp b/src/libs/ui/docsetsdialog.cpp
-index 4e3788b..18d0409 100644
---- a/src/libs/ui/docsetsdialog.cpp
-+++ b/src/libs/ui/docsetsdialog.cpp
-@@ -687,7 +687,7 @@ QNetworkReply *DocsetsDialog::download(const QUrl &url)
-
- void DocsetsDialog::cancelDownloads()
- {
-- for (QNetworkReply *reply : qAsConst(m_replies)) {
-+ for (QNetworkReply *reply : std::as_const(m_replies)) {
- // Hide progress bar
- QListWidgetItem *listItem
- = ui->availableDocsetList->item(reply->property(ListItemIndexProperty).toInt());
-diff --git a/src/libs/ui/qxtglobalshortcut/qxtglobalshortcut_x11.cpp b/src/libs/ui/qxtglobalshortcut/qxtglobalshortcut_x11.cpp
-index a40c772..7a832ad 100644
---- a/src/libs/ui/qxtglobalshortcut/qxtglobalshortcut_x11.cpp
-+++ b/src/libs/ui/qxtglobalshortcut/qxtglobalshortcut_x11.cpp
-@@ -152,7 +152,7 @@ bool QxtGlobalShortcutPrivate::registerShortcut(quint32 nativeKey, quint32 nativ
- }
-
- bool failed = false;
-- for (xcb_void_cookie_t cookie : qAsConst(xcbCookies)) {
-+ for (xcb_void_cookie_t cookie : std::as_const(xcbCookies)) {
- QScopedPointer<xcb_generic_error_t, QScopedPointerPodDeleter> error(xcb_request_check(xcbConnection, cookie));
- failed = !error.isNull();
- }
diff --git a/app-doc/zeal/files/zeal-0.7.0-cmake.patch b/app-doc/zeal/files/zeal-0.7.0-cmake.patch
deleted file mode 100644
index c5907085f1df..000000000000
--- a/app-doc/zeal/files/zeal-0.7.0-cmake.patch
+++ /dev/null
@@ -1,317 +0,0 @@
-From 8ac4da628ff241145addb23376572d7ac13904f0 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Fri, 3 Nov 2023 15:51:09 +0100
-Subject: [PATCH 1/3] build(cmake): Set CMAKE_COMPILE_WARNING_AS_ERROR only for
- ZEAL_RELEASE_BUILD=OFF
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMakeLists.txt | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a6a31c6..dc7ffc5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -45,6 +45,10 @@ if(NOT ZEAL_RELEASE_BUILD)
- else()
- set(ZEAL_VERSION_SUFFIX "-dev")
- endif()
-+
-+ if(${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.24.0")
-+ set(CMAKE_COMPILE_WARNING_AS_ERROR ON)
-+ endif()
- endif()
-
- set(ZEAL_VERSION_FULL "${Zeal_VERSION}${ZEAL_VERSION_SUFFIX}")
-@@ -59,9 +63,5 @@ add_custom_target(zeal_version
- VERBATIM
- )
-
--if(${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.24.0")
-- set(CMAKE_COMPILE_WARNING_AS_ERROR ON)
--endif()
--
- add_subdirectory(assets)
- add_subdirectory(src)
---
-2.42.0
-
-
-From 5a2eb812a822269e836c05322de3658911ce3ba3 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Fri, 3 Nov 2023 16:01:49 +0100
-Subject: [PATCH 2/3] cmake: Import QtVersionOption.cmake from ECM (available
- since 5.82.0)
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- cmake/QtVersionOption.cmake | 36 ++++++++++++++++++++++++++++++++++++
- 1 file changed, 36 insertions(+)
- create mode 100644 cmake/QtVersionOption.cmake
-
-diff --git a/cmake/QtVersionOption.cmake b/cmake/QtVersionOption.cmake
-new file mode 100644
-index 0000000..ea37da2
---- /dev/null
-+++ b/cmake/QtVersionOption.cmake
-@@ -0,0 +1,36 @@
-+# SPDX-FileCopyrightText: 2021 Volker Krause <vkrause@kde.org>
-+#
-+# SPDX-License-Identifier: BSD-3-Clause
-+
-+#[=======================================================================[.rst:
-+QtVersionOption
-+---------------
-+
-+Adds a build option to select the major Qt version if necessary,
-+that is, if the major Qt version has not yet been determined otherwise
-+(e.g. by a corresponding ``find_package()`` call).
-+This module is typically included by other modules requiring knowledge
-+about the major Qt version.
-+
-+``QT_MAJOR_VERSION`` is defined to either be "5" or "6".
-+
-+Since 5.82.0.
-+#]=======================================================================]
-+
-+if (DEFINED QT_MAJOR_VERSION)
-+ return()
-+endif()
-+
-+if (TARGET Qt5::Core)
-+ set(QT_MAJOR_VERSION 5)
-+elseif (TARGET Qt6::Core)
-+ set(QT_MAJOR_VERSION 6)
-+else()
-+ option(BUILD_WITH_QT6 "Build against Qt 6" OFF)
-+
-+ if (BUILD_WITH_QT6)
-+ set(QT_MAJOR_VERSION 6)
-+ else()
-+ set(QT_MAJOR_VERSION 5)
-+ endif()
-+endif()
---
-2.42.0
-
-
-From 1976d46b9a2b193c34fab3d01492198a00219f54 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Fri, 3 Nov 2023 16:11:41 +0100
-Subject: [PATCH 3/3] build(cmake): Switch to ECM's QtVersionOption and
- QT_MAJOR_VERSION
-
-Module imported from KDE's ECM which is already in use by parts of this project.
-This avoids build system automagic, providing a well known default cmake switch
-to distributions.
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMakeLists.txt | 6 +++---
- assets/freedesktop/CMakeLists.txt | 2 +-
- src/app/CMakeLists.txt | 10 +++++-----
- src/libs/browser/CMakeLists.txt | 4 ++--
- src/libs/core/CMakeLists.txt | 6 +++---
- src/libs/registry/CMakeLists.txt | 4 ++--
- src/libs/sidebar/CMakeLists.txt | 4 ++--
- src/libs/ui/CMakeLists.txt | 4 ++--
- src/libs/ui/qxtglobalshortcut/CMakeLists.txt | 8 ++++----
- src/libs/ui/widgets/CMakeLists.txt | 4 ++--
- src/libs/util/CMakeLists.txt | 4 ++--
- 11 files changed, 28 insertions(+), 28 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index dc7ffc5..deb376d 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -21,9 +21,9 @@ endif()
- set(PROJECT_COMPANY_NAME "Oleg Shparber")
- set(PROJECT_COPYRIGHT "© 2013-2023 Oleg Shparber and other contributors")
-
--# Find available major Qt version. It will be stored in QT_VERSION_MAJOR.
--find_package(QT NAMES Qt6 Qt5 REQUIRED COMPONENTS Core)
--if(QT_VERSION_MAJOR EQUAL 6)
-+# Select major Qt version. It will be stored in QT_MAJOR_VERSION if not already set.
-+include(QtVersionOption)
-+if (QT_MAJOR_VERSION EQUAL "6")
- set(QT_MINIMUM_VERSION 6.2.0)
- else()
- set(QT_MINIMUM_VERSION 5.9.5)
-diff --git a/assets/freedesktop/CMakeLists.txt b/assets/freedesktop/CMakeLists.txt
-index aa1b9b5..0dfc6b6 100644
---- a/assets/freedesktop/CMakeLists.txt
-+++ b/assets/freedesktop/CMakeLists.txt
-@@ -3,7 +3,7 @@ if(UNIX AND NOT APPLE)
- set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
- include(ECMInstallIcons)
-
-- if(QT_VERSION_MAJOR EQUAL 5)
-+ if(QT_MAJOR_VERSION EQUAL 5)
- include(KDEInstallDirs)
- else()
- # Workaround until KDEInstallDirs6 is ready to use.
-diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
-index 5c0e6d1..4e2ae7e 100644
---- a/src/app/CMakeLists.txt
-+++ b/src/app/CMakeLists.txt
-@@ -1,5 +1,5 @@
--find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Widgets REQUIRED)
--if (Qt${QT_VERSION_MAJOR}Widgets_VERSION VERSION_LESS QT_MINIMUM_VERSION)
-+find_package(Qt${QT_MAJOR_VERSION} COMPONENTS Widgets REQUIRED)
-+if (Qt${QT_MAJOR_VERSION}Widgets_VERSION VERSION_LESS QT_MINIMUM_VERSION)
- message(FATAL_ERROR "Qt version >= ${QT_MINIMUM_VERSION} is required.")
- endif()
-
-@@ -14,7 +14,7 @@ set(PROJECT_EXECUTABLE_NAME "${_project_output_name}${CMAKE_EXECUTABLE_SUFFIX}")
- message(STATUS "Project executable name: ${PROJECT_EXECUTABLE_NAME}")
-
- # Only support installing runtime dependencies with Qt >=6.5.1 (see QTBUG-111741).
--if(Qt${QT_VERSION_MAJOR}Widgets_VERSION VERSION_GREATER_EQUAL "6.5.1")
-+if(Qt${QT_MAJOR_VERSION}Widgets_VERSION VERSION_GREATER_EQUAL "6.5.1")
- set(_use_qt_cmake_commands TRUE)
-
- qt_standard_project_setup()
-@@ -29,7 +29,7 @@ else()
- set(App_RESOURCES) # Silence CMake warning.
- endif()
-
--if(QT_VERSION_MAJOR EQUAL 6)
-+if(QT_MAJOR_VERSION EQUAL 6)
- qt_add_executable(App WIN32
- main.cpp
- zeal.qrc
-@@ -43,7 +43,7 @@ else()
- )
- endif()
-
--target_link_libraries(App PRIVATE Core Util Qt${QT_VERSION_MAJOR}::Widgets)
-+target_link_libraries(App PRIVATE Core Util Qt${QT_MAJOR_VERSION}::Widgets)
-
- set_target_properties(App PROPERTIES
- OUTPUT_NAME ${_project_output_name}
-diff --git a/src/libs/browser/CMakeLists.txt b/src/libs/browser/CMakeLists.txt
-index d0abfab..5690926 100644
---- a/src/libs/browser/CMakeLists.txt
-+++ b/src/libs/browser/CMakeLists.txt
-@@ -10,5 +10,5 @@ add_library(Browser STATIC
-
- target_link_libraries(Browser)
-
--find_package(Qt${QT_VERSION_MAJOR} COMPONENTS WebChannel WebEngineWidgets REQUIRED)
--target_link_libraries(Browser Qt${QT_VERSION_MAJOR}::WebChannel Qt${QT_VERSION_MAJOR}::WebEngineWidgets)
-+find_package(Qt${QT_MAJOR_VERSION} COMPONENTS WebChannel WebEngineWidgets REQUIRED)
-+target_link_libraries(Browser Qt${QT_MAJOR_VERSION}::WebChannel Qt${QT_VERSION_MAJOR}::WebEngineWidgets)
-diff --git a/src/libs/core/CMakeLists.txt b/src/libs/core/CMakeLists.txt
-index 7dfe901..76d20d3 100644
---- a/src/libs/core/CMakeLists.txt
-+++ b/src/libs/core/CMakeLists.txt
-@@ -16,10 +16,10 @@ add_definitions(-DCPPHTTPLIB_USE_POLL)
-
- target_link_libraries(Core Registry Ui)
-
--find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Network WebEngineCore Widgets REQUIRED)
--target_link_libraries(Core Qt${QT_VERSION_MAJOR}::Network Qt${QT_VERSION_MAJOR}::WebEngineCore Qt${QT_VERSION_MAJOR}::Widgets)
-+find_package(Qt${QT_MAJOR_VERSION} COMPONENTS Network WebEngineCore Widgets REQUIRED)
-+target_link_libraries(Core Qt${QT_MAJOR_VERSION}::Network Qt${QT_VERSION_MAJOR}::WebEngineCore Qt${QT_VERSION_MAJOR}::Widgets)
-
--if(QT_VERSION_MAJOR EQUAL 6)
-+if(QT_MAJOR_VERSION EQUAL 6)
- find_package(Qt6 COMPONENTS WebEngineCore Widgets REQUIRED)
- target_link_libraries(Core Qt6::WebEngineCore)
- else()
-diff --git a/src/libs/registry/CMakeLists.txt b/src/libs/registry/CMakeLists.txt
-index 2fbaba4..0a105eb 100644
---- a/src/libs/registry/CMakeLists.txt
-+++ b/src/libs/registry/CMakeLists.txt
-@@ -12,5 +12,5 @@ add_library(Registry STATIC
- searchresult.h
- )
-
--find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Concurrent Gui Network REQUIRED)
--target_link_libraries(Registry Util Qt${QT_VERSION_MAJOR}::Concurrent Qt${QT_VERSION_MAJOR}::Gui Qt${QT_VERSION_MAJOR}::Network)
-+find_package(Qt${QT_MAJOR_VERSION} COMPONENTS Concurrent Gui Network REQUIRED)
-+target_link_libraries(Registry Util Qt${QT_MAJOR_VERSION}::Concurrent Qt${QT_VERSION_MAJOR}::Gui Qt${QT_VERSION_MAJOR}::Network)
-diff --git a/src/libs/sidebar/CMakeLists.txt b/src/libs/sidebar/CMakeLists.txt
-index 133c9d9..498f654 100644
---- a/src/libs/sidebar/CMakeLists.txt
-+++ b/src/libs/sidebar/CMakeLists.txt
-@@ -7,5 +7,5 @@ add_library(Sidebar STATIC
-
- target_link_libraries(Sidebar)
-
--find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Widgets REQUIRED)
--target_link_libraries(Sidebar Qt${QT_VERSION_MAJOR}::Widgets)
-+find_package(Qt${QT_MAJOR_VERSION} COMPONENTS Widgets REQUIRED)
-+target_link_libraries(Sidebar Qt${QT_MAJOR_VERSION}::Widgets)
-diff --git a/src/libs/ui/CMakeLists.txt b/src/libs/ui/CMakeLists.txt
-index 2937c5a..cb66b98 100644
---- a/src/libs/ui/CMakeLists.txt
-+++ b/src/libs/ui/CMakeLists.txt
-@@ -23,5 +23,5 @@ add_library(Ui STATIC
-
- target_link_libraries(Ui Browser Sidebar QxtGlobalShortcut Widgets Registry)
-
--find_package(Qt${QT_VERSION_MAJOR} COMPONENTS WebEngineWidgets REQUIRED)
--target_link_libraries(Ui Qt${QT_VERSION_MAJOR}::WebEngineWidgets)
-+find_package(Qt${QT_MAJOR_VERSION} COMPONENTS WebEngineWidgets REQUIRED)
-+target_link_libraries(Ui Qt${QT_MAJOR_VERSION}::WebEngineWidgets)
-diff --git a/src/libs/ui/qxtglobalshortcut/CMakeLists.txt b/src/libs/ui/qxtglobalshortcut/CMakeLists.txt
-index f1c6a05..1120a70 100644
---- a/src/libs/ui/qxtglobalshortcut/CMakeLists.txt
-+++ b/src/libs/ui/qxtglobalshortcut/CMakeLists.txt
-@@ -21,8 +21,8 @@ endif()
-
- add_library(QxtGlobalShortcut STATIC ${QxtGlobalShortcut_SOURCES})
-
--find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Gui REQUIRED)
--target_link_libraries(QxtGlobalShortcut Qt${QT_VERSION_MAJOR}::Gui)
-+find_package(Qt${QT_MAJOR_VERSION} COMPONENTS Gui REQUIRED)
-+target_link_libraries(QxtGlobalShortcut Qt${QT_MAJOR_VERSION}::Gui)
-
- if(APPLE)
- find_library(CARBON_LIBRARY Carbon)
-@@ -30,11 +30,11 @@ if(APPLE)
- elseif(UNIX AND X11_FOUND)
- target_link_libraries(QxtGlobalShortcut ${X11_LIBRARIES})
-
-- if(QT_VERSION_MAJOR EQUAL 5)
-+ if(QT_MAJOR_VERSION EQUAL 5)
- find_package(Qt5 COMPONENTS X11Extras REQUIRED)
- target_link_libraries(QxtGlobalShortcut Qt5::X11Extras)
- else()
-- target_link_libraries(QxtGlobalShortcut Qt${QT_VERSION_MAJOR}::GuiPrivate)
-+ target_link_libraries(QxtGlobalShortcut Qt${QT_MAJOR_VERSION}::GuiPrivate)
- endif()
-
- find_package(ECM REQUIRED NO_MODULE)
-diff --git a/src/libs/ui/widgets/CMakeLists.txt b/src/libs/ui/widgets/CMakeLists.txt
-index 09d12dd..2e74e1d 100644
---- a/src/libs/ui/widgets/CMakeLists.txt
-+++ b/src/libs/ui/widgets/CMakeLists.txt
-@@ -5,5 +5,5 @@ add_library(Widgets STATIC
- toolbarframe.cpp
- )
-
--find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Widgets REQUIRED)
--target_link_libraries(Widgets Qt${QT_VERSION_MAJOR}::Widgets)
-+find_package(Qt${QT_MAJOR_VERSION} COMPONENTS Widgets REQUIRED)
-+target_link_libraries(Widgets Qt${QT_MAJOR_VERSION}::Widgets)
-diff --git a/src/libs/util/CMakeLists.txt b/src/libs/util/CMakeLists.txt
-index a9cf9a5..7829c35 100644
---- a/src/libs/util/CMakeLists.txt
-+++ b/src/libs/util/CMakeLists.txt
-@@ -9,8 +9,8 @@ add_library(Util STATIC
- caseinsensitivemap.h
- )
-
--find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Core REQUIRED)
--target_link_libraries(Util Qt${QT_VERSION_MAJOR}::Core)
-+find_package(Qt${QT_MAJOR_VERSION} COMPONENTS Core REQUIRED)
-+target_link_libraries(Util Qt${QT_MAJOR_VERSION}::Core)
-
- find_package(SQLite3 REQUIRED)
- target_link_libraries(Util SQLite::SQLite3)
---
-2.42.0
-
diff --git a/app-doc/zeal/files/zeal-0.7.0-disable-update-check.patch b/app-doc/zeal/files/zeal-0.7.0-disable-update-check.patch
deleted file mode 100644
index a24866b53c76..000000000000
--- a/app-doc/zeal/files/zeal-0.7.0-disable-update-check.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 797fa11f0e53eda7f244de3065d9efd1a7cac87b Mon Sep 17 00:00:00 2001
-From: Henning Schild <henning@hennsch.de>
-Date: Sat, 9 Mar 2019 10:29:54 +0100
-Subject: [PATCH] settings: disable checking for updates by default
-
-Signed-off-by: Henning Schild <henning@hennsch.de>
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- src/libs/core/settings.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/libs/core/settings.cpp b/src/libs/core/settings.cpp
-index 8bcc6e6..6f163c6 100644
---- a/src/libs/core/settings.cpp
-+++ b/src/libs/core/settings.cpp
-@@ -95,7 +95,7 @@ void Settings::load()
-
- // TODO: Put everything in groups
- startMinimized = settings->value(QStringLiteral("start_minimized"), false).toBool();
-- checkForUpdate = settings->value(QStringLiteral("check_for_update"), true).toBool();
-+ checkForUpdate = settings->value(QStringLiteral("check_for_update"), false).toBool();
-
- showSystrayIcon = settings->value(QStringLiteral("show_systray_icon"), true).toBool();
- minimizeToSystray = settings->value(QStringLiteral("minimize_to_systray"), false).toBool();
---
-2.42.0
-
diff --git a/app-doc/zeal/files/zeal-0.7.0-settings-disable-checking-for-updates-by-default.patch b/app-doc/zeal/files/zeal-0.7.0-settings-disable-checking-for-updates-by-default.patch
deleted file mode 100644
index bcabaae0bd49..000000000000
--- a/app-doc/zeal/files/zeal-0.7.0-settings-disable-checking-for-updates-by-default.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/libs/core/settings.cpp
-+++ b/src/libs/core/settings.cpp
-@@ -95,7 +95,7 @@ void Settings::load()
-
- // TODO: Put everything in groups
- startMinimized = settings->value(QStringLiteral("start_minimized"), false).toBool();
-- checkForUpdate = settings->value(QStringLiteral("check_for_update"), true).toBool();
-+ checkForUpdate = settings->value(QStringLiteral("check_for_update"), false).toBool();
-
- showSystrayIcon = settings->value(QStringLiteral("show_systray_icon"), true).toBool();
- minimizeToSystray = settings->value(QStringLiteral("minimize_to_systray"), false).toBool();
diff --git a/app-doc/zeal/zeal-0.7.0.ebuild b/app-doc/zeal/zeal-0.7.0.ebuild
deleted file mode 100644
index 6ad8aeb1b6a3..000000000000
--- a/app-doc/zeal/zeal-0.7.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg-utils
-
-DESCRIPTION="Offline documentation browser inspired by Dash"
-HOMEPAGE="https://zealdocs.org/"
-SRC_URI="https://github.com/zealdocs/${PN}/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-3+ CC0-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- app-arch/libarchive:=
- dev-db/sqlite:3
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5=
- dev-qt/qtnetwork:5
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtwebchannel:5
- dev-qt/qtwebengine:5[widgets]
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- x11-libs/libX11
- x11-libs/libxcb:=
- >=x11-libs/xcb-util-keysyms-0.3.9
-"
-RDEPEND="${DEPEND}
- x11-themes/hicolor-icon-theme
-"
-BDEPEND="kde-frameworks/extra-cmake-modules:*"
-
-PATCHES=(
- "${FILESDIR}/${P}-disable-update-check.patch"
- "${FILESDIR}/${P}-cmake.patch"
-)
-
-src_prepare() {
-# cat "${PATCHES[@]}" | grep '^+++' | cut -s -d / -f 2- | sort -u \
-# | while read -r file
-# do
-# dos2unix "${file}" || die "Failed to convert line endings in ${file}"
-# done
-
- cmake_src_prepare
-
- sed -i -e '/^ *set(CMAKE_COMPILE_WARNING_AS_ERROR ON)$/d' \
- CMakeLists.txt
-}
-
-src_configure() {
- local mycmakeargs=(
- -DZEAL_RELEASE_BUILD=ON
- )
- cmake_src_configure
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}