summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-11-28 13:04:30 +0100
committerUlrich Müller <ulm@gentoo.org>2020-11-28 13:19:22 +0100
commit7d4dfd08f5353f2e79b28a80a10ecd15c1867700 (patch)
tree4a710d472539afd84678e306d21bf6494f215b36 /app-editors/emacs
parentdev-python/more-itertools: Remove old (diff)
downloadgentoo-7d4dfd08f5353f2e79b28a80a10ecd15c1867700.tar.gz
gentoo-7d4dfd08f5353f2e79b28a80a10ecd15c1867700.tar.bz2
gentoo-7d4dfd08f5353f2e79b28a80a10ecd15c1867700.zip
app-editors/emacs: Fix install failure with USE="-gui aqua".
Closes: https://bugs.gentoo.org/757303 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/emacs-23.4-r20.ebuild20
-rw-r--r--app-editors/emacs/emacs-24.5-r9.ebuild20
-rw-r--r--app-editors/emacs/emacs-25.3-r8.ebuild20
-rw-r--r--app-editors/emacs/emacs-26.3-r3.ebuild20
-rw-r--r--app-editors/emacs/emacs-27.1-r2.ebuild20
-rw-r--r--app-editors/emacs/emacs-27.1.9999-r1.ebuild20
-rw-r--r--app-editors/emacs/emacs-28.0.9999.ebuild20
7 files changed, 77 insertions, 63 deletions
diff --git a/app-editors/emacs/emacs-23.4-r20.ebuild b/app-editors/emacs/emacs-23.4-r20.ebuild
index 7817b1255749..32bef55e4fff 100644
--- a/app-editors/emacs/emacs-23.4-r20.ebuild
+++ b/app-editors/emacs/emacs-23.4-r20.ebuild
@@ -301,7 +301,7 @@ src_install() {
dodoc README BUGS
- if use aqua; then
+ if use gui && use aqua; then
dodir /Applications/Gentoo
rm -rf "${ED}"/Applications/Gentoo/${EMACS_SUFFIX^}.app
mv nextstep/Emacs.app \
@@ -316,14 +316,16 @@ src_install() {
it is strongly recommended that you use app-admin/emacs-updater
to rebuild all byte-compiled elisp files of the installed Emacs
packages."
- use gui && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
- Installing media-fonts/font-adobe-{75,100}dpi on the X server's
- machine would satisfy basic Emacs requirements under X11.
- See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
- for how to enable anti-aliased fonts."
- use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
- \"${EPREFIX}/Applications/Gentoo\". You may want to copy or symlink
- it into /Applications by yourself."
+ if use gui; then
+ DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
+ Installing media-fonts/font-adobe-{75,100}dpi on the X server's
+ machine would satisfy basic Emacs requirements under X11.
+ See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
+ for how to enable anti-aliased fonts."
+ use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
+ \"${EPREFIX}/Applications/Gentoo\". You may want to copy or
+ symlink it into /Applications by yourself."
+ fi
readme.gentoo_create_doc
}
diff --git a/app-editors/emacs/emacs-24.5-r9.ebuild b/app-editors/emacs/emacs-24.5-r9.ebuild
index d205fe64db89..f52f447b679e 100644
--- a/app-editors/emacs/emacs-24.5-r9.ebuild
+++ b/app-editors/emacs/emacs-24.5-r9.ebuild
@@ -298,7 +298,7 @@ src_install() {
dodoc README BUGS
- if use aqua; then
+ if use gui && use aqua; then
dodir /Applications/Gentoo
rm -rf "${ED}"/Applications/Gentoo/${EMACS_SUFFIX^}.app
mv nextstep/Emacs.app \
@@ -312,14 +312,16 @@ src_install() {
\\n\\nIf you upgrade from Emacs version 24.2 or earlier, then it is
strongly recommended that you use app-admin/emacs-updater to rebuild
all byte-compiled elisp files of the installed Emacs packages."
- use gui && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
- Installing media-fonts/font-adobe-{75,100}dpi on the X server's
- machine would satisfy basic Emacs requirements under X11.
- See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
- for how to enable anti-aliased fonts."
- use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
- \"${EPREFIX}/Applications/Gentoo\". You may want to copy or symlink
- it into /Applications by yourself."
+ if use gui; then
+ DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
+ Installing media-fonts/font-adobe-{75,100}dpi on the X server's
+ machine would satisfy basic Emacs requirements under X11.
+ See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
+ for how to enable anti-aliased fonts."
+ use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
+ \"${EPREFIX}/Applications/Gentoo\". You may want to copy or
+ symlink it into /Applications by yourself."
+ fi
readme.gentoo_create_doc
}
diff --git a/app-editors/emacs/emacs-25.3-r8.ebuild b/app-editors/emacs/emacs-25.3-r8.ebuild
index 2deef88cebcf..466ee76552fb 100644
--- a/app-editors/emacs/emacs-25.3-r8.ebuild
+++ b/app-editors/emacs/emacs-25.3-r8.ebuild
@@ -307,7 +307,7 @@ src_install() {
dodoc README BUGS CONTRIBUTE
- if use aqua; then
+ if use gui && use aqua; then
dodir /Applications/Gentoo
rm -rf "${ED}"/Applications/Gentoo/${EMACS_SUFFIX^}.app
mv nextstep/Emacs.app \
@@ -322,14 +322,16 @@ src_install() {
it is strongly recommended that you use app-admin/emacs-updater
to rebuild all byte-compiled elisp files of the installed Emacs
packages."
- use gui && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
- Installing media-fonts/font-adobe-{75,100}dpi on the X server's
- machine would satisfy basic Emacs requirements under X11.
- See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
- for how to enable anti-aliased fonts."
- use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
- \"${EPREFIX}/Applications/Gentoo\". You may want to copy or symlink
- it into /Applications by yourself."
+ if use gui; then
+ DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
+ Installing media-fonts/font-adobe-{75,100}dpi on the X server's
+ machine would satisfy basic Emacs requirements under X11.
+ See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
+ for how to enable anti-aliased fonts."
+ use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
+ \"${EPREFIX}/Applications/Gentoo\". You may want to copy or
+ symlink it into /Applications by yourself."
+ fi
readme.gentoo_create_doc
}
diff --git a/app-editors/emacs/emacs-26.3-r3.ebuild b/app-editors/emacs/emacs-26.3-r3.ebuild
index dc65014ec5d0..80915e9112bc 100644
--- a/app-editors/emacs/emacs-26.3-r3.ebuild
+++ b/app-editors/emacs/emacs-26.3-r3.ebuild
@@ -334,7 +334,7 @@ src_install() {
dodoc README BUGS CONTRIBUTE
- if use aqua; then
+ if use gui && use aqua; then
dodir /Applications/Gentoo
rm -rf "${ED}"/Applications/Gentoo/${EMACS_SUFFIX^}.app
mv nextstep/Emacs.app \
@@ -349,14 +349,16 @@ src_install() {
it is strongly recommended that you use app-admin/emacs-updater
to rebuild all byte-compiled elisp files of the installed Emacs
packages."
- use gui && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
- Installing media-fonts/font-adobe-{75,100}dpi on the X server's
- machine would satisfy basic Emacs requirements under X11.
- See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
- for how to enable anti-aliased fonts."
- use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
- \"${EPREFIX}/Applications/Gentoo\". You may want to copy or symlink
- it into /Applications by yourself."
+ if use gui; then
+ DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
+ Installing media-fonts/font-adobe-{75,100}dpi on the X server's
+ machine would satisfy basic Emacs requirements under X11.
+ See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
+ for how to enable anti-aliased fonts."
+ use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
+ \"${EPREFIX}/Applications/Gentoo\". You may want to copy or
+ symlink it into /Applications by yourself."
+ fi
readme.gentoo_create_doc
}
diff --git a/app-editors/emacs/emacs-27.1-r2.ebuild b/app-editors/emacs/emacs-27.1-r2.ebuild
index c0a8301900b1..e6c3aef737c4 100644
--- a/app-editors/emacs/emacs-27.1-r2.ebuild
+++ b/app-editors/emacs/emacs-27.1-r2.ebuild
@@ -377,7 +377,7 @@ src_install() {
dodoc README BUGS CONTRIBUTE
- if use aqua; then
+ if use gui && use aqua; then
dodir /Applications/Gentoo
rm -rf "${ED}"/Applications/Gentoo/${EMACS_SUFFIX^}.app
mv nextstep/Emacs.app \
@@ -392,14 +392,16 @@ src_install() {
it is strongly recommended that you use app-admin/emacs-updater
to rebuild all byte-compiled elisp files of the installed Emacs
packages."
- use gui && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
- Installing media-fonts/font-adobe-{75,100}dpi on the X server's
- machine would satisfy basic Emacs requirements under X11.
- See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
- for how to enable anti-aliased fonts."
- use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
- \"${EPREFIX}/Applications/Gentoo\". You may want to copy or symlink
- it into /Applications by yourself."
+ if use gui; then
+ DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
+ Installing media-fonts/font-adobe-{75,100}dpi on the X server's
+ machine would satisfy basic Emacs requirements under X11.
+ See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
+ for how to enable anti-aliased fonts."
+ use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
+ \"${EPREFIX}/Applications/Gentoo\". You may want to copy or
+ symlink it into /Applications by yourself."
+ fi
readme.gentoo_create_doc
}
diff --git a/app-editors/emacs/emacs-27.1.9999-r1.ebuild b/app-editors/emacs/emacs-27.1.9999-r1.ebuild
index a3e4ddfa6837..8995971a50a2 100644
--- a/app-editors/emacs/emacs-27.1.9999-r1.ebuild
+++ b/app-editors/emacs/emacs-27.1.9999-r1.ebuild
@@ -376,7 +376,7 @@ src_install() {
dodoc README BUGS CONTRIBUTE
- if use aqua; then
+ if use gui && use aqua; then
dodir /Applications/Gentoo
rm -rf "${ED}"/Applications/Gentoo/${EMACS_SUFFIX^}.app
mv nextstep/Emacs.app \
@@ -391,14 +391,16 @@ src_install() {
it is strongly recommended that you use app-admin/emacs-updater
to rebuild all byte-compiled elisp files of the installed Emacs
packages."
- use gui && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
- Installing media-fonts/font-adobe-{75,100}dpi on the X server's
- machine would satisfy basic Emacs requirements under X11.
- See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
- for how to enable anti-aliased fonts."
- use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
- \"${EPREFIX}/Applications/Gentoo\". You may want to copy or symlink
- it into /Applications by yourself."
+ if use gui; then
+ DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
+ Installing media-fonts/font-adobe-{75,100}dpi on the X server's
+ machine would satisfy basic Emacs requirements under X11.
+ See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
+ for how to enable anti-aliased fonts."
+ use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
+ \"${EPREFIX}/Applications/Gentoo\". You may want to copy or
+ symlink it into /Applications by yourself."
+ fi
readme.gentoo_create_doc
}
diff --git a/app-editors/emacs/emacs-28.0.9999.ebuild b/app-editors/emacs/emacs-28.0.9999.ebuild
index 9ea17e49b558..39d49261783c 100644
--- a/app-editors/emacs/emacs-28.0.9999.ebuild
+++ b/app-editors/emacs/emacs-28.0.9999.ebuild
@@ -375,7 +375,7 @@ src_install() {
dodoc README BUGS CONTRIBUTE
- if use aqua; then
+ if use gui && use aqua; then
dodir /Applications/Gentoo
rm -rf "${ED}"/Applications/Gentoo/${EMACS_SUFFIX^}.app
mv nextstep/Emacs.app \
@@ -390,14 +390,16 @@ src_install() {
it is strongly recommended that you use app-admin/emacs-updater
to rebuild all byte-compiled elisp files of the installed Emacs
packages."
- use gui && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
- Installing media-fonts/font-adobe-{75,100}dpi on the X server's
- machine would satisfy basic Emacs requirements under X11.
- See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
- for how to enable anti-aliased fonts."
- use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
- \"${EPREFIX}/Applications/Gentoo\". You may want to copy or symlink
- it into /Applications by yourself."
+ if use gui; then
+ DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
+ Installing media-fonts/font-adobe-{75,100}dpi on the X server's
+ machine would satisfy basic Emacs requirements under X11.
+ See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
+ for how to enable anti-aliased fonts."
+ use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
+ \"${EPREFIX}/Applications/Gentoo\". You may want to copy or
+ symlink it into /Applications by yourself."
+ fi
readme.gentoo_create_doc
}