summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-07 08:28:25 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-07 08:30:02 +0200
commitcf250696dad0ad623bd8a9cc3839be96a6313908 (patch)
treea25e71ee3de3dbeadb9da8ec2c819c77acb88044 /app-editors/joe/joe-4.2.ebuild
parentmedia-gfx/xdot: add xdot-0.5 (diff)
downloadgentoo-cf250696dad0ad623bd8a9cc3839be96a6313908.tar.gz
gentoo-cf250696dad0ad623bd8a9cc3839be96a6313908.tar.bz2
gentoo-cf250696dad0ad623bd8a9cc3839be96a6313908.zip
app-editors/joe: Bump to version 4.2
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-editors/joe/joe-4.2.ebuild')
-rw-r--r--app-editors/joe/joe-4.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-editors/joe/joe-4.2.ebuild b/app-editors/joe/joe-4.2.ebuild
new file mode 100644
index 000000000000..cc41552c9a42
--- /dev/null
+++ b/app-editors/joe/joe-4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="xterm"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND="xterm? ( >=x11-terms/xterm-239 )"
+
+DOCS=( README.md NEWS.md docs/hacking.md docs/man.md )
+
+src_prepare() {
+ default
+ # Enable xterm mouse support in the rc files
+ if use xterm; then
+ cd "${S}"/rc
+ for i in *rc*.in; do
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die "sed failed"
+ done
+ fi
+}
+
+pkg_postinst() {
+ if use xterm; then
+ elog "To enable full xterm clipboard you need to set the allowWindowOps"
+ elog "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
+ elog "This is false by default due to potential security problems on some"
+ elog "architectures (see bug #91453)."
+ fi
+}