summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-02-05 10:06:53 +0100
committerAmy Liffey <amynka@gentoo.org>2017-02-05 10:07:34 +0100
commit6d298803f93db024f9fe3aba42055ed5442858cc (patch)
treeba6c2d5320cd940262218a8240d64650b916d09d /app-editors/joe/joe-4.4.ebuild
parentgnome-base/gnome-control-center: Needs autoconf-archive (diff)
downloadgentoo-6d298803f93db024f9fe3aba42055ed5442858cc.tar.gz
gentoo-6d298803f93db024f9fe3aba42055ed5442858cc.tar.bz2
gentoo-6d298803f93db024f9fe3aba42055ed5442858cc.zip
app-editors/joe: version bump 4.4 bug #606930
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-editors/joe/joe-4.4.ebuild')
-rw-r--r--app-editors/joe/joe-4.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-editors/joe/joe-4.4.ebuild b/app-editors/joe/joe-4.4.ebuild
new file mode 100644
index 000000000000..f7249327fdba
--- /dev/null
+++ b/app-editors/joe/joe-4.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="https://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1+ CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="xterm"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2:0="
+RDEPEND="${DEPEND}
+ xterm? ( >=x11-terms/xterm-239 )"
+
+DOCS=( README.md NEWS.md docs/hacking.md docs/man.md )
+
+PATCHES=( "${FILESDIR}/${PN}-4.3-tinfo.patch" )
+
+src_prepare() {
+ default
+ # Enable xterm mouse support in the rc files
+ if use xterm; then
+ pushd "${S}"/rc &>/dev/null || die
+ local i
+ for i in *rc*.in; do
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die
+ done
+ popd &>/dev/null
+ fi
+ eautoreconf
+}
+
+pkg_postinst() {
+ if use xterm; then
+ elog "To enable full xterm clipboard you need to set the allowWindowOps"
+ elog "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
+ elog "This is false by default due to potential security problems on some"
+ elog "architectures (see bug #91453)."
+ fi
+}