summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-20 15:43:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-20 16:19:37 +0200
commitaf63aa7ded6c3e4ced83e871084ead870229957e (patch)
treed890c799ceed8c4ea582d6c486bdb1de2aeb3829 /app-editors/kile
parentsci-libs/shapelib: Add missing slot operator on sci-libs/proj (diff)
downloadgentoo-af63aa7ded6c3e4ced83e871084ead870229957e.tar.gz
gentoo-af63aa7ded6c3e4ced83e871084ead870229957e.tar.bz2
gentoo-af63aa7ded6c3e4ced83e871084ead870229957e.zip
app-editors/kile: 2.9.93 version bump
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/kile')
-rw-r--r--app-editors/kile/Manifest1
-rw-r--r--app-editors/kile/files/kile-2.9.93-cmake.patch20
-rw-r--r--app-editors/kile/kile-2.9.93.ebuild66
3 files changed, 87 insertions, 0 deletions
diff --git a/app-editors/kile/Manifest b/app-editors/kile/Manifest
index 223d9f046860..be88a52da8bf 100644
--- a/app-editors/kile/Manifest
+++ b/app-editors/kile/Manifest
@@ -1 +1,2 @@
DIST kile-2.9.92_p20190716.tar.xz 6176728 BLAKE2B cc6b5f12c7798c806a1e78b79c32e90a3f713d65429afbddfbf75a3a666cfbea75d32be1c2e7d15ce2e414301473f03168e84428bcec161cfd12ceeba674add3 SHA512 614d6aba168f47af41e6a352e7ad838c187945b857c19654ce40ea80c359e5d88a184f1ab02b404c022b897f8ac6f3a61323c9d1043fbb0412eb3d16690e40bb
+DIST kile-2.9.93.tar.bz2 8580239 BLAKE2B a43f160240dfdffc23c6898385994ee4e49e1f3d793915d1f392e41f606350269f2b9e80592c373680adb56454510abdd0b7e69131f20737fb5efa54d4eaa111 SHA512 d87277b8ef16c82cfd415dd191916641fa1a25e316e1eb2c463b275d3654dcfe180bea03027589ab30cd8b769d92d97005846a78aff8058bcfb20eed76287504
diff --git a/app-editors/kile/files/kile-2.9.93-cmake.patch b/app-editors/kile/files/kile-2.9.93-cmake.patch
new file mode 100644
index 000000000000..94e39c463517
--- /dev/null
+++ b/app-editors/kile/files/kile-2.9.93-cmake.patch
@@ -0,0 +1,20 @@
+I know upstream wants to help us but it doesn't work...
+
+--- a/CMakeLists.txt 2019-10-19 14:23:41.000000000 +0200
++++ b/CMakeLists.txt 2019-10-20 15:50:52.606325681 +0200
+@@ -116,15 +116,6 @@
+ kile2.0-5_upd.pl
+ DESTINATION ${KDE_INSTALL_DATAROOTDIR}/kconf_update)
+
+-install(FILES
+- AUTHORS
+- ChangeLog
+- README
+- README.cwl
+- kile-remote-control.txt
+- README.MacOSX
+- DESTINATION ${KDE_INSTALL_DATAROOTDIR}/doc/kile)
+-
+ feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
+ find_package(KF5I18n CONFIG REQUIRED)
+ ki18n_install(po)
diff --git a/app-editors/kile/kile-2.9.93.ebuild b/app-editors/kile/kile-2.9.93.ebuild
new file mode 100644
index 000000000000..ad69bc67ec67
--- /dev/null
+++ b/app-editors/kile/kile-2.9.93.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Latex Editor and TeX shell based on KDE Frameworks"
+HOMEPAGE="https://kile.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="FDL-1.2 GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pdf +png"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdoctools)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep okular)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qttest)
+ $(add_qt_dep qtwidgets)
+ pdf? ( app-text/poppler[qt5] )
+"
+RDEPEND="${DEPEND}
+ !app-editors/kile:4
+ $(add_kdeapps_dep konsole)
+ $(add_kdeapps_dep okular 'pdf?')
+ virtual/latex-base
+ virtual/tex-base
+ pdf? (
+ >=app-text/texlive-core-2014
+ app-text/ghostscript-gpl
+ )
+ png? (
+ app-text/dvipng
+ virtual/imagemagick-tools[png?]
+ )
+"
+
+DOCS=( AUTHORS ChangeLog kile-remote-control.txt README{,.cwl} )
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package pdf Poppler)
+ )
+
+ kde5_src_configure
+}