summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-25 01:06:06 +0000
committerSam James <sam@gentoo.org>2022-01-25 01:06:06 +0000
commit1f1a40a417c7706d03a9d87ed2bf1550fbb92c02 (patch)
tree304985048a0ad7c7f85fd0f504813996eda650e3 /app-editors
parentgames-board/gnome-mahjongg: fix build with meson 0.61 (diff)
downloadgentoo-1f1a40a417c7706d03a9d87ed2bf1550fbb92c02.tar.gz
gentoo-1f1a40a417c7706d03a9d87ed2bf1550fbb92c02.tar.bz2
gentoo-1f1a40a417c7706d03a9d87ed2bf1550fbb92c02.zip
app-editors/gedit: fix build with meson 0.61
Closes: https://bugs.gentoo.org/831925 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit/files/40.1-fix-meson-0.61.patch29
-rw-r--r--app-editors/gedit/gedit-40.1.ebuild4
2 files changed, 32 insertions, 1 deletions
diff --git a/app-editors/gedit/files/40.1-fix-meson-0.61.patch b/app-editors/gedit/files/40.1-fix-meson-0.61.patch
new file mode 100644
index 000000000000..cac046067cb2
--- /dev/null
+++ b/app-editors/gedit/files/40.1-fix-meson-0.61.patch
@@ -0,0 +1,29 @@
+https://gitlab.gnome.org/GNOME/gedit/-/merge_requests/124.patch
+https://bugs.gentoo.org/831925
+
+From c6c7c6580bc7f82a7d449b8ee33ae44f8b6f4a1f Mon Sep 17 00:00:00 2001
+From: rvalue <i@rvalue.moe>
+Date: Wed, 15 Dec 2021 07:02:09 +0000
+Subject: [PATCH] Remove incorrect args for i18n.merge_file
+
+The positional argument has been silently ignored for a time. And it causes failure
+with "ERROR: Function does not take positional arguments" since meson 0.60.0
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -4,7 +4,6 @@ install_man('gedit.1')
+
+ appdata = 'org.gnome.gedit.appdata.xml'
+ appdata_file = i18n.merge_file(
+- appdata,
+ input: appdata + '.in',
+ output: appdata,
+ po_dir: '../po/',
+@@ -23,7 +22,6 @@ endif
+
+ desktop_file = 'org.gnome.gedit.desktop'
+ desktop_output_file = i18n.merge_file(
+- desktop_file,
+ type: 'desktop',
+ input: desktop_file + '.in',
+ output: desktop_file,
+GitLab
diff --git a/app-editors/gedit/gedit-40.1.ebuild b/app-editors/gedit/gedit-40.1.ebuild
index faf11bb7ae49..07697d136123 100644
--- a/app-editors/gedit/gedit-40.1.ebuild
+++ b/app-editors/gedit/gedit-40.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -58,6 +58,8 @@ PATCHES=(
# Make gspell and python optional
"${FILESDIR}"/3.38-make-gspell-optional.patch
"${FILESDIR}"/3.38-make-python-optional.patch
+
+ "${FILESDIR}"/${PV}-fix-meson-0.61.patch
)
pkg_setup() {