summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-05 04:36:08 +0100
committerSam James <sam@gentoo.org>2021-07-05 04:36:08 +0100
commit40b1116979f9c8def20e31892d200297a2d7d5e6 (patch)
tree8c2c161379803115f6cfcb5f93b020a968d351bd /app-editors
parentapp-editors/neovim: add 0.5.0 (diff)
downloadgentoo-40b1116979f9c8def20e31892d200297a2d7d5e6.tar.gz
gentoo-40b1116979f9c8def20e31892d200297a2d7d5e6.tar.bz2
gentoo-40b1116979f9c8def20e31892d200297a2d7d5e6.zip
app-editors/neovim: sync live ebuild
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index d8873b59f067..0b1eed9a36fc 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0 vim"
@@ -46,12 +46,10 @@ DEPEND="${LUA_DEPS}
$(lua_gen_cond_dep '
dev-lua/LuaBitOp[${LUA_USEDEP}]
' lua5-{1,2})
- dev-libs/libutf8proc:=
dev-libs/libuv:0=
>=dev-libs/libvterm-0.1.2
dev-libs/msgpack:0=
dev-libs/tree-sitter:=
- net-libs/libnsl
tui? (
dev-libs/libtermkey
>=dev-libs/unibilium-2.0.0:0=
@@ -65,6 +63,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
"${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
+ "${FILESDIR}/${PN}-0.4.4-cmake-darwin.patch"
)
src_prepare() {
@@ -82,6 +81,7 @@ src_configure() {
# if we want it on (not just -flto)
# ... but allow turning it off.
local mycmakeargs=(
+ -DUSE_BUNDLED=OFF
-DENABLE_LTO=$(usex lto)
-DFEAT_TUI=$(usex tui)
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")