summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-10 09:21:13 +0100
committerSam James <sam@gentoo.org>2023-06-10 09:52:04 +0100
commit50219f6e18cd71c2961cd9f488857a03c0d9e1ab (patch)
treee6b48aa63a7ee20743a74fe96acc2fdc3a237af0 /app-editors
parentdev-python/botocore: Remove old (diff)
downloadgentoo-50219f6e18cd71c2961cd9f488857a03c0d9e1ab.tar.gz
gentoo-50219f6e18cd71c2961cd9f488857a03c0d9e1ab.tar.bz2
gentoo-50219f6e18cd71c2961cd9f488857a03c0d9e1ab.zip
app-editors/micro: add 2.0.11
Bug: https://bugs.gentoo.org/844307 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/micro/Manifest2
-rw-r--r--app-editors/micro/micro-2.0.11.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/micro/Manifest b/app-editors/micro/Manifest
index 138eb4d8bb40..3cca71826773 100644
--- a/app-editors/micro/Manifest
+++ b/app-editors/micro/Manifest
@@ -88,4 +88,6 @@ DIST gopkg.in%2Fyaml.v2%2F@v%2Fv2.2.7.zip 80579 BLAKE2B d5de9f0dbf72902ec2244971
DIST layeh.com%2Fgopher-luar%2F@v%2Fv1.0.7.mod 109 BLAKE2B 08629b072202d338d461af7142fd4049b4db1c2df5997c995edfa9b12b2db2df0da8160db7032bc84215c742ad67021910b2fa3ec87c33c14fec309a137cb174 SHA512 b2ec68ffa8d8e747ebfc1f6103ec980c0e02d372a50d44c1ca289688cceb41006443c02c937975bf5847460a6a071d17f1f0c8ee7549fa1cf4eccdf848020ac2
DIST layeh.com%2Fgopher-luar%2F@v%2Fv1.0.7.zip 36857 BLAKE2B c4ff2a1bbc2dc984fc24065f71b560cbdda220b78d88cff9ed5a91654984cd56c9e85b64a416c140e4b01bfda75734f7c77f882e3fb45a0227b3f47cc02781c8 SHA512 94b70a83a31acde7232223ca82d6588716b39d6463baf5f15d921a5bc24a7d9b98307b8d44d3bbc9a5a82f6e4111b2b9ba1c15ee313a3784a30d63fe5d198bd3
DIST micro-2.0.10.tar.gz 814030 BLAKE2B 8becaf7caa167747443e1aa3af32e96588af275d2b921fa88fe9d55b4eec22622cf7a68d85d47834159042100414855c5bb3f8b9f7c8d934f762ec63f4d40435 SHA512 06796270a6d99578ac36f3313dffb6ba56c5e8963c6b59562b4ef9e65036ae2ed21ce602b39ee08d2f3c54c501089166fdecc5719a1ca535d84960b3b4b67f72
+DIST micro-2.0.11-deps.tar.xz 19390200 BLAKE2B 3f4e3a60395854e1dcba0ed69c7f6b95d7e1efa6897da01232e66b253a0ef2f88c29cc9628ddcc569dc5d4bc63ed21866fb5861ffdfb4de61ae5654f4b6a7ae4 SHA512 c4fcd2ce5d8e85bdaf969d7d2fec5b526ea650b7a58649dd3546f0164b10478e248eaeb1cf4fe371f44ff0a3cd70541e1c4751d01ac33a49a6bd853f78941436
+DIST micro-2.0.11.tar.gz 549261 BLAKE2B 30c21d7747870a9a85a8fb552ec9035af5c42232f4d2ee0744c24671e78ee22ff5eea803fbc19fac704b49644df0597538950b735f955eecc921e681c0ad924c SHA512 3aa3dd10baaec9fa73b5c673c3d29eb8b4d04b468e36866118bcfc70dd638c50e56d51fc6085dcc7441a2ce0d9bbf742c37fd26a7e2b92d8b20844c8a7b53487
DIST micro-2.0.9.tar.gz 811560 BLAKE2B 2e461593e71fda69a6f75e5adfaedd7bcf052b8bda9899f03a1e25e3db3bb8071bec80716d14a0ff7a381728871f0705076ef69e4de58f40499a7501343b4063 SHA512 5dbf81deb734618ec0a8ccaffc65f972d8da1d28b761c31bf3f5433c02ad6daa2360b1ea825c0a2cfce2f8d31d6481d468bbe29b42e1c96083c7a941fe42bc3a
diff --git a/app-editors/micro/micro-2.0.11.ebuild b/app-editors/micro/micro-2.0.11.ebuild
new file mode 100644
index 000000000000..ad2569b67bc2
--- /dev/null
+++ b/app-editors/micro/micro-2.0.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module optfeature desktop xdg
+
+DESCRIPTION="Modern and intuitive terminal-based text editor"
+HOMEPAGE="https://github.com/zyedidia/micro"
+SRC_URI="https://github.com/zyedidia/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="dev-vcs/git"
+
+src_compile() {
+ go build -v -work -x -o ${PN} -ldflags \
+ "-X github.com/zyedidia/micro/v2/internal/util.Version=${PV} -X github.com/zyedidia/micro/v2/internal/util.CompileDate=$(date -u +%Y-%m-%dT%H:%M:%SZ)" \
+ ./cmd/micro || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ./assets/packaging/micro.1
+ domenu assets/packaging/micro.desktop
+ einstalldocs
+}
+
+pkg_postinst() {
+ # Update desktop file mime cache
+ xdg_pkg_postinst
+
+ optfeature_header "Clipboard support with display servers:"
+ optfeature "Xorg" x11-misc/xsel x11-misc/xclip
+ optfeature "Wayland" gui-apps/wl-clipboard
+}