summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2023-07-18 11:24:44 +0200
committerMatt Turner <mattst88@gentoo.org>2023-07-18 12:52:11 -0400
commit8a167187ad2246efe415781c562c8b4350d40a48 (patch)
tree009423393a165b61fb28fd5646566847a05523e5 /app-editors
parentapp-crypt/tpm-emulator: Remove last rited packaged (diff)
downloadgentoo-8a167187ad2246efe415781c562c8b4350d40a48.tar.gz
gentoo-8a167187ad2246efe415781c562c8b4350d40a48.tar.bz2
gentoo-8a167187ad2246efe415781c562c8b4350d40a48.zip
app-editors/gnome-latex: Version bump to 3.45.1
Bug: https://bugs.gentoo.org/910060 Closes: https://github.com/gentoo/gentoo/pull/31940 Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gnome-latex/Manifest1
-rw-r--r--app-editors/gnome-latex/gnome-latex-3.45.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/gnome-latex/Manifest b/app-editors/gnome-latex/Manifest
index c3cb978fa360..8eaf28d31a57 100644
--- a/app-editors/gnome-latex/Manifest
+++ b/app-editors/gnome-latex/Manifest
@@ -1 +1,2 @@
DIST gnome-latex-3.44.0.tar.xz 1168840 BLAKE2B 7eb34502a9bcdcbb5c8e2d8336a3029fad1cdd1da0cbd704fae4de44a3aab913ed43228172dfe7798c7a513a61664fd8af97df0aff66d62f8502edbe845ac12f SHA512 d1dc7b2321438ebed7a209c7c750123a0dcf8ebcf92f73fd7eb4c79282f51d6b6a8328ee8759326f43e53dbd2ba9d1fadc056c2fcea11e7785e7c27574707e95
+DIST gnome-latex-3.45.1.tar.xz 1216388 BLAKE2B e56c176a81b85bdd7965c9a96dd62a3208264c10f2cd425e26376b6ee4a00adf45b3af29b5e66a2a71b433a21a3eda8f67b8448194e18994f9afa304a40cd4d9 SHA512 2ed4d61029809dea4e040830ba1b0a9556fc65ac4d76803e0115581600e889a4716ddb36971b4162ee91372fcf5361191c0eda4961d82b97816e9a1ac3994dac
diff --git a/app-editors/gnome-latex/gnome-latex-3.45.1.ebuild b/app-editors/gnome-latex/gnome-latex-3.45.1.ebuild
new file mode 100644
index 000000000000..2f8845e6c4f9
--- /dev/null
+++ b/app-editors/gnome-latex/gnome-latex-3.45.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/swilmet/gnome-latex"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+introspection +latexmk rubber"
+
+DEPEND="
+ >=dev-libs/glib-2.70:2
+ >=x11-libs/gtk+-3.22:3
+ >=app-text/gspell-1.8:0=
+ >=gui-libs/amtk-5.6:=
+ >=gui-libs/tepl-6.5.1:=
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ gnome-base/dconf
+"
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.6:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-dconf_migration
+}