summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-08-13 21:34:23 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-13 21:34:23 +0300
commit8ecc5fdb1c70572561888c6a4b72683e2e6624d1 (patch)
tree7e071590b2d3a18a54f93c54067b8806540aa9eb /app-editors
parentapp-arch/7zip: add 24.08 (diff)
downloadgentoo-8ecc5fdb1c70572561888c6a4b72683e2e6624d1.tar.gz
gentoo-8ecc5fdb1c70572561888c6a4b72683e2e6624d1.tar.bz2
gentoo-8ecc5fdb1c70572561888c6a4b72683e2e6624d1.zip
app-editors/vscodium: add 1.92.1.24225
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.92.1.24225.ebuild128
2 files changed, 131 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index 3e077bb5275e..56f57e1e63ca 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -4,3 +4,6 @@ DIST vscodium-1.91.0.24190-arm64.tar.gz 128404095 BLAKE2B c60ced0c7f4d9d7bc38eaa
DIST vscodium-1.91.1.24193-amd64.tar.gz 128383899 BLAKE2B d51c4c502540107f196a6e89b03a4b4602b4b79ace646828e11abe3387d1f188d3dad27f4f47b8a08200b1d993c494ae5c36aadc86fb30da30f01c137622b417 SHA512 8d3d9497076cea4ed26bb111ce6d19eb542e3f5a4dc458493781077f0249fac7bca91015de3b3b6150a0992e41243a2d93ea1b4f628895c787e2abd1136f68bd
DIST vscodium-1.91.1.24193-arm.tar.gz 116984757 BLAKE2B 059eb90563300015d65c9cdb4795bbef68d549fac1d507178f7f7fdfd33131a6f9af39e881d8f2090534d6289c11139b4478a9fb3dbc850f399debfb851b842b SHA512 f49a23877279192707620c08091c79e7a7025882e54df9187ac460465d13b2727ba2bf5869a3a679451e6150d0df3fb35679c7184734332fefb26008f11b3d87
DIST vscodium-1.91.1.24193-arm64.tar.gz 128400491 BLAKE2B 652d79c401d675fa1f82bf12f23729bb5ec3e3420752e5e57c0aea14fd9651d674f4b93013ed64ea9a4baaf61ab5b4016afc4f8ca8222d8ae5d80f6bbd80a397 SHA512 1143c709a649c635a6b9231c7047a2204e72b442c105a764c0baff0bbd2d4e5d1ebf251f83f930f9a01c60112f399e135cb21df71ba8e627a8e0d2694b7b890b
+DIST vscodium-1.92.1.24225-amd64.tar.gz 130846082 BLAKE2B c16bfb6c359d4a31ea016e0e545747e1f288db984592995d032db0a143b1b1c1db43ddcd0ca8cd977cebd467c7408467cb87e26288be6b0db46bd891657580bc SHA512 84c1722f98ccda8e729bfd9e7663ed0aeff7f65d2ff034ebfbb8d6eb38c9901737bb2e0c411d471982451fa8c5bd6b8f4b3f99e52b8c4ce2dec2efc499bc86c3
+DIST vscodium-1.92.1.24225-arm.tar.gz 119303418 BLAKE2B 9a804be292104e4f65c0e75eade99bd9c4924f389fcabc4ab26eac500103a391e199133c1317b8b222bb63e6172d2009abbf0d2d8d83faadc8efff800a199db9 SHA512 1152be3718b488a4787a8efa3bece3e96c3d7e24f336e70aa453d40c584d5a76021a78c112c2f54948f0480fc523426d661c56f8c0b03dab7c7ec282c73fccc4
+DIST vscodium-1.92.1.24225-arm64.tar.gz 130894367 BLAKE2B ff18c7c13f17ebdc1bca0037c68a68820b9ee2c46c67357a7967e431924ee8578fa3b4a657cc7916dd163de9460dbafece478f5f414ff43f54863888fa4a265d SHA512 688fed5cc2e1123e7e4a03442e6cdfdc4777233cab53838123186b32ac48ba86b9e5d39921628aaec2825443050fa681d599e9310de67b799f7afbd8d9adcf60
diff --git a/app-editors/vscodium/vscodium-1.92.1.24225.ebuild b/app-editors/vscodium/vscodium-1.92.1.24225.ebuild
new file mode 100644
index 000000000000..4bf914823a45
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.92.1.24225.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+# Usage: arch_src_uri <gentoo arch> <upstream arch>
+arch_src_uri() {
+ echo "${1}? (
+ https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-${2}-${PV}.tar.gz
+ -> ${P}-${1}.tar.gz
+ )"
+}
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ $(arch_src_uri amd64 x64)
+ $(arch_src_uri arm armhf)
+ $(arch_src_uri arm64 arm64)
+"
+S="${WORKDIR}"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* amd64 ~arm ~arm64"
+IUSE="egl kerberos wayland"
+RESTRICT="strip bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+ kerberos? ( app-crypt/mit-krb5 )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ # Cleanup license file - it exists only in amd64 tarball
+ rm -f "${S}/resources/app/LICENSE.txt" || die
+
+ if ! use kerberos; then
+ rm -rf "${S}/resources/app/node_modules.asar.unpacked/kerberos" || die
+ fi
+
+ # Install
+ pax-mark m codium
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym -r "/opt/${PN}/bin/codium" "usr/bin/codium"
+
+ local EXEC_EXTRA_FLAGS=()
+ if use wayland; then
+ EXEC_EXTRA_FLAGS+=( "--ozone-platform-hint=auto" )
+ fi
+ if use egl; then
+ EXEC_EXTRA_FLAGS+=( "--use-gl=egl" )
+ fi
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/vscodium-url-handler.desktop" \
+ > "${T}/vscodium-url-handler.desktop" || die
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/vscodium.desktop" \
+ > "${T}/vscodium.desktop" || die
+
+ domenu "${T}/vscodium.desktop"
+ domenu "${T}/vscodium-url-handler.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/docs/index.md"
+ optfeature "desktop notifications" x11-libs/libnotify
+ optfeature "keyring support inside vscode" "virtual/secret-service"
+}