summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-01-20 11:09:49 +0000
committerMatthew Smith <matthew@gentoo.org>2024-01-20 11:09:49 +0000
commita14a0b3d80f7f735e3315292174f2027ff589251 (patch)
tree97587eb43fa102bcc324bf6d2bae9bd5b7fe9c1d /app-editors
parentwww-apps/gitea: add 1.21.4 (diff)
downloadgentoo-a14a0b3d80f7f735e3315292174f2027ff589251.tar.gz
gentoo-a14a0b3d80f7f735e3315292174f2027ff589251.tar.bz2
gentoo-a14a0b3d80f7f735e3315292174f2027ff589251.zip
app-editors/emacs: skip brittle treesit tests
Closes: https://bugs.gentoo.org/922525 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-29.2.9999.ebuild8
-rw-r--r--app-editors/emacs/emacs-29.2.ebuild8
-rw-r--r--app-editors/emacs/emacs-30.0.9999.ebuild8
3 files changed, 24 insertions, 0 deletions
diff --git a/app-editors/emacs/emacs-29.2.9999.ebuild b/app-editors/emacs/emacs-29.2.9999.ebuild
index e1e4debdc81e..1919adfa22cc 100644
--- a/app-editors/emacs/emacs-29.2.9999.ebuild
+++ b/app-editors/emacs/emacs-29.2.9999.ebuild
@@ -425,6 +425,14 @@ src_test() {
# Reason: tries to access network
# internet-is-working
%src/process-tests.el
+
+ # Reason: fails with stable version of tree-sitter-json due to
+ # ast changes. Bug #922525
+ %src/treesit-tests.log
+
+ # Reason: test is not skipped if tree-sitter-tsx is not installed
+ # Bug #922525
+ %lisp/progmodes/typescript-ts-mode-tests.el
)
use threads || exclude_tests+=(
%lisp/server-tests.el
diff --git a/app-editors/emacs/emacs-29.2.ebuild b/app-editors/emacs/emacs-29.2.ebuild
index 876631c7e678..1d369b00aca6 100644
--- a/app-editors/emacs/emacs-29.2.ebuild
+++ b/app-editors/emacs/emacs-29.2.ebuild
@@ -428,6 +428,14 @@ src_test() {
# Reason: tries to access network
# internet-is-working
%src/process-tests.el
+
+ # Reason: fails with stable version of tree-sitter-json due to
+ # ast changes. Bug #922525
+ %src/treesit-tests.log
+
+ # Reason: test is not skipped if tree-sitter-tsx is not installed
+ # Bug #922525
+ %lisp/progmodes/typescript-ts-mode-tests.el
)
use threads || exclude_tests+=(
%lisp/server-tests.el
diff --git a/app-editors/emacs/emacs-30.0.9999.ebuild b/app-editors/emacs/emacs-30.0.9999.ebuild
index d0bc42272a6f..73f31fed6ec7 100644
--- a/app-editors/emacs/emacs-30.0.9999.ebuild
+++ b/app-editors/emacs/emacs-30.0.9999.ebuild
@@ -427,6 +427,14 @@ src_test() {
# Reason: tries to access network
# internet-is-working
%src/process-tests.el
+
+ # Reason: fails with stable version of tree-sitter-json due to
+ # ast changes. Bug #922525
+ %src/treesit-tests.log
+
+ # Reason: test is not skipped if tree-sitter-tsx is not installed
+ # Bug #922525
+ %lisp/progmodes/typescript-ts-mode-tests.el
)
use threads || exclude_tests+=(
%lisp/server-tests.el