summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-24 19:16:20 -0400
committerMatt Turner <mattst88@gentoo.org>2023-03-24 19:17:39 -0400
commitc9dfdda62ca9342d8220a4f1707c33d1e203b5c0 (patch)
tree7295f9bc538b440305841978da110ddf6ecb9b60 /app-editors
parentdev-python/importlib_resources: drop myself as a maintainer (diff)
downloadgentoo-c9dfdda62ca9342d8220a4f1707c33d1e203b5c0.tar.gz
gentoo-c9dfdda62ca9342d8220a4f1707c33d1e203b5c0.tar.bz2
gentoo-c9dfdda62ca9342d8220a4f1707c33d1e203b5c0.zip
app-editors/ghex: Version bump to 44.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ghex/Manifest1
-rw-r--r--app-editors/ghex/ghex-44.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index cc0c8b4eac27..1c94b1e128c1 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1,3 +1,4 @@
DIST ghex-43.0.tar.xz 1020716 BLAKE2B e4b6590f9af11d6fbec31266ef9959b827937697eebd02a942b85e0c0d51555ced79ab84b34c4ab42b5cbb6d6071390d00cd0177e7e712e33e240b3132749a19 SHA512 4150d33ea1dc40d0c051ba1ba4a4829d084a4aa6ed682bade5b3e039a90049c4d009183e78b06768946b516386aa9e41b888eca61c40d96336d7ab4dd37b395b
DIST ghex-43.1.tar.xz 1021548 BLAKE2B 18e9ee5287180475ccb03343fa3d59d17578c0251e03362f2ea43bf26529fdd1691b71c7d66c18fea7d1146fa05a17c3e3e1267d897887c2cd4a766b67044803 SHA512 8ec171921084faa9fce2fe42459dc53b0217a67c775cfbb547096d095820f0a39c5683f441de9b32de178443f39d58fc49dc94bffcdf92c0540b8e5e1fe86ef3
+DIST ghex-44.0.tar.xz 1070300 BLAKE2B 9226cd7d499c159341864b13293d4517de83d51be49445b99cf0376c4ab84f8dbd229e59c4a81fe582b5a433d9734747f97c9ac4dde1627b74bee60da8510c98 SHA512 2c199daa37eb30d3c9e50f972fa5aeff5e6e4e8420dc6cac89abb8c400e74b10bd5586e30aa137f41adb5f9e151849a3dd4397b74fdf7930923f07a2420f1974
DIST ghex-44.rc.tar.xz 1070232 BLAKE2B e28c746adb517e88206922ea4bea50485189e180037316cd09960e084bdd5a47da08a444a437f96fded50a11b238801d6e7aa90977a646f3d1d5e51e9275fc3b SHA512 6ff7b69ad8d8688b9d44716e733a7a2444bd328871b00ca034df21e3fb7f9df55924f4452af4d284ced13316b01f4272db37a8192b222b30001aa354aacdc23a
diff --git a/app-editors/ghex/ghex-44.0.ebuild b/app-editors/ghex/ghex-44.0.ebuild
new file mode 100644
index 000000000000..7d5199d0588b
--- /dev/null
+++ b/app-editors/ghex/ghex-44.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4
+ gui-libs/libadwaita:1
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}