summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-04-12 18:40:33 +0200
committerUlrich Müller <ulm@gentoo.org>2021-04-12 19:51:57 +0200
commited9c8b24cfda0d0ecced67d8c5034b1facc81550 (patch)
tree3bb213dffe9892276f1545816de580ba08088f59 /app-emacs/chess/chess-2.0.5.ebuild
parentapp-emacs/whine: Trivial EAPI 7 bump (diff)
downloadgentoo-ed9c8b24cfda0d0ecced67d8c5034b1facc81550.tar.gz
gentoo-ed9c8b24cfda0d0ecced67d8c5034b1facc81550.tar.bz2
gentoo-ed9c8b24cfda0d0ecced67d8c5034b1facc81550.zip
app-emacs/chess: Version bump to 2.0.5
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/chess/chess-2.0.5.ebuild')
-rw-r--r--app-emacs/chess/chess-2.0.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/chess/chess-2.0.5.ebuild b/app-emacs/chess/chess-2.0.5.ebuild
new file mode 100644
index 000000000000..464c4f8a75e1
--- /dev/null
+++ b/app-emacs/chess/chess-2.0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A chess client and library for Emacs"
+HOMEPAGE="https://elpa.gnu.org/packages/chess.html
+ https://www.emacswiki.org/emacs/ChessMode"
+# Taken from https://elpa.gnu.org/packages/${P}.tar
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~ulm/distfiles/emacs-chess-sounds-${PV%.*}.tar.bz2
+ https://dev.gentoo.org/~ulm/distfiles/emacs-chess-pieces-${PV%.*}.tar.bz2"
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Free alternatives first, otherwise follow the ordering in the upstream
+# chess-default-engine (in chess.el). Rearrange chess-default-engine in
+# the site-init file accordingly.
+RDEPEND="|| ( games-board/stockfish
+ games-board/fruit
+ games-board/gnuchess
+ games-board/phalanx
+ games-board/sjeng
+ games-board/crafty )"
+
+ELISP_REMOVE="chess-pkg.el"
+SITEFILE="50${PN}-gentoo-2.0.4.el"
+DOCS="AUTHORS NEWS TODO"
+
+src_install() {
+ elisp_src_install
+ doinfo chess.info
+ insinto "${SITEETC}/${PN}"
+ doins chess-eco.fen chess-polyglot.bin
+ doins -r "${WORKDIR}"/{sounds,pieces}
+}