summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-08-22 07:52:52 +0200
committerHans de Graaff <graaff@gentoo.org>2016-08-22 07:52:52 +0200
commit215db542f32cf4312012d276e2fc46e0e13b01e6 (patch)
treed2c00699042a327870a06ff29085c06efb3e858b /app-emacs/dash/dash-2.13.0.ebuild
parentwww-apps/nanoc: add 4.3.0 (diff)
downloadgentoo-215db542f32cf4312012d276e2fc46e0e13b01e6.tar.gz
gentoo-215db542f32cf4312012d276e2fc46e0e13b01e6.tar.bz2
gentoo-215db542f32cf4312012d276e2fc46e0e13b01e6.zip
app-emacs/dash: add 2.13.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emacs/dash/dash-2.13.0.ebuild')
-rw-r--r--app-emacs/dash/dash-2.13.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/dash/dash-2.13.0.ebuild b/app-emacs/dash/dash-2.13.0.ebuild
new file mode 100644
index 000000000000..329b30522688
--- /dev/null
+++ b/app-emacs/dash/dash-2.13.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A modern list library for Emacs"
+HOMEPAGE="https://github.com/magnars/dash.el"
+SRC_URI="https://github.com/magnars/dash.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${PN}.el-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="dash.texi"
+DOCS="README.md"
+
+src_test() {
+ ./run-tests.sh || die
+}