summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-06 00:31:38 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-06 15:06:50 +0100
commite180ace83972615b419c7aa99b52b1abd305603b (patch)
tree9ac3ab04881044e0d28622ad66673096f6e145fd /app-emacs/diff-hl
parentnet-libs/ngtcp2: drop 0.11.0, 0.12.0 (diff)
downloadgentoo-e180ace83972615b419c7aa99b52b1abd305603b.tar.gz
gentoo-e180ace83972615b419c7aa99b52b1abd305603b.tar.bz2
gentoo-e180ace83972615b419c7aa99b52b1abd305603b.zip
app-emacs/diff-hl: bump to 1.9.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/diff-hl')
-rw-r--r--app-emacs/diff-hl/Manifest1
-rw-r--r--app-emacs/diff-hl/diff-hl-1.9.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/diff-hl/Manifest b/app-emacs/diff-hl/Manifest
index b9cd6350eeac..7033904e561d 100644
--- a/app-emacs/diff-hl/Manifest
+++ b/app-emacs/diff-hl/Manifest
@@ -1,2 +1,3 @@
DIST diff-hl-1.8.8_p20220405.tar.gz 241924 BLAKE2B 316326eaca5e37155665436e923b9c8fa2a05cee6cf37bdb4c8538dc2ca8575fa7eff736e125b063c92abc0365c42743907f01edcfb7df2837f58bb2cad2a62e SHA512 4055699146f4244863c2be05a2196db7c51de16c9403ddad926b93b6be87b704efba1b578c2570d25a6e4da2d73863f8298691e26d270513558200169da02e04
DIST diff-hl-1.9.0.tar.gz 242125 BLAKE2B 1dff9d601ba0dd8e117dc22de95dbdfa05ab14c0efecdcb7168061f760fa00b61c936fd1b3f0208d325336e3f7eb4f4c081e8b3b6db84799b45a56a73f3e8542 SHA512 fd82e22e685d2c51048acd3e339f0d7da9a1dc7ba49f64437b66dccaaf5b7bd93b9832eb37c56c0e9cbbe6dc058968e9a53c6e5dec398471fc79615ccce828fb
+DIST diff-hl-1.9.1.tar.gz 242182 BLAKE2B 5d4c718c9b1da142304687401589581147e4653e8adbf285a31cfd9369a9da8509129673a8d29cd4a14c7f6ba0c1cdc4a4e2635a57ae9357528672fd19b76be8 SHA512 f5090e0de5528ab4676c6710c9c758fce1d0a4075d18a62f00597d3d0d12690ef8e62b6e31f56f0ed87f9145dc0805b5854531179f3398f5f561e2dc66d78cdf
diff --git a/app-emacs/diff-hl/diff-hl-1.9.1.ebuild b/app-emacs/diff-hl/diff-hl-1.9.1.ebuild
new file mode 100644
index 000000000000..5b323cff93f5
--- /dev/null
+++ b/app-emacs/diff-hl/diff-hl-1.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=8f2e4eb345f0639c8fc41e3f7576f77ba6987655
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Highlight uncommitted changes, jump between and revert them selectively"
+HOMEPAGE="https://github.com/dgutov/diff-hl/"
+SRC_URI="https://github.com/dgutov/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-vcs/git )"
+
+DOCS=( README.md screenshot{,-dired,-margin}.png )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ebegin "Creating a git repository for tests"
+ git init "${S}" --initial-branch="master" &&
+ git add "${S}" &&
+ git config --local user.email "test@test" &&
+ git config --local user.name "test" &&
+ git commit --message "test" --quiet
+ eend $? || die
+ emake EMACS="${EMACS} ${EMACSFLAGS}" test
+}