summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-04 17:31:55 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-03-04 17:32:12 +0100
commitc2b503f8c56a2a9d7c11310191167e3404bcd9a0 (patch)
tree2b2e9184d9cc22b963486024bd0c5490d36a7d84 /app-emacs/eglot
parentapp-emacs/external-completion: new package; add 0.1 (diff)
downloadgentoo-c2b503f8c56a2a9d7c11310191167e3404bcd9a0.tar.gz
gentoo-c2b503f8c56a2a9d7c11310191167e3404bcd9a0.tar.bz2
gentoo-c2b503f8c56a2a9d7c11310191167e3404bcd9a0.zip
app-emacs/eglot: bump to 1.11
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/eglot')
-rw-r--r--app-emacs/eglot/Manifest1
-rw-r--r--app-emacs/eglot/eglot-1.11.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/eglot/Manifest b/app-emacs/eglot/Manifest
index 5a085a9ce376..22fa75572fe9 100644
--- a/app-emacs/eglot/Manifest
+++ b/app-emacs/eglot/Manifest
@@ -1,3 +1,4 @@
+DIST eglot-1.11.tar.xz 36900 BLAKE2B 20496e37944127c0e209762d2455fad01e6578fd1fa8350cc1a6782ed3e5dc11b09f8b737cd97d5439ab7ef67caa5cdf725d53d2e9e91bbca10223106a9073ad SHA512 c258c89d8c81b1c1df8ea9798c120a7534c174ce435a4551f503c7477520619ac08bd627372033ed1740dfc67bf7e8004751259769844d6be9adc9411d8ae5ac
DIST eglot-1.6.tar.gz 288078 BLAKE2B a2214d216d0eeaca32d974c6686696dfcf141b3384741bc8cce0d02abb508eb5713933bc227d12a07f4b87fc34601431845b1b8e519538ae04ecc74b24db4004 SHA512 51227c8e2b0a1dd9a63ededbea592f01616ff728c34c330400c078212fef3f3e747e6dd30ba312523cbe60c7ea663a7af9d83300210cf331ea6162d2db5c7e41
DIST eglot-1.8.tar.gz 302450 BLAKE2B 7247b11adaf9a65a2e071ca17b55038fe85f5842fb4155b44dbfa82bae5774e4cd2f7a5557d40cb1a7ab7f554233f15abe297e10568a1630b464ab6a600d978f SHA512 0295eff6dfbbf9d7a82349b8e5ed9e7dad700f2f0bfcab879d906e30bfbb4d28b8779fd9076108ac9b1594a60ca5e30c5035e2f8ceae44add99c28a843027609
DIST eglot-1.9.tar.gz 316541 BLAKE2B 5b9f188ae3f2b26fd7bb95aeb3095fbf5a78f6a15eeccaceaf947f5f91e78253622d2c81d5e57f11762c0370baf9d6c856a4f770c2652840d750f98ee780b418 SHA512 961399e0877a09bd292424715c3fac86e7750e144ba302e61262925b6ded1d30c6ebf3e63067b27b56fa2062461a947425951ac5538e25312d179fa20bd68b79
diff --git a/app-emacs/eglot/eglot-1.11.ebuild b/app-emacs/eglot/eglot-1.11.ebuild
new file mode 100644
index 000000000000..4c3f5fa8f297
--- /dev/null
+++ b/app-emacs/eglot/eglot-1.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.3
+
+inherit elisp
+
+DESCRIPTION="A minimal Emacs LSP client"
+HOMEPAGE="https://github.com/joaotavora/eglot/
+ https://elpa.gnu.org/packages/eglot.html"
+SRC_URI="https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-emacs/external-completion"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file "${S}"/${PN}-autoload.el "${S}"/
+ elisp_src_install
+}