summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-18 23:18:27 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-18 23:27:25 +0200
commitdb761fac64ff64da8a8672b19f92993ecf978ec0 (patch)
tree2f7f1baa1e387d35befb5817d50a5c2cf9b892fa /app-emacs/elfeed-protocol
parentsci-electronics/nvc: bump to 1.10.3 (diff)
downloadgentoo-db761fac64ff64da8a8672b19f92993ecf978ec0.tar.gz
gentoo-db761fac64ff64da8a8672b19f92993ecf978ec0.tar.bz2
gentoo-db761fac64ff64da8a8672b19f92993ecf978ec0.zip
app-emacs/elfeed-protocol: bump to 0.9.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/elfeed-protocol')
-rw-r--r--app-emacs/elfeed-protocol/Manifest1
-rw-r--r--app-emacs/elfeed-protocol/elfeed-protocol-0.9.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/elfeed-protocol/Manifest b/app-emacs/elfeed-protocol/Manifest
index 61cad9f82c06..b1e15e412eb7 100644
--- a/app-emacs/elfeed-protocol/Manifest
+++ b/app-emacs/elfeed-protocol/Manifest
@@ -1 +1,2 @@
DIST elfeed-protocol-0.8.1.tar.gz 48250 BLAKE2B 9a6491c29b1fe64bc7ced8e94548552b85b501279e60173bca0a8a11e5b624a17a51cdb035139620905ecde0c7c4dab0fed7a00f869af823123ca69c12dcfdc6 SHA512 846c39766d9312b3612b9d27ebe88e2aac153b2a3cd1683438b696004aaa4cb6d250b876c9669bf63a17a6fc6aaa6a0980550e962b19ab85268d6214ad4a022f
+DIST elfeed-protocol-0.9.0.tar.gz 48646 BLAKE2B cffb43799f9909a7c194d24ae490afcdcc7d9ae789b047ac90d9d4a6d1c014deedd5cc3d4a18cca7b643c07b2a297ece5fc8058651e531b9ee9da2572eb1152b SHA512 d9d1f130453a3759ca008153634bb6a768f757df22fdde6f39c397e9605eef335dc192f05c04a94f71123d24a8055acb9c7fc37350bd0b533cd9caf3c2602c9b
diff --git a/app-emacs/elfeed-protocol/elfeed-protocol-0.9.0.ebuild b/app-emacs/elfeed-protocol/elfeed-protocol-0.9.0.ebuild
new file mode 100644
index 000000000000..1fd5f3db4117
--- /dev/null
+++ b/app-emacs/elfeed-protocol/elfeed-protocol-0.9.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Provide extra news client subscription protocols for elfeed"
+HOMEPAGE="https://github.com/fasheng/elfeed-protocol/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fasheng/${PN}.git"
+else
+ SRC_URI="https://github.com/fasheng/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="app-emacs/elfeed"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert-runner test